CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

2D VAWT pimpleDymFoam - strange flow behavior

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 25, 2013, 19:39
Default 2D VAWT pimpleDymFoam - strange flow behavior
  #1
New Member
 
Join Date: Jul 2013
Posts: 1
Rep Power: 0
VAWT is on a distinguished road
Dear Foamers

We are trying to model a three-bladed vertical-axis wind turbine with OpenFOAM, using the pimpleDymFoam solver. We have observed some strange flow behavior (very high speeds near the leading edge) at one of the blades. Initially the problem appeared running a simulation at 300rpm so we decided to run a trial with a very small rotation movement (around 0.01 per second). We also ran a reference case with a rotation speed of 0/second. Free-stream velocity is 60m/s.

Much to our surprise, the result is quite different for blade number 3 in the 0.01/s and 0/s case. All the numerical settings and simulation conditions are identical for both simulations. The attached figure shows the flow speed around the three blades (maximum velocity on the right column has been rescaled for easier comparison but the real maximum speed is about 150m/s). For the first two blades the difference between the non-rotating and slowly rotating models is small. For the third blade there is an unreasonably large difference. Note that the colour scale for the rotating case has been truncated.

Does someone have any idea about the origin of this problem? Could this be a bug in the pimpleDyMFoam solver or in the AMI? Any help or suggestions would be much appreciated.
Attached Images
File Type: jpg VAWT_Blades_OF.jpg (56.6 KB, 40 views)
VAWT is offline   Reply With Quote

Old   April 23, 2014, 06:00
Default
  #2
New Member
 
carsten fuetterer
Join Date: Dec 2013
Location: Potsdam/Berlin
Posts: 7
Rep Power: 3
carstenf is on a distinguished road
Hi,
did you solved the problem? I have the same issue

best regards
carstenf is offline   Reply With Quote

Old   April 23, 2014, 06:27
Default
  #3
New Member
 
Juanito
Join Date: Oct 2010
Posts: 27
Rep Power: 6
Aerospace is on a distinguished road
It was a stupid error, I used fixedValue for the velocity at blade wall instead of movingWall.

Regards
Aerospace is offline   Reply With Quote

Old   April 23, 2014, 08:01
Default
  #4
New Member
 
carsten fuetterer
Join Date: Dec 2013
Location: Potsdam/Berlin
Posts: 7
Rep Power: 3
carstenf is on a distinguished road
ahh, thank you very much for that quick reply, that solved my problem too.

best regards
carstenf is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Poiseuille flow: strange behaviour samiam1000 OpenFOAM 6 February 17, 2013 04:31
Behavior of k and epsilon in a channel flow mn1363 Main CFD Forum 1 January 11, 2013 12:49
Strange Behavior of A Mesh Run at Two Dfferent Velocities Using Turbulence Model zachnap Main CFD Forum 0 May 11, 2011 15:22
very strange behavior of residuals Mohammad El-Alti CD-adapco 0 March 30, 2007 04:28
computation about flow around a yawed cone Tylor Xie Main CFD Forum 0 June 9, 1999 07:33


All times are GMT -4. The time now is 13:09.