CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

Problems with mesh motion in parallel

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 2, 2007, 09:26
Default I encountered a problem when d
  #1
New Member
 
Thomas Gallinger
Join Date: Mar 2009
Posts: 28
Rep Power: 7
thomas is on a distinguished road
I encountered a problem when doing mesh motion in parallel.

When I run the tutorial case movingCone, using the icoDyMFoam solver, and do a domain decomposition having 2 domains in y-direction, the number of iterations for solving motionUx/Uy/Uz increases by a factor of 10 or more compared to solving in seriell. Also, the motion solver now solves for motion in z-direction, although it's a 2-dimensional problem and 2d-motion is set to yes.
And, in some time steps the maximum number of iterations is reached.

Solving for the fields U and p, there's not much difference between seriell and parallel runs.

Using 4 domains, the behavior is similar.

I am doing the simple method and use the developer version 280307 from the fsb server.

I know that using 2 or more processors for 2000 elements does not really make sense, but I do not understand this behavior and would like to know where it comes from.

Thank you very much!
thomas is offline   Reply With Quote

Old   July 4, 2007, 02:07
Default Does no one have an idea? Shou
  #2
New Member
 
Thomas Gallinger
Join Date: Mar 2009
Posts: 28
Rep Power: 7
thomas is on a distinguished road
Does no one have an idea? Should I give more details?

Thank's very much!
thomas is offline   Reply With Quote

Old   July 4, 2007, 02:25
Default I used parallel mesh motion wi
  #3
Senior Member
 
Francesco Del Citto
Join Date: Mar 2009
Location: Zürich Area, Switzerland
Posts: 209
Rep Power: 8
fra76 is on a distinguished road
I used parallel mesh motion with 3D cases, both with OF 1.3 and OF 1.4, and I didn't notice this kind of problems...

Which version are you using? There are a lot of changes in the mesh motion libraries between 1.3 and 1.4 ...
fra76 is offline   Reply With Quote

Old   July 4, 2007, 02:48
Default I tried the official OF 1.3 an
  #4
New Member
 
Thomas Gallinger
Join Date: Mar 2009
Posts: 28
Rep Power: 7
thomas is on a distinguished road
I tried the official OF 1.3 and the 2 developer versions available from the FSB-web site. I did not try OF 1.4

I also did mesh motion in parallel on large problems with 100.000 to 500.000 cells, here it was no problem, but in the tutorial case with only 2000 cells the behavior is strange.

I am using the tetDecompositionMotionSolver, which is based on a node-mesh (FE), as I think.
thomas is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Motion diffusivity solver has problems with patches moving toward each other bfa OpenFOAM Running, Solving & CFD 2 July 8, 2009 21:35
Mesh motion independent mesh regions philippose OpenFOAM Running, Solving & CFD 12 August 5, 2008 16:16
Mesh motion Samuel CFX 2 October 1, 2007 10:48
Oscillatory mesh motion setup mesh flux ERROR jaswi OpenFOAM Running, Solving & CFD 5 August 23, 2007 04:41
expirience with deforming mesh/mesh motion Js CFX 0 May 28, 2007 07:11


All times are GMT -4. The time now is 07:06.