CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

OpenFOAM 1.5 dev

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 26, 2010, 04:36
Default
  #61
Member
 
Andre Z
Join Date: Dec 2009
Posts: 32
Rep Power: 6
LVDH is on a distinguished road
Hi,
I got the same paraFoam problem. But I found a simple workaround.
Since I got OpenFOAM 1.6 installed as well as the 1.5-dev version thanks to the help I got here I use the paraFoam I got from OF 1.6.

As I stated in the beginning of this thread I source the OF-bashes with aliases I set in $HOME/.bashrc. I got an "ofoam" command to source OF 1.6 and a "devfoam" command to source 1.5-dev.

So after a 1.5-dev calculation is finished I start a new bash and source OF 1.6 with "ofoam" after that I run "paraFoam".

This works but I am not completely happy. When I find the time I will figure out how to install Paraview by myself but still use the paraFoam command. That way I hope I will be able to use the python commands Paraview offers which you apparently cannot use with the Paraview that comes with OF 1.6.
LVDH is offline   Reply With Quote

Old   February 26, 2010, 04:59
Default
  #62
New Member
 
maja ondracka
Join Date: Apr 2009
Location: Slovenia
Posts: 17
Rep Power: 7
maja is on a distinguished road
Hi,
I also still have OF1.6 on another directory, which worked perfectly, including paraFoam. But I do not know how to do all this with aliases. I just changed the bashrc the way it works with OF1.5-dev and I do not use OF1.6 at the moment. Maybe you can give me a hint?

And I would really like to use paraFoam with this version of OF as many others would too, I think.

Regards, Maja
maja is offline   Reply With Quote

Old   February 26, 2010, 05:26
Default
  #63
ngj
Senior Member
 
Niels Gjoel Jacobsen
Join Date: Mar 2009
Location: Rotterdam, The Netherlands
Posts: 1,534
Rep Power: 23
ngj will become famous soon enoughngj will become famous soon enough
Hi Maja

In stead of a direct source, type the following in your .bashrc:

alias source15dev=`. $HOME/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc`
alias source16=`. $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc`

then you can type either source15dev or source16 depending on the version to use. Off course you can choose whatever alias you want.

Best regards,

Niels
ngj is offline   Reply With Quote

Old   February 26, 2010, 05:49
Default
  #64
Senior Member
 
Pavan
Join Date: May 2009
Location: Melbourne
Posts: 101
Rep Power: 7
rieuk is on a distinguished road
Well paraview3.3 works with OF-1.5-dev for me but the reader (PV3FoamReader) does not. Hence paraFoam opens paraview but can't read the file. So, like Phil I've resorted to using foamToVTK and opening paraview to view results. Of course sourcing the OF1.6 right after a computation is another option.

Both are hassles though especially when I'm trying to get a mesh right, by editing the polymesh file and rechecking over and over..
rieuk is offline   Reply With Quote

Old   March 1, 2010, 08:42
Default
  #65
New Member
 
maja ondracka
Join Date: Apr 2009
Location: Slovenia
Posts: 17
Rep Power: 7
maja is on a distinguished road
Hi,
I did what Niels wrote, but each time OF-1.5-dev started, no matter what I did. So, there must have been some other garbage left somewhere. So, fortunately I am using two computers. I decided that for the moment on one of them I will be running OF1.6 with paraFoam and on the other OF-1.5-dev. I cleand up, installed once again. I am really sick of it. And besides OF-1.6 paraFoam complains starting if there is ggi as a boundary condition...

Thanks for help anyway.

Regards, Maja
maja is offline   Reply With Quote

Old   March 1, 2010, 08:46
Default
  #66
Senior Member
 
Pavan
Join Date: May 2009
Location: Melbourne
Posts: 101
Rep Power: 7
rieuk is on a distinguished road
Hmm from what I understand, GGI isn't fully working yet in OF1.6 which is why most people go for 1.5-dev.

What do you mean by "but each time OF-1.5-dev started" ?
rieuk is offline   Reply With Quote

Old   March 1, 2010, 08:52
Default
  #67
ngj
Senior Member
 
Niels Gjoel Jacobsen
Join Date: Mar 2009
Location: Rotterdam, The Netherlands
Posts: 1,534
Rep Power: 23
ngj will become famous soon enoughngj will become famous soon enough
Hi Maja

The following might make a difference, as the `-thing surrounding the alias should actually be a '.
Sorry for any confusion.

Best regards,

Niels
ngj is offline   Reply With Quote

Old   March 1, 2010, 08:53
Default
  #68
Member
 
Andre Z
Join Date: Dec 2009
Posts: 32
Rep Power: 6
LVDH is on a distinguished road
Hi,
your problems both have easy solutions.

First of all you should use two different bashes.
I do not know what Linux Distro you are using but OpenSuse has tabs when you use the bash so its not that uncomfortable using the two bashes. In one bash you source the dev version and in the other you source the 1.6 version.
You can switch between the bashes with the shift key plus one of the left or right courser keys. I would guess other distros have similar solutions.

The problem with the crashing Paraview when using GGi is also easily solved:
In your boundaryfiles include values after the ggi part. For example in the U file include this:

Code:
INTERFACE_ausstroemer
    {
    type        ggi;
    value       uniform (0 0 0);
    }
This value does nothing to your calculations. Its just to prevents Paraview from crashing.
LVDH is offline   Reply With Quote

Old   March 1, 2010, 08:54
Default
  #69
New Member
 
maja ondracka
Join Date: Apr 2009
Location: Slovenia
Posts: 17
Rep Power: 7
maja is on a distinguished road
Hi,
I know ggi does not work in OF-1.6. That`s the reason I went for OF-1.5-dev, too. But I would also like to check the mesh. So, I have to change my boundary condition in order to start paraFoam. Am I wrong?

I tried to add into /.bashrc those two lines Niels wrote:
alias source15dev=`. $HOME/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc`
alias source16=`. $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc`

Of course I commented . $HOME/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc`

but even when I typed source16, OF-1.5-dev started.

Regards, Maja
maja is offline   Reply With Quote

Old   March 1, 2010, 08:57
Default
  #70
New Member
 
maja ondracka
Join Date: Apr 2009
Location: Slovenia
Posts: 17
Rep Power: 7
maja is on a distinguished road
Thank you, Andre.
I will try this now. I hope (I believe) this will work.
Thanks again, Maja
maja is offline   Reply With Quote

Old   March 1, 2010, 09:14
Default
  #71
Member
 
Andre Z
Join Date: Dec 2009
Posts: 32
Rep Power: 6
LVDH is on a distinguished road
Hi,
I think you should show us your complete $HOME/.bashrc.

You are doing something wrong.
LVDH is offline   Reply With Quote

Old   March 1, 2010, 09:24
Default
  #72
New Member
 
maja ondracka
Join Date: Apr 2009
Location: Slovenia
Posts: 17
Rep Power: 7
maja is on a distinguished road
With pleasure. I am not at all experienced in Linux, as you can see. So, it really takes me a lot of time and I really appreciate your help.

Here it is:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# don't overwrite GNU Midnight Commander's setting of `ignorespace'.
export HISTCONTROL=$HISTCONTROL${HISTCONTROL+,}ignoredups
# ... or force ignoredups and ignorespace
export HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
# We have color support; assume it's compliant with Ecma-48
# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
# a case would tend to support setf rather than setaf.)
color_prompt=yes
else
color_prompt=
fi
fi

if [ "$color_prompt" = yes ]; then
PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
;;
*)
;;
esac

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

#if [ -f ~/.bash_aliases ]; then
# . ~/.bash_aliases
#fi

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
eval "`dircolors -b`"
alias ls='ls --color=auto'
#alias dir='dir --color=auto'
#alias vdir='vdir --color=auto'

#alias grep='grep --color=auto'
#alias fgrep='fgrep --color=auto'
#alias egrep='egrep --color=auto'
fi

# some more ls aliases
#alias ll='ls -l'
#alias la='ls -A'
#alias l='ls -CF'

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ]; then
. /etc/bash_completion
fi
export SHELL=/bin/bash
#source /home/maja/OpenFOAM/OpenFOAM-1.5/etc/bashrc
export PATH=/usr/local/Trolltech/Qt-4.3.5/bin:$PATH
export LD_LIBRARY_PATH=/usr/local/Trolltech/Qt-4.3.5/lib:$LD_LIBRARY_PATH

#. $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc
. $HOME/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc

#alias source15=`. /home/maja/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc`
#alias source16=`. /home/maja/OpenFOAM/OpenFOAM-1.6/etc/bashrc`

export PATH=$PATH\:$HOME/OpenFOAM/OpenFOAM-1.5-dev/wmake


Regards
maja is offline   Reply With Quote

Old   March 1, 2010, 09:40
Default
  #73
ngj
Senior Member
 
Niels Gjoel Jacobsen
Join Date: Mar 2009
Location: Rotterdam, The Netherlands
Posts: 1,534
Rep Power: 23
ngj will become famous soon enoughngj will become famous soon enough
Hi Maja

First of all you are adding a specific part of 1.5-dev to your PATH, why do you see that? See:

export PATH=$PATH\:$HOME/OpenFOAM/OpenFOAM-1.5-dev/wmake

Further, try to replace the following lines:

#. $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc
. $HOME/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc

#alias source15=`. /home/maja/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc`
#alias source16=`. /home/maja/OpenFOAM/OpenFOAM-1.6/etc/bashrc`

with these (copy paste from my own, so rename according to your wishes):

alias source15='. $HOME/OpenFOAM/OpenFOAM-1.5.x/etc/bashrc'
alias source16='. $HOME/OpenFOAM/OpenFOAM-1.6.x/etc/bashrc'
alias sourceDEV='. $HOME/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc'

You have not un-commented the 1.5-dev, is that the source of the error or is it just from your working version of .bashrc?

Best regards,

Niels
ngj is offline   Reply With Quote

Old   March 1, 2010, 10:39
Default
  #74
New Member
 
maja ondracka
Join Date: Apr 2009
Location: Slovenia
Posts: 17
Rep Power: 7
maja is on a distinguished road
Thanks Niels, it works perfectly now!!

Regards, Maja
maja is offline   Reply With Quote

Old   March 1, 2010, 10:59
Default
  #75
ngj
Senior Member
 
Niels Gjoel Jacobsen
Join Date: Mar 2009
Location: Rotterdam, The Netherlands
Posts: 1,534
Rep Power: 23
ngj will become famous soon enoughngj will become famous soon enough
I am glad. Happy Foaming.

/ Niels
ngj is offline   Reply With Quote

Old   March 1, 2010, 15:10
Default
  #76
Senior Member
 
Herman
Join Date: Nov 2009
Posts: 122
Rep Power: 6
enry is on a distinguished road
Hi everyone.
I have installed OpenFOAM 1.5-dev following your advice.
As LVHD suggested, since I got OpenFOAM 1.6 installed as well as the 1.5-dev version, I use the paraFoam I got from OF 1.6.
Have you solved this problem?
Thanks in advance.
Enry.
enry is offline   Reply With Quote

Old   March 20, 2010, 08:45
Default
  #77
Senior Member
 
Pavan
Join Date: May 2009
Location: Melbourne
Posts: 101
Rep Power: 7
rieuk is on a distinguished road
Hey guys, I'm trying now to install 1.5-dev onto Scientific Linux (on a cluster server) and am getting the following errors:

-lmeshTools -lODE -lfiniteVolume -ldynamicMesh -lOpenFOAM -liberty -ldl -lm -o /nfs/monash/home/pbil1/OpenFOAM/OpenFOAM-1.5-dev/applications/bin/linux64GccDPOpt/blockMesh
/usr/bin/ld: cannot find -liberty
collect2: ld returned 1 exit status
make[3]: *** [/nfs/monash/home/pbil1/OpenFOAM/OpenFOAM-1.5-dev/applications/bin/linux64GccDPOpt/blockMesh] Error 1
make[2]: *** [blockMesh] Error 2

Looks like I'm missing some kind of compiler. The cluster uses a module load system - any ideas what module I would need?
rieuk is offline   Reply With Quote

Old   March 20, 2010, 09:33
Default
  #78
ngj
Senior Member
 
Niels Gjoel Jacobsen
Join Date: Mar 2009
Location: Rotterdam, The Netherlands
Posts: 1,534
Rep Power: 23
ngj will become famous soon enoughngj will become famous soon enough
Hi

Running on ordinary linux, I needed to install "binutils-dev" as it provides /usr/libiberty.a which is the library you are missing.

I hope it helps,

Niels
ngj is offline   Reply With Quote

Old   March 24, 2010, 00:56
Default Paraview (visualization) problem
  #79
Member
 
MSarkar
Join Date: Dec 2009
Posts: 99
Rep Power: 6
msarkar is on a distinguished road
Quote:
Originally Posted by norman1981 View Post
Ok, I see..
I suggest you these steps starting from a clean install (delete all the no 1.6 ThirdParty folders you have and the OpenFOAM-1.5-dev folder) trying to isolate the problem:
0- Check you have installed in your distro these packages:
binutils gcc flex bison bisonc++ build-essential
and the packages relative to mpi
1- Comment all the 1.6## reference in your .bashrc file
2- Add to the .bashrc file these lines:
---
. $HOME/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc
export PATH=$PATH\:$HOME/OpenFOAM/OpenFOAM-1.5-dev/wmake
---
3- type:
cd $HOME/OpenFOAM
wget http://mesh.dl.sourceforge.net/sourc...y.General.gtgz
wget http://mesh.dl.sourceforge.net/sourc....linuxGcc.gtgz
svn co https://openfoam-extend.svn.sourcefo...enFOAM-1.5-dev
tar xzf ThirdParty.General.gtgz
tar xzf ThirdParty.linuxGcc.gtgz
source ~/.bashrc
foam
./Allwmake >&log

Regards
Norman
Hi Norman,

I was having some problem to install OF-1.5-dev but following your instruction I successfully installed it and ran a test case. Thanks a lot for your post. Now I have one problem to visualize my results. Somehow, paraview is not installed. When I am trying to open paraview using command paraFoam, it says paraview not found. Could you please suggest something for this? I would appreciate your help!

Thanks!
M. Sarkar
msarkar is offline   Reply With Quote

Old   March 25, 2010, 00:06
Default Problem during OF-1.5-dev installing
  #80
Member
 
MSarkar
Join Date: Dec 2009
Posts: 99
Rep Power: 6
msarkar is on a distinguished road
Hi All,

I followed Norman's instruction and trying to install OF-1.5-dev version for last couple of days but without any success. First I downloaded ThirdParty.General.gtz and ThirdPartylinux64Gcc.gtgz then I downloaded OpenFOAM-1.5-dev. Untar everything and it works fine untill I ran Allwmake. While running Allwmake, it is giving error. The error message is attached below. If anyone has any clue, please help me.

Some more information regarding my proble - when I first time followed Norman's instruction, I was able to install it properly and ran a solver but I was not able to view result because the ThirdParty binary files were for 32 bit machine whereas my machine is 64 bit. So,I downloaded the ThirdParty files for 64 bit and now I am trying to recompile OF-1.5-dev but it is not compiling, giving thesome error. Part of the error message during compilation is attached below. Please provideme some clue how to get out of this problem.
Attached Files
File Type: zip message during compilation.zip (7.2 KB, 7 views)
msarkar is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Paraview/Parafoam in OpenFoam 1.5 dev titio OpenFOAM Post-Processing 0 December 9, 2009 12:13
Paraview/Parafoam in OpenFoam 1.5 dev titio OpenFOAM Paraview & paraFoam 0 December 9, 2009 12:12
OpenFOAM 1.5 installation on OpenSUSE 11.0 bigphil OpenFOAM Installation 16 April 29, 2009 06:28
Problem installing OpenFOAM 1.5 installation on RHEL 4. vwsj84 OpenFOAM Installation 4 April 23, 2009 04:48
OpenFOAM Version 1.5 Released OpenFOAM discussion board administrator OpenFOAM Announcements from ESI-OpenCFD 0 July 14, 2008 18:22


All times are GMT -4. The time now is 20:45.