CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

splitMesh Error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 17, 2010, 19:16
Default splitMesh Error
  #1
Member
 
Robin Gilbert
Join Date: Jan 2010
Posts: 66
Rep Power: 8
robingilbert is on a distinguished road
Hello guys,

I ran splitMesh on an internal surface and it worked fine. I want to run splitMesh on another surface which is surrounded by the previous surface. I tried running splitMesh but it gave the following error:

Code:
Create time

Create polyMesh for time = 0

Read 226 faces to split



--> FOAM FATAL ERROR: 
Can not find faces using edge (61716 68018) on cell 168913

    From function meshTools::getEdgeFaces(const primitiveMesh&, const label, const label, label&, label&
    in file meshTools/meshTools.C at line 513.

FOAM aborting

#0  Foam::error::printStack(Foam::Ostream&) in "/home/robingilbert/OpenFOAM/robingilbert-1.6.x/lib/linux64GccDPOpt/libOpenFOAM.so"
#1  Foam::error::abort() in "/home/robingilbert/OpenFOAM/robingilbert-1.6.x/lib/linux64GccDPOpt/libOpenFOAM.so"
#2  Foam::regionSide::otherFace(Foam::primitiveMesh const&, int, int, int) in "/home/robingilbert/OpenFOAM/robingilbert-1.6.x/applications/bin/linux64GccDPOpt/splitMesh"
#3  Foam::regionSide::walkAllPointConnectedFaces(Foam::primitiveMesh const&, Foam::HashSet<int, Foam::Hash<int> > const&, Foam::HashSet<int, Foam::Hash<int> > const&) in "/home/robingilbert/OpenFOAM/robingilbert-1.6.x/applications/bin/linux64GccDPOpt/splitMesh"
#4  Foam::regionSide::regionSide(Foam::primitiveMesh const&, Foam::HashSet<int, Foam::Hash<int> > const&, Foam::HashSet<int, Foam::Hash<int> > const&, int, int) in "/home/robingilbert/OpenFOAM/robingilbert-1.6.x/applications/bin/linux64GccDPOpt/splitMesh"
#5  main in "/home/robingilbert/OpenFOAM/robingilbert-1.6.x/applications/bin/linux64GccDPOpt/splitMesh"
#6  __libc_start_main in "/lib/libc.so.6"
#7  _start at /build/buildd/eglibc-2.10.1/csu/../sysdeps/x86_64/elf/start.S:116
Aborted
Please help me out. this is very important
robingilbert is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile problem ivanyao OpenFOAM Running, Solving & CFD 1 October 12, 2012 09:31
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
Compiling problems with hello worldC fw407 OpenFOAM Installation 21 January 6, 2008 18:38
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31


All times are GMT -4. The time now is 22:37.