CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

temperature at time t=0: T=0K

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 19, 2011, 10:02
Default problem with start temperature at time t=0: T=0K
  #1
Senior Member
 
Join Date: Mar 2011
Posts: 155
Rep Power: 7
tH3f0rC3 is on a distinguished road
Time = 0


Solving for fluid region air
DILUPBiCG: Solving for Ux, Initial residual = 1, Final residual = 0.081617595, No Iterations 1
DILUPBiCG: Solving for Uy, Initial residual = 1, Final residual = 0.079375952, No Iterations 1
DILUPBiCG: Solving for Uz, Initial residual = 1, Final residual = 0.024770842, No Iterations 2
DILUPBiCG: Solving for h, Initial residual = 0.99999958, Final residual = 0.015671234, No Iterations 2
Min/max T:0.28089014 1073.15
GAMG: Solving for p_rgh, Initial residual = 1, Final residual = 0.0090209083, No Iterations 13
time step continuity errors : sum local = 0.0061858492, global = -0.00025520461, cumulative = -0.00025520461
Min/max rho:0.38292586 1602.3886
DILUPBiCG: Solving for epsilon, Initial residual = 0.17574746, Final residual = 0.016515494, No Iterations 1
DILUPBiCG: Solving for k, Initial residual = 1, Final residual = 0.02045702, No Iterations 2
maxResidual: 1 convergence criterion: 1e-05

Solving for solid region stahl
DICPCG: Solving for T, Initial residual = 1, Final residual = 0.064339172, No Iterations 3
Min/max T:0.086167946 23.333917
maxResidual: 1 convergence criterion: 0

Solving for solid region nickel
DICPCG: Solving for T, Initial residual = 0.99999928, Final residual = 0.095158884, No Iterations 3
Min/max T:572.99961 573
maxResidual: 0.99999928 convergence criterion: 0
ExecutionTime = 33.5 s ClockTime = 35 s


It is very strange, that the solver starts to solve the region stahl (solid1) and the region air at 0 Kelvin.
I have given the same boundary conditions as in the region nickel (solid2). In every boundaryfield is written value uniform 573.150024 (or a higher temperature9 and initialField is also set to 573.150024.

Does someone know the mistake?

Best regards,
tH3f0rC3

Last edited by tH3f0rC3; April 19, 2011 at 15:16.
tH3f0rC3 is offline   Reply With Quote

Old   April 21, 2011, 03:04
Default
  #2
Senior Member
 
Join Date: Mar 2011
Posts: 155
Rep Power: 7
tH3f0rC3 is on a distinguished road
Solved :-)

For everyone:
If you get an errormessage like the one above do the following:

Check the Setup of the fluid-solid interface. There was one point missing in my source-code -> hard to find...

Now it works
tH3f0rC3 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Moving mesh Niklas Wikstrom (Wikstrom) OpenFOAM Running, Solving & CFD 122 June 15, 2014 06:20
Modeling in micron scale using icoFoam m9819348 OpenFOAM Running, Solving & CFD 7 October 27, 2007 00:36
IcoFoam parallel woes msrinath80 OpenFOAM Running, Solving & CFD 9 July 22, 2007 02:58
AMG versus ICCG msrinath80 OpenFOAM Running, Solving & CFD 2 November 7, 2006 16:15
unsteady calcs in FLUENT Sanjay Padhiar Main CFD Forum 1 March 31, 1999 12:32


All times are GMT -4. The time now is 03:29.