CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

[ICEM] The pre-mesh quality is very good but the mesh quality is bad

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 27, 2012, 11:27
Question The pre-mesh quality is very good but the mesh quality is bad
  #1
lnk
Senior Member
 
lnk
Join Date: Feb 2011
Location: Switzerland
Posts: 118
Rep Power: 6
lnk is on a distinguished road
Hi everyone,

Here is my question about mesh generation by ICEM. My pre-mesh quality is very good by the button 'check pre-mesh quality' . But after I convert it to mesh, the mesh quality is very bad by the button 'display mesh quality'. Should I go back to block to redo my block to solve this problem? Or I can trust the 'pre-mesh quality' and run the case directly?

Best regards and many thanks,
lnk
lnk is offline   Reply With Quote

Old   July 28, 2012, 08:08
Default
  #2
Senior Member
 
Anna Tian's Avatar
 
Meimei Wang
Join Date: Jul 2012
Posts: 492
Rep Power: 7
Anna Tian is on a distinguished road
I also have this problem sometimes. You may check the Pre-mesh quality. It may also not good anymore. Sometimes if you save and close a project and then open again, something changes.
__________________
Best regards,
Meimei
Anna Tian is offline   Reply With Quote

Old   July 30, 2012, 12:32
Default
  #3
Senior Member
 
Ananthakrishnan.A.S
Join Date: Feb 2012
Location: Mumbai (Bombay), India
Posts: 141
Rep Power: 7
Ananthakrishnan is on a distinguished road
Send a message via Skype™ to Ananthakrishnan
Hi.
You dont have to necessarily redo the mesh. You can very well trust the pre mesh quality. Its because, ICEM does not check the mesh with the same parameters in structured (premesh) and unstructured cases(dislplay mesh quality).

Anna Tian,
I have never witnessed anything like that.. I think something else is happening.
Ananthakrishnan is offline   Reply With Quote

Old   July 30, 2012, 13:58
Default
  #4
Far
Super Moderator
 
Far's Avatar
 
Sijal Ahmed Memon (turboenginner@gmail.com)
Join Date: Mar 2009
Location: Islamabad Pakistan
Posts: 3,914
Blog Entries: 6
Rep Power: 38
Far will become famous soon enoughFar will become famous soon enough
Send a message via Skype™ to Far
Quote:
Originally Posted by Anna Tian View Post
I also have this problem sometimes. You may check the Pre-mesh quality. It may also not good anymore. Sometimes if you save and close a project and then open again, something changes.
I get this problem frequently. What I do is " I use to unchecke the solid and VORFN blocks" This always works for me
Far is offline   Reply With Quote

Old   July 30, 2012, 14:08
Default
  #5
Senior Member
 
Ananthakrishnan.A.S
Join Date: Feb 2012
Location: Mumbai (Bombay), India
Posts: 141
Rep Power: 7
Ananthakrishnan is on a distinguished road
Send a message via Skype™ to Ananthakrishnan
@ far,
is it?? but i read that it is not required to check the structured mesh quality after converting to unstructured mesh.. is it not enough if i just check the pre mesh
Ananthakrishnan is offline   Reply With Quote

Old   July 30, 2012, 14:11
Default
  #6
Far
Super Moderator
 
Far's Avatar
 
Sijal Ahmed Memon (turboenginner@gmail.com)
Join Date: Mar 2009
Location: Islamabad Pakistan
Posts: 3,914
Blog Entries: 6
Rep Power: 38
Far will become famous soon enoughFar will become famous soon enough
Send a message via Skype™ to Far
Question:
Quote:
Originally Posted by Anna Tian View Post
I also have this problem sometimes. You may check the Pre-mesh quality. It may also not good anymore. Sometimes if you save and close a project and then open again, something changes.
Response:
Quote:
Originally Posted by Far View Post
I get this problem frequently. What I do is " I use to unchecke the solid and VORFN blocks" This always works for me
Quote:
@ far,
is it?? but i read that it is not required to check the structured mesh quality after converting to unstructured mesh.. is it not enough if i just check the pre mesh
I always found that the premesh quality is same as I get in Fluent or CFX
Far is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No layers in a small gap bobburnquist OpenFOAM Native Meshers: snappyHexMesh and Others 2 November 25, 2012 09:54
Layers:problem with curvature giulio.topazio OpenFOAM Native Meshers: snappyHexMesh and Others 10 August 22, 2012 09:03
erroneous temps in conjugate model? sieginc. STAR-CCM+ 11 July 14, 2012 03:41
[ICEM] Tetra mesh quality before and after prism layer Chander ANSYS Meshing & Geometry 0 December 25, 2011 23:04
unstructured vs. structured grids Frank Muldoon Main CFD Forum 1 January 5, 1999 11:09


All times are GMT -4. The time now is 01:12.