CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > FLUENT

Why Fluent does not work on Linux?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 1, 2005, 07:02
Default Why Fluent does not work on Linux?
  #1
pzyss
Guest
 
Posts: n/a
Hello everyone! I have used Fluent on Windows for two years and now I want to work on linux.

I have installed Fluent6.2.16 on Redhat Linux and set PATH for bin. But when I run fluent, it does not work and prompt out the following line: "Error:directory /CFD/Fluent.Inc/fluent[0-9]* does not contain a valid arch. Set the environment variable FLUENT_ARCH and try again." Would anyone tell me what is the problem and what shall I do?
  Reply With Quote

Old   July 1, 2005, 09:59
Default Re: Why Fluent does not work on Linux?
  #2
vengi
Guest
 
Posts: n/a
Hai,

Be sure that your Fluent.Inc directory is available in /usr/local/. directory. The license file should be respective license folder. Then try to run /usr/local/Fluen.Inc/bin/(fluent or gambit).

All the best...
  Reply With Quote

Old   July 1, 2005, 11:25
Default Re: Why Fluent does not work on Linux?
  #3
pzyss
Guest
 
Posts: n/a
Thanks a lot, vengi!

Installing Fluent to a dir other than /usr/local/. will bring the error?

BTW, the edition of Redhat is newest, i.e. Redhat EA 4. And CPU is AMD 64 3000+.

  Reply With Quote

Old   July 1, 2005, 12:18
Default Re: Why Fluent does not work on Linux?
  #4
pUl|
Guest
 
Posts: n/a
You need to do certaing things after installing.. for starters type this at the bash prompt.

FLUENT_ARCH=lnx86 <Return>

export FLUENT_ARCH <Return>

The fluent user services center has a cool guide that walks you through the installation. Please read it.
  Reply With Quote

Old   July 1, 2005, 21:33
Default Re: Why Fluent does not work on Linux?
  #5
pzyss
Guest
 
Posts: n/a
Thanks, pUl|

It sounds reasonable. Should I also add these two lines to ~/.bash_profile? Or any where else.
  Reply With Quote

Old   July 1, 2005, 23:42
Default Re: Why Fluent does not work on Linux?
  #6
pUl|
Guest
 
Posts: n/a
yes, that would make life easier.
  Reply With Quote

Old   July 2, 2005, 09:06
Default Re: Why Fluent does not work on Linux?
  #7
pzyss
Guest
 
Posts: n/a
But the problem is still there. I am almost mad!
  Reply With Quote

Old   July 2, 2005, 09:54
Default Re: Why Fluent does not work on Linux?
  #8
mreg
Guest
 
Posts: n/a
you should add the following lines at the end of the /etc/profile file:

PATH=/<where is located>/Fluent.Inc/bin:$PATH export PATH # in case you use mozilla ;-) export FLUENT_HELP_BROWSER=mozilla <empty line>

then reboot, so that the path statement is re-read
  Reply With Quote

Old   July 2, 2005, 09:59
Default Re: Why Fluent does not work on Linux?
  #9
mreg
Guest
 
Posts: n/a
Sorry, some chars disappeared.

You should add the following lines at the end of the /etc/profile file:

PATH=/(where it is located)/Fluent.Inc/bin:$PATH

export PATH

# in case you use mozilla ;-)

export FLUENT_HELP_BROWSER=mozilla

(empty line at the end)

then reboot, so that the path statement is re-read
  Reply With Quote

Old   July 2, 2005, 15:40
Default Re: Why Fluent does not work on Linux?
  #10
pUl|
Guest
 
Posts: n/a
No, that might not solve your problem. All it does is add a path definition which will make your life easier by just typing 'fluent' instead of '/usr/local/Fluent.Inc/bin/fluent'

pzyss: To solve your problem, start fluent from the path in which it was installed. If I had to guess, this would be somewhere inside the /CFD directory structure for your case. Try to 'cd' all the way into the 'bin' subdirectory and execute fluent from there using ./fluent

PS: Oh, and by the way mreg, we don't reboot for everything in the *nix world.
  Reply With Quote

Old   July 2, 2005, 15:43
Default Re: Why Fluent does not work on Linux?
  #11
pUl|
Guest
 
Posts: n/a
Forgot to mention: add the path definitions to your .bash_profile and respawn a shell. There is no need to reboot.
  Reply With Quote

Old   July 2, 2005, 20:43
Default Re: Why Fluent does not work on Linux?
  #12
pUl|
Guest
 
Posts: n/a
Ok, here goes: An excerpt from the Fluent webpage:

What Linux Platform should I Download?

For the Linux + Pentium there are two download options:

1. Pentium+Linux (RHEL3/SLES9)

2. Pentium+Linux (SLES8)

In general, Pentium + Linux (RHEL3/SLES9) is for RedHat Enterprise3 and SuSe Linux Enterprise Server 9 and later. Pentium + Linux (SLES8) is for earlier versions, notably Red Hat 7 but it depends on your version of glibc.

To check which version you have with:

rpm -qa | grep glibc

if you get: glibc-2.3*************** download the RHEL3/SLES9 package

if you get glibc-2.2************** download the SLES8 package.

If you install ONLY lnx86_glibc22 version then fluent won't run and you will get the following error message:

Error: directory /.../Fluent.Inc/fluent[0-9]* does not contain a valid arch. Set the environment variable FLUENT_ARCH and try again.

This is because the part of bin/fluent script that checks for a valid arch happens before the rpm check for the glibc version and thus the arch is still "lnx86" at this point.

Resolution:

You can fix this by installing the RHEL3/SLES9 package in addition to the SLES8 package. (It does not matter which package you install first). Installing both packages also means that FLUENT will continue to work when you upgrade your operating system.

HTH

-pUl|
  Reply With Quote

Old   July 2, 2005, 20:43
Default Re: Why Fluent does not work on Linux?
  #13
pzyss
Guest
 
Posts: n/a
Yes, of cause I have cd into the bin dir and type fluent. But it do not work.
  Reply With Quote

Old   July 2, 2005, 21:22
Default Re: Why Fluent does not work on Linux?
  #14
pzyss
Guest
 
Posts: n/a
Thank you so much! -pUl|

I have check the version. The OS is RHEL4. However CPU is AMD ALTHLON 3000+. glibc version is 2.3. Fluent version is 64BIT 6.2.16.

You meanse I should download RHEL3/SLES9 package? RHEL3/SLES9 is just a package or a Linux version? I am wondering.

  Reply With Quote

Old   July 3, 2005, 02:51
Default Re: Why Fluent does not work on Linux?
  #15
pzyss
Guest
 
Posts: n/a
I have added the following two line in profile. The above problem has been solved.

FLUENT_ARCH=lnamd64 export FLUENT_ARCH

However, another error came out:

Warning: DISPLAY environment variable is not set. Graphics and GUI will not operate correctly without this being set properly. ......cortex.3.6.6:cannot execute binary file.

What is the problem come from and how to fix it?
  Reply With Quote

Old   July 3, 2005, 04:05
Default Re: Why Fluent does not work on Linux?
  #16
pzyss
Guest
 
Posts: n/a
Hi~~pUl|

The problem now reduced to : when I run fluent, the following lines come out: /CFD/Fluent.Inc/fluent6.2.16/cortex/lnamd64/cortex.3.6.6 -f fluent (fluent " -alnamd64 -path/CFD/Fluent.Inc") /CFD/Fluent.Inc/bin/fluent: line 3702: /CFD/Fluent.Inc/fluent6.2.16/cortex/lnamd64/cortex.3.6.6:cannot execute binary file.

What is the problem? Herhaps This is the last problem to be solved!
  Reply With Quote

Old   July 3, 2005, 14:48
Default Re: Why Fluent does not work on Linux?
  #17
pUl|
Guest
 
Posts: n/a
Are you really on a 64 bit architecture?
  Reply With Quote

Old   July 3, 2005, 20:26
Default Re: Why Fluent does not work on Linux?
  #18
pzyss
Guest
 
Posts: n/a
Yes! pUl| The CPU of my computer is AMD 64Bit Athlon 3000+. Are all version of Fluent higher than 6.2 on linux 64Bit? I think the problem is that the version of Fluent is sensitive of OS and Achitecture. For me I should use SuSU linux, not Redhat. I will have a try!
  Reply With Quote

Old   March 9, 2011, 12:35
Default
  #19
New Member
 
anonymous
Join Date: Jan 2011
Posts: 12
Rep Power: 6
calvin is on a distinguished road
hey pzyss
m facing similar problem ..
did u get thru it n how
pl help
calvin is offline   Reply With Quote

Old   February 2, 2013, 03:38
Default Setting environment variable for fluent arch in ubuntu 11.04
  #20
New Member
 
kumawat
Join Date: Feb 2012
Posts: 5
Rep Power: 5
kumawatnana is on a distinguished road
Hii
can anyone help me for Setting environment variable for fluent arch in ubuntu 11.04. i have installed fluent 6.3 (home/username/Fluent_lnc) in ubuntu 11.04 but when i start fluent i get error set fluent arch.

please help...
...kumavat
kumawatnana is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
fluent UDF on linux machine Min-Hua Wang Fluent UDF and Scheme Programming 6 June 29, 2013 08:41
Fluent - Linux vs Windows derick FLUENT 1 October 19, 2005 12:50
Running Fluent on Red Hat Linux WS version 4 Bob FLUENT 1 September 4, 2005 05:01
Mandrake Linux and Fluent... easycad FLUENT 1 February 15, 2005 11:09
linux or windows for FLUENT users peter gelblum FLUENT 3 December 27, 2002 17:19


All times are GMT -4. The time now is 23:18.