CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Bugs

Bug in PV3FoamReader

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 26, 2010, 09:21
Default Bug in PV3FoamReader
  #1
New Member
 
Matteo Carpentieri
Join Date: Mar 2009
Posts: 28
Rep Power: 8
mcarpe is on a distinguished road
Hi all

I may have found a bug in the paraFoam ParaView reader. I'm using OpenFoam 1.6.x with the packaged ParaView (3.6) from the ThirdParty directory.

When I visualise data from R (the Reynolds stress tensor) I believe ParaView picks up the wrong components.
The order of the 6-component array (symmTensorField) is intepreted by PV as Rxx Ryy Rzz Rxy Rxz Ryz, while the correct order in OpenFoam is Rxx Rxy Rxz Ryy Ryz Rzz.

For example: I'm trying to visualise the boundary conditions for the inlet patch, so I know the values in advance. And I know that R is something like this:

(<positive value> 0 <negative value> <positive value> 0 <positive value>)

This, in OpenFoam means: xx xy xz yy yz zz

When I try to visualise it with paraFoam, I see the correct values ONLY for xx. When i visualise yy i see all 0 values (like xy in the original data). When i visualise zz i see negative values (like xz in the original data) which is clearly wrong, since Rzz can't be negative. An so on...

Cheers,
Matteo
mcarpe is offline   Reply With Quote

Old   March 11, 2010, 08:22
Default
  #2
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 777
Rep Power: 18
olesen will become famous soon enough
This should now be fixed in the 1.6.x version.
olesen is offline   Reply With Quote

Old   March 11, 2010, 08:55
Default
  #3
New Member
 
Matteo Carpentieri
Join Date: Mar 2009
Posts: 28
Rep Power: 8
mcarpe is on a distinguished road
Quote:
Originally Posted by olesen View Post
This should now be fixed in the 1.6.x version.
Thanks a lot!
mcarpe is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Serious bug in LES interface fs82 OpenFOAM Bugs 21 November 16, 2009 09:15
bug in Rcomponents utility cedric_duprat OpenFOAM Bugs 1 May 7, 2009 02:56
Please report this bug egp OpenFOAM Installation 5 December 8, 2006 13:56
Bug reports Mattijs Janssens (Mattijs) OpenFOAM 0 January 10, 2005 11:05
Forum y2k Bug Jonas Larsson Main CFD Forum 1 January 5, 2000 11:22


All times are GMT -4. The time now is 07:26.