CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation on Windows, Mac and other Unsupported Platforms

OF 1.9 (aka OF 2.1) on Mac OS X

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree25Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   October 14, 2012, 17:11
Default
  #141
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,837
Rep Power: 38
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by wyldckat View Post
As for Open-MPI: apparently the instructions do not specify how to tell OpenFOAM and wmake which MPI version to be looking for
Since I don't have a Mac to confirm this... Please try this and let us know if it works:
  1. Edit OpenFOAM's "etc/bashrc" file.
  2. Find the line that defines "WM_MPLIB":
    Code:
    export WM_MPLIB=OPENMPI
  3. Set it to this:
    Code:
    export WM_MPLIB=SYSTEMOPENMPI
  4. Just in case, start a new terminal.
  5. Try running Allwmake once again, as instructed.
Best regards,
Bruno
Nothing I can add to Brunos recommendation (although I have a Mac). Except to set WM_MPLIB in a different file (pointed out in http://openfoamwiki.net/index.php/Ho...penMPI-version). I usually set stuff that is specific to my installation in those files (that's why it didn't show up in my patches) so that I don't have to mess with the sources
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 29, 2012, 16:55
Default
  #142
New Member
 
Nicola Donato
Join Date: Oct 2012
Posts: 9
Rep Power: 3
Nicrheo is on a distinguished road
Hello to all contributors,

I would like to thank the whole community for this post and your availability in helping people interested in OF.
I'm currently approaching for the first time to OF but I'm stuck in the installation process.
I'm trying to install it on MBP OSx Lion;
I followed the instructions in the wiki page onebyone and I red the full post, even though I did not reach to make it work. I'm not expert in terminal but I really need to use OF asap. I have the feeling there is something wrong with Macport or perhaps with the bash. No idea but I get the following errors:

1st:
Nico$ mpirun -v
-bash: mpirun: command not found

2nd:
Ni:/ Nico$ . Volumes/OpenFOAM-v2.1\ 1/OpenFOAM-2.1.0/etc/bashrc
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/bin/foamEtcFile: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/bin/foamCleanPath: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/bin/foamCleanPath: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/bin/foamCleanPath: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/bin/foamCleanPath: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/etc/config/settings.sh: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/etc/config/aliases.sh: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/bin/foamEtcFile: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/bin/foamEtcFile: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/bin/foamCleanPath: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/bin/foamCleanPath: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/bin/foamCleanPath: No such file or directory

3rd:
Last login: Mon Oct 29 21:06:06 on ttys001
/Volumes/OpenFOAM-v2.1\ 1/OpenFOAM-2.1.0/Allwmake ; exit;
ni:~ Nico$ /Volumes/OpenFOAM-v2.1\ 1/OpenFOAM-2.1.0/Allwmake ; exit;
/Volumes/OpenFOAM-v2.1 1/OpenFOAM-2.1.0/Allwmake: line 2: cd: /Volumes/OpenFOAM-v2.1: No such file or directory
logout

[Process completed]

4th:
Last login: Mon Oct 29 21:48:31 on ttys001
nicola:~ Nico$ /Volumes/OpenFOAM-v2.1\ 1/OpenFOAM-2.1.0/bin/foamInstallationTest ; exit;
Executing /Volumes/OpenFOAM-v2.1 1/OpenFOAM-2.1.0/bin/foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------

FATAL ERROR: OpenFOAM environment not configured.

Please refer to the installation section of the README file:
<OpenFOAM installation dir>/OpenFOAM-/README
to source the OpenFOAM environment.

logout

[Process completed]


Is there someone willing to help me and tell me where exactly I went wrong and how could I repair ??

Thanks a lot
Nicrheo is offline   Reply With Quote

Old   October 31, 2012, 15:16
Default
  #143
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,329
Blog Entries: 32
Rep Power: 72
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Hi again Nicola,

OK, from what I know:
Quote:
Originally Posted by Nicrheo View Post
1st:
Nico$ mpirun -v
-bash: mpirun: command not found
Read: http://openfoamwiki.net/index.php/Ho...penMPI-version

Quote:
Originally Posted by Nicrheo View Post
2nd:
Ni:/ Nico$ . Volumes/OpenFOAM-v2.1\ 1/OpenFOAM-2.1.0/etc/bashrc
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.0/bin/foamEtcFile: No such file or directory
-bash: /Users/Nico/Open...
Why does your path have a space in this name "OpenFOAM-v2.1\ 1"? The "\ " indicates that a space is in the name, which there shouldn't be one!! OpenFOAM's environment system is not prepared for spaces in names

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   October 31, 2012, 15:52
Default
  #144
New Member
 
Nicola Donato
Join Date: Oct 2012
Posts: 9
Rep Power: 3
Nicrheo is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Hi again Nicola,

OK, from what I know:

Read: http://openfoamwiki.net/index.php/Ho...penMPI-version


Why does your path have a space in this name "OpenFOAM-v2.1\ 1"? The "\ " indicates that a space is in the name, which there shouldn't be one!! OpenFOAM's environment system is not prepared for spaces in names

Best regards,
Bruno
Dear Bruno,

thanks for your help and fast reply...I corrected the bashrc file to use openmpi and I corrected the error in the sourcing line but the result I get is always the same.
Code:
nicola:/ Nico$ nano Volumes/OpenFOAM-v2.1/OpenFOAM-2.1.1/etc/bashrc
nicola:/ Nico$ . Volumes/OpenFOAM-v2.1/OpenFOAM-2.1.1/etc/bashrc
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.1/bin/foamEtcFile: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.1/bin/foamCleanPath: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.1/bin/foamCleanPath: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.1/bin/foamCleanPath: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.1/etc/config/settings.sh: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.1/etc/config/aliases.sh: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.1/bin/foamEtcFile: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.1/bin/foamEtcFile: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.1/bin/foamCleanPath: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.1/bin/foamCleanPath: No such file or directory
-bash: /Users/Nico/OpenFOAM/OpenFOAM-2.1.1/bin/foamCleanPath: No such file or directory
nicola:/ Nico$
Terminal goes to find a folder on the system that does not exist anymore (due to previous installation trials). The terminal searches in the home "Nico" while it should search in the Volume OpenFOAM-v2.1. How can I set the new path??


thanks again

regards
Nicrheo is offline   Reply With Quote

Old   October 31, 2012, 15:59
Default
  #145
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,329
Blog Entries: 32
Rep Power: 72
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Check your steps on 2.4: http://openfoamwiki.net/index.php/Ho...efore_building

The ln command is necessary for creating a symbolic link to where you have the mounted volume. In case it is still pointing to the old location, run:
Code:
cd
unlink OpenFOAM
ln -s /Volumes/OpenFOAM-v2.1 OpenFOAM
wyldckat is offline   Reply With Quote

Old   October 31, 2012, 17:02
Default
  #146
New Member
 
Nicola Donato
Join Date: Oct 2012
Posts: 9
Rep Power: 3
Nicrheo is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Check your steps on 2.4: http://openfoamwiki.net/index.php/Ho...efore_building

The ln command is necessary for creating a symbolic link to where you have the mounted volume. In case it is still pointing to the old location, run:
Code:
cd
unlink OpenFOAM
ln -s /Volumes/OpenFOAM-v2.1 OpenFOAM
Dear Bruno,

it seems I'm moving a step forward but now I get this:

Code:
nicola:/ Nico$ . Volumes/OpenFOAM-v2.1/OpenFOAM-2.1.1/etc/bashrc

    Your "Darwin" operating system is not supported by this release
    of OpenFOAM. For further assistance, please contact www.OpenFOAM.org

-bash: mpicc: command not found
-bash: mpicc: command not found
nicola:/ Nico$
Do you think I can solve this or I have to find a previous release version?

thanks a lot Bruno
Nicrheo is offline   Reply With Quote

Old   October 31, 2012, 18:01
Default
  #147
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,329
Blog Entries: 32
Rep Power: 72
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Hi Nicola,

If you got that message, then clearly you forgot to apply the patches : http://openfoamwiki.net/index.php/Ho...hes_and_tweaks

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   November 1, 2012, 06:37
Default
  #148
New Member
 
Nicola Donato
Join Date: Oct 2012
Posts: 9
Rep Power: 3
Nicrheo is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Hi Nicola,

If you got that message, then clearly you forgot to apply the patches : http://openfoamwiki.net/index.php/Ho...hes_and_tweaks

Best regards,
Bruno
Oh yes you're right...sometimes I seem so dummy but I've been trying to install OF so many times in the past 24h that at the end I forgot to reapply the patches, but now the sourcing is right, no errors are shown.

I've got the following problem with the script /Allwmake, please find the log file in the attachment.

Code:
nicola:OpenFOAM-2.1.1 Nico$ ./Allwmake 2>&1 | tee make.log
Error: Current directory is not /Users/Nico/OpenFOAM/OpenFOAM-2.1.1
Error: Current directory is not $WM_PROJECT_DIR
    The environment variables are inconsistent with the installation.
    Check the OpenFOAM entries in your dot-files and source them.
nicola:OpenFOAM-2.1.1 Nico$
I've been reading the whole discussion and I found that I'm running the script from the wrong location, then, I am not able to get from which location I should be running it.

I hope you got what I mean.
Thanks
Attached Files
File Type: gz make.log.tar.gz (297 Bytes, 0 views)
Nicrheo is offline   Reply With Quote

Old   November 1, 2012, 09:57
Default
  #149
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,329
Blog Entries: 32
Rep Power: 72
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Hi Nicola,

OK, first step, take a deep breath and relax

Now, the problem is possibly related to how your doing the mount and the symbolic link. So, let's look at the definitions made in the tutorial:
  • The mounted disk image that is case-sensitive is meant to be mounted at "/Volumes/OpenFOAM-v2.1". That basically points to the root of the file system in that image. It is as if it were "/" of that disk.
  • Your home folder can be found with either one of the following commands:
    Code:
    cd
    cd ~
    cd $HOME
  • Now, the implied location of the symbolic link in section 2.4 (http://openfoamwiki.net/index.php/Ho...efore_building) is that in your home folder you will have the folder "OpenFOAM", which points to "/Volumes/OpenFOAM-v2.1".
  • This means that the following two paths are equivalent:
    Code:
    ~/OpenFOAM
    /Volumes/OpenFOAM-v2.1
  • Which means that you should have inside those two folders the following sub-folders:
    Code:
    ~/OpenFOAM/OpenFOAM-2.1.1
    ~/OpenFOAM/ThirdParty-2.1.1
    
    #identical to
    /Volumes/OpenFOAM-v2.1/OpenFOAM-2.1.1
    /Volumes/OpenFOAM-v2.1/ThirdParty-2.1.1
  • If by any chance you have this:
    Code:
    /Volumes/OpenFOAM-v2.1/OpenFOAM/OpenFOAM-2.1.1
    /Volumes/OpenFOAM-v2.1/OpenFOAM/ThirdParty-2.1.1
    Then this is the reason why things are not working. You can fix this, for example, like this:
    Code:
    cd /Volumes/OpenFOAM-v2.1
    mv OpenFOAM/* .
    rmdir OpenFOAM
    And you should now be ready to go!
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   November 1, 2012, 18:08
Default
  #150
New Member
 
Nicola Donato
Join Date: Oct 2012
Posts: 9
Rep Power: 3
Nicrheo is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Hi Nicola,

OK, first step, take a deep breath and relax

Now, the problem is possibly related to how your doing the mount and the symbolic link. So, let's look at the definitions made in the tutorial:
  • The mounted disk image that is case-sensitive is meant to be mounted at "/Volumes/OpenFOAM-v2.1". That basically points to the root of the file system in that image. It is as if it were "/" of that disk.
  • Your home folder can be found with either one of the following commands:
    Code:
    cd
    cd ~
    cd $HOME
  • Now, the implied location of the symbolic link in section 2.4 (http://openfoamwiki.net/index.php/Ho...efore_building) is that in your home folder you will have the folder "OpenFOAM", which points to "/Volumes/OpenFOAM-v2.1".
  • This means that the following two paths are equivalent:
    Code:
    ~/OpenFOAM
    /Volumes/OpenFOAM-v2.1
  • Which means that you should have inside those two folders the following sub-folders:
    Code:
    ~/OpenFOAM/OpenFOAM-2.1.1
    ~/OpenFOAM/ThirdParty-2.1.1
    
    #identical to
    /Volumes/OpenFOAM-v2.1/OpenFOAM-2.1.1
    /Volumes/OpenFOAM-v2.1/ThirdParty-2.1.1
  • If by any chance you have this:
    Code:
    /Volumes/OpenFOAM-v2.1/OpenFOAM/OpenFOAM-2.1.1
    /Volumes/OpenFOAM-v2.1/OpenFOAM/ThirdParty-2.1.1
    Then this is the reason why things are not working. You can fix this, for example, like this:
    Code:
    cd /Volumes/OpenFOAM-v2.1
    mv OpenFOAM/* .
    rmdir OpenFOAM
    And you should now be ready to go!
Best regards,
Bruno
Hello again,

I followed the logic you said and I found out the problem was in running the script Allwmake from the link in the Home directory and not from the /Volume.
So, finally I run the script and all seemed to work but I got the errors in the attachment as output of Allwmake.
What do you think ? Is there something wrong again??

Thanks
Attached Files
File Type: gz make.log.tar.gz (20.6 KB, 1 views)
Nicrheo is offline   Reply With Quote

Old   November 1, 2012, 18:19
Default
  #151
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,329
Blog Entries: 32
Rep Power: 72
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Hi Nicola,

Looks like Open-MPI is still missing And Flex also seems to be an old version, since the files it generates aren't good enough for Gcc...

Try once again installing Mac Ports' Open-MPI and Flex as well if possible:
Code:
sudo port install openmpi 
sudo port install flex
And make sure you have the SYSTEMOPENMPI option selected, as indicated in post #140: OF 1.9 (aka OF 2.1) on Mac OS X

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   November 2, 2012, 17:52
Default
  #152
New Member
 
Nicola Donato
Join Date: Oct 2012
Posts: 9
Rep Power: 3
Nicrheo is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Hi Nicola,

Looks like Open-MPI is still missing And Flex also seems to be an old version, since the files it generates aren't good enough for Gcc...

Try once again installing Mac Ports' Open-MPI and Flex as well if possible:
Code:
sudo port install openmpi 
sudo port install flex
And make sure you have the SYSTEMOPENMPI option selected, as indicated in post #140: OF 1.9 (aka OF 2.1) on Mac OS X

Best regards,
Bruno
Hello again,

I followed your instruction and reinstalled Mac Ports this time from source, than also Open-MPI and flex.
I made sure about the option SYSTEMOPENMPI in the bashrc script and I recompiled the Allwmake but nothing has changed, the errors are still there (see attachment). Then I tried using one by one all the other options such as (MPI, OPENMPI etc) and I noted the only difference is that when I use SYSTEMOPENMPI while sourcing the bashrc file, I receive the following output:
Code:
:/ Nico$ source Volumes/OpenFOAM-v2.1/OpenFOAM-2.1.1/etc/bashrc
-bash: mpicc: command not found
-bash: mpicc: command not found
But when compiling Allwmake the result is the same.

Do you have any further suggestion? Thanks

Regards
Attached Files
File Type: gz make.log.tar.gz (16.0 KB, 2 views)
Nicrheo is offline   Reply With Quote

Old   November 3, 2012, 06:41
Default
  #153
New Member
 
Nicola Donato
Join Date: Oct 2012
Posts: 9
Rep Power: 3
Nicrheo is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Hi Nicola,

Looks like Open-MPI is still missing And Flex also seems to be an old version, since the files it generates aren't good enough for Gcc...

Try once again installing Mac Ports' Open-MPI and Flex as well if possible:
Code:
sudo port install openmpi 
sudo port install flex
And make sure you have the SYSTEMOPENMPI option selected, as indicated in post #140: OF 1.9 (aka OF 2.1) on Mac OS X

Best regards,
Bruno

I have been working out the problem trying to update the release of my openmpi and flex, consulting here
after the updates I did not get the error while sourcing the bashrc script "mpicc command not found" and the output of Allwmake is way different but still I get some errors.
Could please someone check whether are relevant or I can proceed with the postprocessing tool installation?


Thanks a lot

make.log.tar.gz
Nicrheo is offline   Reply With Quote

Old   November 3, 2012, 16:50
Default
  #154
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,329
Blog Entries: 32
Rep Power: 72
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Hi Nicola, sorry for the late reply!

I'm glad you finally managed to get Open-MPI working!

As for the error on this latest log, it has occurred to other people as well and they were able to solve it:
Quote:
Originally Posted by lithos View Post
EDIT: Ok, one who could read has a clear advantage. I corrected the problem with the 'R', see OF 1.9 (aka OF 2.1) on Mac OS X ran wcleanAll and Allwmake again. No errors anymore.
Basically, you can run from the same folder where you ran Allwmake, the following commands:
Code:
wclean applications/utilities/postProcessing/turbulence/R
wmake applications/utilities/postProcessing/turbulence/R
If it doesn't work, check the information in the quote above and then try again.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   November 4, 2012, 17:34
Default
  #155
New Member
 
Nicola Donato
Join Date: Oct 2012
Posts: 9
Rep Power: 3
Nicrheo is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Hi Nicola, sorry for the late reply!

I'm glad you finally managed to get Open-MPI working!

As for the error on this latest log, it has occurred to other people as well and they were able to solve it:

Basically, you can run from the same folder where you ran Allwmake, the following commands:
Code:
wclean applications/utilities/postProcessing/turbulence/R
wmake applications/utilities/postProcessing/turbulence/R
If it doesn't work, check the information in the quote above and then try again.

Best regards,
Bruno
Thank you Bruno for your continuos help,

I tried your solution but the wmake ends with the followign error:
Code:
Undefined symbols for architecture x86_64:
  "Foam::incompressible::turbulenceModel::typeName", referenced from:
      Foam::calc(Foam::argList const&, Foam::Time const&, Foam::fvMesh const&) in R.o
ld: symbol(s) not found for architecture x86_64
collect2: ld returned 1 exit status
make: *** [/Users/Nico/OpenFOAM/OpenFOAM-2.1.1/platforms/darwinIntel64Gcc46DPOpt/bin/R] Error 1
nicola:OpenFOAM-2.1.1 Nico$
I also tried to wcleanAll and remake Allwmake but I keep getting the same error. Do you know some other way to bypass the problem?

thanks
Nicrheo is offline   Reply With Quote

Old   November 5, 2012, 03:58
Default
  #156
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,329
Blog Entries: 32
Rep Power: 72
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
From the link on the other quote:
Quote:
Originally Posted by gschaider View Post
Anyway: from the log it seems that this part of the patch was not correctly applied:
Code:
diff --git  a/applications/utilities/postProcessing/turbulence/R/Make/options  b/applications/utilities/postProcessing/turbulence/R/Make/options
--- a/applications/utilities/postProcessing/turbulence/R/Make/options
+++ b/applications/utilities/postProcessing/turbulence/R/Make/options
@@ -7,6 +7,7 @@
 
 EXE_LIBS = \
     $(FOAM_LIBBIN)/postCalc.o \
+    -lincompressibleTurbulenceModel \
     -lincompressibleRASModels \
     -lincompressibleTransportModels \
     -lfiniteVolume \
In essence, edit the file "applications/utilities/postProcessing/turbulence/R/Make/options" and add the line:
Code:
    -lincompressibleTurbulenceModel \
As shown in the quote above!
wyldckat is offline   Reply With Quote

Old   November 5, 2012, 05:46
Default
  #157
New Member
 
Nicola Donato
Join Date: Oct 2012
Posts: 9
Rep Power: 3
Nicrheo is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
From the link on the other quote:

In essence, edit the file "applications/utilities/postProcessing/turbulence/R/Make/options" and add the line:
Code:
    -lincompressibleTurbulenceModel \
As shown in the quote above!
Dear Bruno,

I finally got it working...thank you for your extensive help.

Many Regards
Nicrheo is offline   Reply With Quote

Old   November 8, 2012, 12:36
Default OpenFOAM in Mac OSX
  #158
New Member
 
Aditya
Join Date: Jan 2011
Posts: 2
Rep Power: 0
aditya198601 is on a distinguished road
Hello I was able to successfully install openfoam in mac osx . However as soon as I restart my computer, openfoam doesnt work and it shows that it is not installed. I followed the steps as per http://openfoamwiki.net/index.php/Ho...enFOAM_v21_Mac . Please let me know what to do , Is it that using this method you need to install openfoam everytime you restart
aditya198601 is offline   Reply With Quote

Old   November 9, 2012, 03:34
Default
  #159
Member
 
norman1981's Avatar
 
Norman Del Puppo
Join Date: Mar 2009
Location: Hinwil, CH
Posts: 57
Rep Power: 7
norman1981 is on a distinguished road
Dear Aditya,

I think you didn't add to your .bashrc file this line:

. OpenFOAM/OpenFOAM-2.1.0/etc/bashrc

that set OpenFOAM environment when you start your terminal. You have also to mount the OpenFOAM dmg before opening the terminal.

If you have different OpenFOAM versions installed on your system you can add this line to your .bashrc file (change the path according to your OpenFOAM dmg file path):

alias of21='hdiutil attach "/PATH/TO/YOUR/DMG/OpenFOAM-2.1.x.dmg" -mountpoint "$HOME/OpenFOAM" > /dev/null ; . $HOME/OpenFOAM/OpenFOAM-2.1.x/etc/bashrc'

instead of the one I wrote above. In this case you have only to type "of21" to start using the OpenFOAM version that correspond to the specified dmg file. Note that this command will also mount the dmg file.

Hope this will help you in some way

Regards

Norman
wyldckat likes this.
norman1981 is offline   Reply With Quote

Old   November 9, 2012, 14:22
Default
  #160
New Member
 
Aditya
Join Date: Jan 2011
Posts: 2
Rep Power: 0
aditya198601 is on a distinguished road
Quote:
Originally Posted by norman1981 View Post
Dear Aditya,

I think you didn't add to your .bashrc file this line:

. OpenFOAM/OpenFOAM-2.1.0/etc/bashrc

that set OpenFOAM environment when you start your terminal. You have also to mount the OpenFOAM dmg before opening the terminal.

If you have different OpenFOAM versions installed on your system you can add this line to your .bashrc file (change the path according to your OpenFOAM dmg file path):

alias of21='hdiutil attach "/PATH/TO/YOUR/DMG/OpenFOAM-2.1.x.dmg" -mountpoint "$HOME/OpenFOAM" > /dev/null ; . $HOME/OpenFOAM/OpenFOAM-2.1.x/etc/bashrc'

instead of the one I wrote above. In this case you have only to type "of21" to start using the OpenFOAM version that correspond to the specified dmg file. Note that this command will also mount the dmg file.

Hope this will help you in some way

Regards

Norman
Thank you norman for the help. Now it runs properly. Else I had to install it everytime I restart my computer
aditya198601 is offline   Reply With Quote

Reply

Tags
compilation error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Extend Project 1.6-ext Binary Release for Mac OS X hjasak OpenFOAM Announcements from Other Sources 26 November 5, 2013 16:50
Openfoam mac: Compiling custom libraries atareen64 OpenFOAM 3 April 14, 2011 11:01
OpenFOAM-1.6 on Mac OS X 10.6.1 elvisjohndowson OpenFOAM 6 October 21, 2009 15:45
Mac Simple Install Request or Processing Assistance Help sjohnson OpenFOAM Installation 4 December 12, 2008 07:46
MAC + SOLA for free surface T Main CFD Forum 1 April 11, 2001 13:43


All times are GMT -4. The time now is 01:12.