CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Contrib/swak4Foam

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   June 21, 2012, 04:05
Smile
  #21
Senior Member
 
Julien
Join Date: Jun 2012
Location: France
Posts: 153
Rep Power: 5
Djub is on a distinguished road
My lieges ,

Bruno:
Code:
mpirun (Open MPI) 1.3.2
Bernhard:
You are right: I have found
/opt/OpenFOAM-2.1.0/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so
BUT the environment variable $FOAM_MPI_LIBBIN does NOT exist!
Another problem: I just don't know what do you mean about "have a bug-report on the mantis with the changes required to Make/option". I would like to help, but how?
Djub is offline   Reply With Quote

Old   June 21, 2012, 10:15
Default
  #22
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by wyldckat View Post
Hi Bernhard and Julien,

@Bernhard:

What can I say, I'm helping people on the forum instead of playing WoW
Greatly appreciated. You don't have a Facebook-account as well I guess
gschaider is offline   Reply With Quote

Old   June 21, 2012, 14:51
Default
  #23
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by Djub View Post
My lieges ,
Please don't use such fancy words. I must assume that you're making fun of me
Quote:
Originally Posted by Djub View Post
Bernhard:
You are right: I have found
/opt/OpenFOAM-2.1.0/platforms/linux64GccDPOpt/lib/openmpi-system/libPstream.so
BUT the environment variable $FOAM_MPI_LIBBIN does NOT exist!
Another problem: I just don't know what do you mean about "have a bug-report on the mantis with the changes required to Make/option". I would like to help, but how?
Like it says at http://openfoamwiki.net/index.php/Co...oam#Bugreports at the Mantis of openfoam-extend http://sourceforge.net/apps/mantisbt...e_status_id=90
wyldckat likes this.
gschaider is offline   Reply With Quote

Old   June 21, 2012, 16:23
Default
  #24
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,318
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Quote:
Originally Posted by gschaider View Post
Greatly appreciated. You don't have a Facebook-account as well I guess
I do have a Facebook account, but I only use it as a photo album and to somewhat stay in touch with people


As for the bug issue: I'm not so sure this is an actual bug There are too many tell tale signs of something not working properly in this OpenFOAM installation!

edit: I forgot to mention: Julien, what about your "~/.bashrc" file? What does the OpenFOAM related section look like?

Last edited by wyldckat; June 21, 2012 at 16:25. Reason: see "edit:"
wyldckat is offline   Reply With Quote

Old   June 21, 2012, 19:37
Default
  #25
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by wyldckat View Post
As for the bug issue: I'm not so sure this is an actual bug There are too many tell tale signs of something not working properly in this OpenFOAM installation!
That may be right. My assumption was (and I think I saw that before) that some linkers (or some flags) don't link implicitly libraries like meshTools and triSurface to applications. And I thought "Including these won't hurt anyone"
gschaider is offline   Reply With Quote

Old   June 22, 2012, 05:19
Default
  #26
Senior Member
 
Julien
Join Date: Jun 2012
Location: France
Posts: 153
Rep Power: 5
Djub is on a distinguished road
Hi!

@Bernhard: I apologize. It was a kind of "private joke" with Bruno since when I played Warcraft, some orcs were saying "My Liege ?". And it was also out of deference to you (with absolutely no irony)

@Bruno: the only link from bash to OpenFoam is its last line:
source /opt/OpenFOAM-2.1.0/etc/bashrc
Djub is offline   Reply With Quote

Old   June 22, 2012, 15:15
Default
  #27
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by Djub View Post
@Bernhard: I apologize. It was a kind of "private joke" with Bruno since when I played Warcraft, some orcs were saying "My Liege ?". And it was also out of deference to you (with absolutely no irony)
No problem. My posting was with irony
gschaider is offline   Reply With Quote

Old   June 23, 2012, 15:16
Default
  #28
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,318
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
@Julien:
Quote:
Originally Posted by Djub View Post
@Bruno: the only link from bash to OpenFoam is its last line:
source /opt/OpenFOAM-2.1.0/etc/bashrc
Mmm... openSUSE 11.4, x86_64 and only installed OpenFOAM 2.1.0 from repositories... you must have installed something else or have something else activated in your terminal environment, for this to be not working the way it should!

The "missing libraries" issue was something that only happened when Ubuntu 11.04 or 11.10 or when Fedora 16 came out (can't really be certain) which brought a new fancy ld that forcefully needs that people properly define all of the necessary library dependencies.
But openSUSE 11.4 didn't have this issue, at least not that I remember. So, it's possible that either you or some application needed this kind of setting... and changed the system's default ld options.

Another question: how exactly were you able to install Open-MPI 1.3.2? Last time I saw, it had disappeared from the openSUSE Science repositories...
wyldckat is offline   Reply With Quote

Old   June 25, 2012, 04:42
Default
  #29
Senior Member
 
Julien
Join Date: Jun 2012
Location: France
Posts: 153
Rep Power: 5
Djub is on a distinguished road
Sorry Bruno, I have no idea... It a new job for me: I am using a computer allready installed...
Djub is offline   Reply With Quote

Old   February 18, 2013, 22:50
Default interFoamWithSources could not be compiled
  #30
Member
 
Albert Tong
Join Date: Dec 2010
Location: Perth, WA, Australia
Posts: 74
Blog Entries: 1
Rep Power: 6
tfuwa is on a distinguished road
Hi All,

I compiled the swak4Foam a while ago and it worked smoothly.

However, when I wclean all and ./Allwmake it again yesterday, the interFoamWithSources solver could not be compiled. The following is the message from a second time of ./Allwmake.

Code:
./Allwmake 
No simpleFuctionsObject existing. Press ENTER to continue compilation or abort and download it with the downloadSimpleFunctionObjects.sh script

'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswak4FoamParsers.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libgroovyBC.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakFunctionObjects.so' is up to date.

   simpleSwakFunctionObjects not compiled because no simpleFunctionObjects installation found

'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakTopoSources.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakSourceFields.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libgroovyStandardBCs.so' is up to date.
make: `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/funkySetFields' is up to date.
make: `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/funkySetBoundaryField' is up to date.
make: `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/replayTransientBC' is up to date.
make: `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/funkyDoCalc' is up to date.
So I downloaded compiled the latest version with no improvement.

Code:
./Allwmake 
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
Traceback (most recent call last):
  File "./maintainanceScripts/makeSwakVersionFile.py", line 8, in <module>
    output = Popen(["hg", "branch"], stdout=PIPE).communicate()[0]
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1239, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Bison is version 2.4.1
Flex is version 2.5.35 (Minor version: 35)
OpenFOAM-version: Major 1 Minor 7 Patch 1
No change to swak4FoamParsers/foamVersion4swak.H
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswak4FoamParsers.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libgroovyBC.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakFunctionObjects.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libsimpleFunctionObjects.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libsimpleLagrangianFunctionObjects.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libsimpleSwakFunctionObjects.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakTopoSources.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakSourceFields.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libgroovyStandardBCs.so' is up to date.
SWAK_PYTHON_INCLUDE not defined .... no Python-Integration
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakMeshQualityFunctionPlugin.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakLocalCalculationsFunctionPlugin.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakRandomFunctionPlugin.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakFvcSchemesFunctionPlugin.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakThermoTurbFunctionPlugin.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakTransportTurbFunctionPlugin.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakSurfacesAndSetsFunctionPlugin.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakLagrangianCloudSourcesFunctionPlugin.so' is up to date.
'/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt/libswakVelocityFunctionPlugin.so' is up to date.
make[1]: Entering directory `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/swak4Foam_1.x_release_0.2.1/Utilities/funkyDoCalc'
make[1]: `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/funkyDoCalc' is up to date.
make[1]: Leaving directory `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/swak4Foam_1.x_release_0.2.1/Utilities/funkyDoCalc'
make[1]: Entering directory `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/swak4Foam_1.x_release_0.2.1/Utilities/funkySetBoundaryField'
make[1]: `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/funkySetBoundaryField' is up to date.
make[1]: Leaving directory `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/swak4Foam_1.x_release_0.2.1/Utilities/funkySetBoundaryField'
make[1]: Entering directory `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/swak4Foam_1.x_release_0.2.1/Utilities/funkySetFields'
make[1]: `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/funkySetFields' is up to date.
make[1]: Leaving directory `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/swak4Foam_1.x_release_0.2.1/Utilities/funkySetFields'
make[1]: Entering directory `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/swak4Foam_1.x_release_0.2.1/Utilities/replayTransientBC'
make[1]: `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/replayTransientBC' is up to date.
make[1]: Leaving directory `/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/swak4Foam_1.x_release_0.2.1/Utilities/replayTransientBC'
Please point out the reason and guild me to compile interFoamWithSources. Cheers.
__________________
Kind regards,

Albert
tfuwa is offline   Reply With Quote

Old   February 18, 2013, 22:59
Default
  #31
Member
 
Albert Tong
Join Date: Dec 2010
Location: Perth, WA, Australia
Posts: 74
Blog Entries: 1
Rep Power: 6
tfuwa is on a distinguished road
Hi again,

When I tried to compile interFoamWithSources separately, the error message is

Code:
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/openfoam171/src/transportModels     -I/opt/openfoam171/src/transportModels/incompressible/lnInclude     -I/opt/openfoam171/src/transportModels/interfaceProperties/lnInclude     -I/opt/openfoam171/src/turbulenceModels/incompressible/turbulenceModel     -I/opt/openfoam171/src/finiteVolume/lnInclude     -I../../../Libraries/swak4FoamParsers/lnInclude/     -I../../../Libraries/swakSourceFields/lnInclude/ -IlnInclude -I. -I/opt/openfoam171/src/OpenFOAM/lnInclude -I/opt/openfoam171/src/OSspecific/POSIX/lnInclude   -fPIC -Xlinker --add-needed Make/linux64GccDPOpt/interFoamWithSources.o -L/opt/openfoam171/lib/linux64GccDPOpt \
         -ltwoPhaseInterfaceProperties     -linterfaceProperties     -lincompressibleTransportModels     -lincompressibleTurbulenceModel     -lincompressibleRASModels     -lincompressibleLESModels     -lfiniteVolume     -L/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt     -lswak4FoamParsers     -lswakSourceFields -lOpenFOAM -liberty -ldl   -lm -o /home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/interFoamWithSources
/opt/openfoam171/lib/linux64GccDPOpt/libinterfaceProperties.so: undefined reference to `typeinfo for Foam::alphaContactAngleFvPatchScalarField'
collect2: ld returned 1 exit status
make: *** [/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/interFoamWithSources] Error 1
Thanks in advance for your help.
__________________
Kind regards,

Albert
tfuwa is offline   Reply With Quote

Old   February 19, 2013, 11:24
Default
  #32
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tfuwa View Post
Hi again,

When I tried to compile interFoamWithSources separately, the error message is

Code:
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/opt/openfoam171/src/transportModels     -I/opt/openfoam171/src/transportModels/incompressible/lnInclude     -I/opt/openfoam171/src/transportModels/interfaceProperties/lnInclude     -I/opt/openfoam171/src/turbulenceModels/incompressible/turbulenceModel     -I/opt/openfoam171/src/finiteVolume/lnInclude     -I../../../Libraries/swak4FoamParsers/lnInclude/     -I../../../Libraries/swakSourceFields/lnInclude/ -IlnInclude -I. -I/opt/openfoam171/src/OpenFOAM/lnInclude -I/opt/openfoam171/src/OSspecific/POSIX/lnInclude   -fPIC -Xlinker --add-needed Make/linux64GccDPOpt/interFoamWithSources.o -L/opt/openfoam171/lib/linux64GccDPOpt \
         -ltwoPhaseInterfaceProperties     -linterfaceProperties     -lincompressibleTransportModels     -lincompressibleTurbulenceModel     -lincompressibleRASModels     -lincompressibleLESModels     -lfiniteVolume     -L/home/tfuwa/OpenFOAM/tfuwa-1.7.1/lib/linux64GccDPOpt     -lswak4FoamParsers     -lswakSourceFields -lOpenFOAM -liberty -ldl   -lm -o /home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/interFoamWithSources
/opt/openfoam171/lib/linux64GccDPOpt/libinterfaceProperties.so: undefined reference to `typeinfo for Foam::alphaContactAngleFvPatchScalarField'
collect2: ld returned 1 exit status
make: *** [/home/tfuwa/OpenFOAM/tfuwa-1.7.1/applications/bin/linux64GccDPOpt/interFoamWithSources] Error 1
Thanks in advance for your help.
That is a problem with OpenOFAM. Some time back some stuff was split off into a separate library which must be explicitly linked. Try with this Make/options:
Code:
EXE_INC = \
    -I$(LIB_SRC)/transportModels \
    -I$(LIB_SRC)/transportModels/incompressible/lnInclude \
    -I$(LIB_SRC)/transportModels/interfaceProperties/lnInclude \
    -I$(LIB_SRC)/turbulenceModels/incompressible/turbulenceModel \
    -I$(LIB_SRC)/finiteVolume/lnInclude \
    -I$(LIB_SRC)/sampling/lnInclude \
    -I$(LIB_SRC)/meshTools/lnInclude \
    -I../../../Libraries/swak4FoamParsers/lnInclude/ \
    -I../../../Libraries/swakSourceFields/lnInclude/


EXE_LIBS = \
    -ltwoPhaseInterfaceProperties \
    -linterfaceProperties \
    -lincompressibleTransportModels \
    -lincompressibleTurbulenceModel \
    -lincompressibleRASModels \
    -lincompressibleLESModels \
    -lfiniteVolume \
    -lsampling \
    -lmeshTools \
    -L$(FOAM_USER_LIBBIN) \
    -lswak4FoamParsers \
    -lswakSourceFields
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   February 23, 2013, 09:46
Default interFoamWithSources
  #33
Member
 
Albert Tong
Join Date: Dec 2010
Location: Perth, WA, Australia
Posts: 74
Blog Entries: 1
Rep Power: 6
tfuwa is on a distinguished road
Hi Bernhard,

I just gave up the installation of interFoamWithSources on OF1.7.1 and moved to OF2.1.1, as after changing options to your suggestion, there were still some errors for OF1.7.1.

After downloading the swak4Foam files from your wiki page (1st link here, "can be downloaded here for OpenFOAM 2.x and OpenFOAM 1.x. "). The installation for swak4Foam itself is ok. I got these in /bin

Code:
funkyDoCalc  funkySetBoundaryField  funkySetFields   replayTransientBC
and those in /lib

Code:
libgroovyBC.so                   libswakFunctionObjects.so               libswakSourceFields.so
libgroovyStandardBCs.so               libswakFvcSchemesFunctionPlugin.so           libswakSurfacesAndSetsFunctionPlugin.so
libsimpleFunctionObjects.so           libswakLagrangianCloudSourcesFunctionPlugin.so  libswakThermoTurbFunctionPlugin.so
libsimpleLagrangianFunctionObjects.so  libswakLocalCalculationsFunctionPlugin.so       libswakTopoSources.so
libsimpleSwakFunctionObjects.so        libswakMeshQualityFunctionPlugin.so           libswakTransportTurbFunctionPlugin.so
libswak4FoamParsers.so               libswakRandomFunctionPlugin.so               libswakVelocityFunctionPlugin.so
However, when moved to interFoamWithSources(at swak4Foam_2.x_release_0.2.1/Examples/InterFoamWithSources/interFoamWithSources/)

Code:
wmake all
the error messages appears as following.

This could be simple for you but I really have no idea what is wrong. Please comment on this. Thanks heaps.

Code:
Making dependency list for source file interFoamWithSources.C
could not open file mappedWallPolyPatch.H for source file interFoamWithSources.C
could not open file mappedPolyPatch.H for source file interFoamWithSources.C
could not open file FixedValuePointPatchField.H for source file interFoamWithSources.C
could not open file ZeroGradientPointPatchField.H for source file interFoamWithSources.C
could not open file CalculatedPointPatchField.H for source file interFoamWithSources.C
SOURCE=interFoamWithSources.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3  -DNoRepository -ftemplate-depth-100 -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/transportModels -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/transportModels/incompressible/lnInclude -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/transportModels/interfaceProperties/lnInclude -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/turbulenceModels/incompressible/turbulenceModel -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/sampling/lnInclude -I../../../Libraries/swak4FoamParsers/lnInclude/ -I../../../Libraries/swakSourceFields/lnInclude/ -IlnInclude -I. -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/OpenFOAM/lnInclude -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/OSspecific/POSIX/lnInclude   -fPIC -c $SOURCE -o Make/linux64Gcc44DPOpt/interFoamWithSources.o
In file included from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriverI.H:13,
                 from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:448,
                 from ../../../Libraries/swakSourceFields/lnInclude/expressionSource.H:45,
                 from interFoamWithSources.C:49:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedWallFvPatch.H:39:33: error: mappedWallPolyPatch.H: No such file or directory
In file included from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriverI.H:14,
                 from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:448,
                 from ../../../Libraries/swakSourceFields/lnInclude/expressionSource.H:45,
                 from interFoamWithSources.C:49:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedFvPatch.H:39:29: error: mappedPolyPatch.H: No such file or directory
In file included from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionParser_location.hh:44,
                 from FieldValueExpressionParser.tab.hh:65,
                 from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:19,
                 from ../../../Libraries/swakSourceFields/lnInclude/expressionSource.H:45,
                 from interFoamWithSources.C:49:
position.hh: In function ‘bool parserField::operator==(const parserField::position&, const parserField::position&)’:
position.hh:136: warning: suggest parentheses around ‘&&’ within ‘||’
In file included from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriverI.H:13,
                 from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:448,
                 from ../../../Libraries/swakSourceFields/lnInclude/expressionSource.H:45,
                 from interFoamWithSources.C:49:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedWallFvPatch.H: In static member function ‘static const char* Foam::mappedWallFvPatch::typeName_()’:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedWallFvPatch.H:58: error: ‘mappedWallPolyPatch’ has not been declared
In file included from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriverI.H:14,
                 from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:448,
                 from ../../../Libraries/swakSourceFields/lnInclude/expressionSource.H:45,
                 from interFoamWithSources.C:49:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedFvPatch.H: In static member function ‘static const char* Foam::mappedFvPatch::typeName_()’:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedFvPatch.H:58: error: ‘mappedPolyPatch’ has not been declared
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/readTimeControls.H: In function ‘int main(int, char**)’:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/readTimeControls.H:38: warning: unused variable ‘maxDeltaT’
make: *** [Make/linux64Gcc44DPOpt/interFoamWithSources.o] Error 1
__________________
Kind regards,

Albert
tfuwa is offline   Reply With Quote

Old   February 24, 2013, 08:40
Default
  #34
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tfuwa View Post
Hi Bernhard,

I just gave up the installation of interFoamWithSources on OF1.7.1 and moved to OF2.1.1, as after changing options to your suggestion, there were still some errors for OF1.7.1.

After downloading the swak4Foam files from your wiki page (1st link here, "can be downloaded here for OpenFOAM 2.x and OpenFOAM 1.x. "). The installation for swak4Foam itself is ok. I got these in /bin

Code:
funkyDoCalc  funkySetBoundaryField  funkySetFields   replayTransientBC
and those in /lib

Code:
libgroovyBC.so                   libswakFunctionObjects.so               libswakSourceFields.so
libgroovyStandardBCs.so               libswakFvcSchemesFunctionPlugin.so           libswakSurfacesAndSetsFunctionPlugin.so
libsimpleFunctionObjects.so           libswakLagrangianCloudSourcesFunctionPlugin.so  libswakThermoTurbFunctionPlugin.so
libsimpleLagrangianFunctionObjects.so  libswakLocalCalculationsFunctionPlugin.so       libswakTopoSources.so
libsimpleSwakFunctionObjects.so        libswakMeshQualityFunctionPlugin.so           libswakTransportTurbFunctionPlugin.so
libswak4FoamParsers.so               libswakRandomFunctionPlugin.so               libswakVelocityFunctionPlugin.so
However, when moved to interFoamWithSources(at swak4Foam_2.x_release_0.2.1/Examples/InterFoamWithSources/interFoamWithSources/)

Code:
wmake all
the error messages appears as following.

This could be simple for you but I really have no idea what is wrong. Please comment on this. Thanks heaps.

Code:
Making dependency list for source file interFoamWithSources.C
could not open file mappedWallPolyPatch.H for source file interFoamWithSources.C
could not open file mappedPolyPatch.H for source file interFoamWithSources.C
could not open file FixedValuePointPatchField.H for source file interFoamWithSources.C
could not open file ZeroGradientPointPatchField.H for source file interFoamWithSources.C
could not open file CalculatedPointPatchField.H for source file interFoamWithSources.C
SOURCE=interFoamWithSources.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3  -DNoRepository -ftemplate-depth-100 -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/transportModels -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/transportModels/incompressible/lnInclude -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/transportModels/interfaceProperties/lnInclude -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/turbulenceModels/incompressible/turbulenceModel -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/sampling/lnInclude -I../../../Libraries/swak4FoamParsers/lnInclude/ -I../../../Libraries/swakSourceFields/lnInclude/ -IlnInclude -I. -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/OpenFOAM/lnInclude -I/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/OSspecific/POSIX/lnInclude   -fPIC -c $SOURCE -o Make/linux64Gcc44DPOpt/interFoamWithSources.o
In file included from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriverI.H:13,
                 from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:448,
                 from ../../../Libraries/swakSourceFields/lnInclude/expressionSource.H:45,
                 from interFoamWithSources.C:49:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedWallFvPatch.H:39:33: error: mappedWallPolyPatch.H: No such file or directory
In file included from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriverI.H:14,
                 from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:448,
                 from ../../../Libraries/swakSourceFields/lnInclude/expressionSource.H:45,
                 from interFoamWithSources.C:49:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedFvPatch.H:39:29: error: mappedPolyPatch.H: No such file or directory
In file included from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionParser_location.hh:44,
                 from FieldValueExpressionParser.tab.hh:65,
                 from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:19,
                 from ../../../Libraries/swakSourceFields/lnInclude/expressionSource.H:45,
                 from interFoamWithSources.C:49:
position.hh: In function ‘bool parserField::operator==(const parserField::position&, const parserField::position&)’:
position.hh:136: warning: suggest parentheses around ‘&&’ within ‘||’
In file included from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriverI.H:13,
                 from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:448,
                 from ../../../Libraries/swakSourceFields/lnInclude/expressionSource.H:45,
                 from interFoamWithSources.C:49:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedWallFvPatch.H: In static member function ‘static const char* Foam::mappedWallFvPatch::typeName_()’:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedWallFvPatch.H:58: error: ‘mappedWallPolyPatch’ has not been declared
In file included from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriverI.H:14,
                 from ../../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:448,
                 from ../../../Libraries/swakSourceFields/lnInclude/expressionSource.H:45,
                 from interFoamWithSources.C:49:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedFvPatch.H: In static member function ‘static const char* Foam::mappedFvPatch::typeName_()’:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/mappedFvPatch.H:58: error: ‘mappedPolyPatch’ has not been declared
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/readTimeControls.H: In function ‘int main(int, char**)’:
/home/xlou/OpenFOAM/OpenFOAM-2.1.1/src/finiteVolume/lnInclude/readTimeControls.H:38: warning: unused variable ‘maxDeltaT’
make: *** [Make/linux64Gcc44DPOpt/interFoamWithSources.o] Error 1
Yeah. There's a couple of -Is missing from Make/options (fixed in the next release). Locate the files that are not found (either with find or locate) and add the directories to Make/options. I think the missing lines are
Code:
     -I$(LIB_SRC)/sampling/lnInclude \
     -I$(LIB_SRC)/meshTools/lnInclude \
and in the link options
Code:
     -lsampling \
     -lmeshTools \
The solvers in Examples are only examples (how to add code to stock-solvers) so they're not tested regularly
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   February 24, 2013, 20:53
Default
  #35
Member
 
Albert Tong
Join Date: Dec 2010
Location: Perth, WA, Australia
Posts: 74
Blog Entries: 1
Rep Power: 6
tfuwa is on a distinguished road
Hi Bernhard,

Great help, especially the tips on how to locate the missing head files. It reflects the spirit that "Give a man a fish, and you feed him for a day; show him how to catch fish, and you feed him for a lifetime." Many thanks.

Quote:
Originally Posted by gschaider View Post
Yeah. There's a couple of -Is missing from Make/options (fixed in the next release). Locate the files that are not found (either with find or locate) and add the directories to Make/options. I think the missing lines are
Code:
     -I$(LIB_SRC)/sampling/lnInclude \
     -I$(LIB_SRC)/meshTools/lnInclude \
and in the link options
Code:
     -lsampling \
     -lmeshTools \
The solvers in Examples are only examples (how to add code to stock-solvers) so they're not tested regularly
__________________
Kind regards,

Albert
tfuwa is offline   Reply With Quote

Old   February 25, 2013, 17:20
Default
  #36
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tfuwa View Post
Hi Bernhard,

Great help, especially the tips on how to locate the missing head files. It reflects the spirit that "Give a man a fish, and you feed him for a day; show him how to catch fish, and you feed him for a lifetime." Many thanks.
I'd have said it reflects the spirit "Don't bother me again" but I prefer you explanation. It makes me look like a better person than I actually am.

It occurred to me after rereading my post right now that not necessarily everyone is aware that "find" and "locate" are Unix-commands in which case it sounds like mockery.
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   February 25, 2013, 20:33
Default
  #37
Member
 
Albert Tong
Join Date: Dec 2010
Location: Perth, WA, Australia
Posts: 74
Blog Entries: 1
Rep Power: 6
tfuwa is on a distinguished road
Hi Bernhard,

I hope this reply won't bother you. But sorry for the stupid questions and I appreciate your time & answers.

Kind regards,
Albert

Quote:
Originally Posted by gschaider View Post
I'd have said it reflects the spirit "Don't bother me again" but I prefer you explanation. It makes me look like a better person than I actually am.

It occurred to me after rereading my post right now that not necessarily everyone is aware that "find" and "locate" are Unix-commands in which case it sounds like mockery.
tfuwa is offline   Reply With Quote

Old   February 26, 2013, 05:27
Default
  #38
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tfuwa View Post
Hi Bernhard,

I hope this reply won't bother you. But sorry for the stupid questions and I appreciate your time & answers.

Kind regards,
Albert
If it bothers me I can't be bothered to answer. So there's no need to bother that I'll be bothered by your reply.
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   July 23, 2013, 13:51
Default
  #39
psk
Member
 
david
Join Date: Jun 2013
Location: Montreal, Canada
Posts: 62
Rep Power: 3
psk is an unknown quantity at this point
Good Day Folks,
I try to install swak4Foam in Openfoam 2.1, I follow these steps

Step 1: [ svn checkout svn://svn.code.sf.net/p/openfoam-extend/svn/trunk/Breeder_2.0/libraries/swak4Foam/ ], copy & paste in terminal window

step 2: [ hg clone http://hg.code.sf.net/p/openfoam-extend/swak4Foam ] copy & paste in terminal window

upto this step it works

step 3: [ hg update port_2.0.x ] copy & paste in terminal, I got error like this,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ hg update port_2.0.x
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!

kindly let me the step 3 is necessary? just I tried.

step4: ./Allwmake --->copy & paste in terminal window, I got error like,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ ./Allwmake
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!
Swak version is 0.2.4
No 'bison' found. This is absolutely essential for swak4Foam. Can't go on
Requirements for Library not satisfied. I see no sense in going on
toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$

Kindly help me
__________________
Million Thanks,
David

"Small Dream is a Crime"
psk is offline   Reply With Quote

Old   July 23, 2013, 14:05
Default
  #40
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by psk View Post
Good Day Folks,
I try to install swak4Foam in Openfoam 2.1, I follow these steps

Step 1: [ svn checkout svn://svn.code.sf.net/p/openfoam-extend/svn/trunk/Breeder_2.0/libraries/swak4Foam/ ], copy & paste in terminal window

step 2: [ hg clone http://hg.code.sf.net/p/openfoam-extend/swak4Foam ] copy & paste in terminal window

upto this step it works

step 3: [ hg update port_2.0.x ] copy & paste in terminal, I got error like this,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ hg update port_2.0.x
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!

kindly let me the step 3 is necessary? just I tried.

step4: ./Allwmake --->copy & paste in terminal window, I got error like,

toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$ ./Allwmake
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
abort: no repository found in '/home/toshiba/OpenFOAM/toshiba-2.1.0/swak4Foam' (.hg not found)!
Swak version is 0.2.4
No 'bison' found. This is absolutely essential for swak4Foam. Can't go on
Requirements for Library not satisfied. I see no sense in going on
toshiba@ubuntu:~/OpenFOAM/toshiba-2.1.0/swak4Foam$

Kindly help me
The only fatal thing here is the missing bison (and probably flex is missing too). Both (flex and bison) are available for virtually every Linux-distro known to man (and most of the extraterrestrial distros too). Install them via the package manager of your distro
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Reply

Tags
swak4foam

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 21:46.