CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

problem in installation in OpenFOAM-2.1.x on Red Hat

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 4, 2013, 03:16
Default problem in installation in OpenFOAM-2.1.x on Red Hat
  #1
New Member
 
nagendra verma
Join Date: Feb 2013
Posts: 25
Rep Power: 4
nagendra verma is on a distinguished road
Dear former,

I am installing OpenFOAM-2.1.x
on Red Hat Enterprise Linux Server release 5.1
after calling ./Allwmake after 2 hour 1o min I have got error
Target `application' not remade because of errors.
please tell me what I should to do.

Thanks in Advance
nagendra
Attached Images
File Type: jpg error_openfoam2.jpg (41.3 KB, 18 views)
nagendra verma is offline   Reply With Quote

Old   February 4, 2013, 06:16
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,172
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Nagendra and welcome to the forum!

OK, there are at least two issues:
  1. The files seem to be in the future. You can fix this warning by updating all files to the latest date-time:
    Code:
    cd $WM_PROJECT_DIR/..
    find OpenFOAM-2.1.x ThirdParty-2.1.x | xargs touch
  2. The error given to you at the end doesn't give us the real reason why things haven't worked properly. Run Allwmake like this:
    Code:
    cd $WM_PROJECT_DIR
    ./Allwmake > make.log 2>&1
    Then search for the first error that appears inside "make.log"
Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   February 6, 2013, 08:00
Default Recompilation of OpenFOAM
  #3
New Member
 
nagendra verma
Join Date: Feb 2013
Posts: 25
Rep Power: 4
nagendra verma is on a distinguished road
Thankyou for your reply

I have use command you tell me
cd $WM_PROJECT_DIR/.. find OpenFOAM-2.1.x ThirdParty-2.1.x | xargs touch
cd $WM_PROJECT_DIR ./Allwmake > make.log 2>&1
but sir I am not getting what cause error .
I am quite new sir please help me.
I have attached make.log file please check it .
please tell me is there any dependency for installing openfoam on Red Hat Enterprise Linux Server release 5.1.
I am using Gcc 4.1.2
please tell me now what I need to do.


Thanks&Regards
nagendra
Attached Files
File Type: zip make.txt.zip (42.4 KB, 5 views)
nagendra verma is offline   Reply With Quote

Old   February 6, 2013, 18:39
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,172
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Nagendra,

You can try following these instructions: http://openfoamwiki.net/index.php/In...HEL#CentOS_5.8 - they were tested with CentOS 5.8, so I don't know if they will work with RHEL 5.1, but they should with RHEL 5.8.

In essence, it's not possible to build OpenFOAM 2.1.1/x with Gcc 4.1.2, at least not as it is usually distributed. You need to get a more recent version of Gcc, any version between Gcc 4.3.3 and 4.7.x should work. The instructions above rely on Gcc 4.4 that should be available through RHEL's package management system.

The other possibility is to find what needs to be modified for OpenFOAM to build with Gcc 4.1.2. You'll have to search this forum for more information on this.

But I still think the best solution would be to ask your system's administrator to install Gcc 4.4.

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   February 8, 2013, 07:33
Default Error in Installation of OpenFOAM on RedHat5.1
  #5
New Member
 
nagendra verma
Join Date: Feb 2013
Posts: 25
Rep Power: 4
nagendra verma is on a distinguished road
Thanks for your reply

what you had sent me link I have followed

I have try following instructions: http://openfoamwiki.net/index.php/In...HEL#CentOS_5.8 -


But still I am getting some Error,I am sending make4.log file please let me know about error and what I should to do now.

Thanks&Regards
nagendra
Attached Files
File Type: zip make4.zip (27.3 KB, 2 views)

Last edited by nagendra verma; February 8, 2013 at 07:36. Reason: forgot to attach make4.log file
nagendra verma is offline   Reply With Quote

Old   February 10, 2013, 07:06
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,172
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Nagendra,

It looks like you still have two problems:
  1. The files are still defined as being in the future.
  2. You're still trying to use Gcc 4.1.2, which won't work for building OpenFOAM.
A couple of questions:
  • Did you install Gcc 4.4 as instructed in the wiki page?
  • Did you do step #4, which is to start a new terminal?
Beyond those two questions, I suggest that you try these steps as well:
  1. Go into the folder OpenFOAM-2.1.x through the command line (just as if you were to run Allwmake once again) and run:
    Code:
    wcleanAll
  2. Then run:
    Code:
    find . | xargs touch
    If this command gives you any error messages, please let me know.
  3. Make sure you've done the last 2 lines from step #6 from the wiki page.
  4. Run Allwmake once again, as instructed in step #7.
Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   February 12, 2013, 02:30
Default problem in Installation of OpenFOAM-2.1.1 on RHEL Server release 5.1
  #7
New Member
 
nagendra verma
Join Date: Feb 2013
Posts: 25
Rep Power: 4
nagendra verma is on a distinguished road
Thanks for your contineous help...

I am still getting the same error , I am sending all the steps what I have done and sending log file also.
I have installed gcc44 version 4.4.7 on my system /usr/bin.

Step 1- yum groupinstall 'Development Tools'

Error: Unable to satisfy dependencies
Error: Package rpm-devel needs rpm = 4.4.2-47.el5, this is not available.
Error: Package rpm-libs needs rpm = 4.4.2-47.el5, this is not available.
Error: Package elfutils-libelf conflicts with elfutils-libs > 0.125-3.el5.
Error: Package python-devel needs python = 2.4.3-19.el5, this is not available.
Error: Package elfutils-libelf conflicts with elfutils > 0.125-3.el5.
Step 2- yum install gcc44 gcc44-c++ openmpi openmpi-devel zlib-devel Instead of gcc44-c++ I am having g++44 Step 3 my SYSTEMOPENMPI is openmp-1.2.8 Step 4- exit and open new terminal Step 6- I have added these 7 lines in ~/.bashrc file. Then source ~/.bashrc Then wcleanAll
find . | xargs touch
this command does not give any error.
Step -7 now running ./Allwmake > make.log 2>&1
Is there any rpm file for OpenFOAM2.1.1 available for RHEL 5.1

please help me what I shoult to do now.

When I was using same process for OpenFOAM-2.1.x then its using gcc44 but giving same error I am attaching make2.log for OpenFOAM-2.1.x

Thanks & Regards
nagendra
Attached Files
File Type: zip make_1.zip (27.5 KB, 1 views)
File Type: zip make2.zip (87.5 KB, 4 views)

Last edited by nagendra verma; February 12, 2013 at 06:00. Reason: attaching one more log file
nagendra verma is offline   Reply With Quote

Old   February 12, 2013, 06:06
Default
  #8
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,172
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Nagendra,

Did you do the commands in step #6 with success? You can confirm by running the following commands:
  1. Check if the necessary environment variables are properly defined:
    Code:
    echo $WM_CC
    echo $WM_CXX
    It should show:
    Code:
    gcc44
    g++44
  2. Check if the compiler option is properly set:
    Code:
    echo $WM_COMPILER
  3. Check the contents of "OpenFOAM-2.1.1/wmake/rules/linuxGcc44/c" and "OpenFOAM-2.1.1/wmake/rules/linuxGcc44/c++" and see if you can find the string "gcc" or "g++":
    Code:
    grep gcc "OpenFOAM-2.1.1/wmake/rules/linuxGcc44/c"
    grep "g++" "OpenFOAM-2.1.1/wmake/rules/linuxGcc44/c++"
Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   February 12, 2013, 06:09
Default
  #9
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,172
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
OK, onward to the second log file:
  1. Go to the "ThirdParty-2.1.1" folder:
    Code:
    foam3rdParty
  2. Clean all:
    Code:
    ./Allclean
  3. Back to the main folder "OpenFOAM-2.1.1":
    Code:
    foam
  4. Clean all as well:
    Code:
    wcleanAll
  5. And now run Allwmake as before.
wyldckat is online now   Reply With Quote

Old   February 12, 2013, 08:33
Default
  #10
New Member
 
nagendra verma
Join Date: Feb 2013
Posts: 25
Rep Power: 4
nagendra verma is on a distinguished road
Thankyou for giving your precious time...


echo $WM_CC giving gcc44
echo $WM_CXX giving g++44
echo $WM_COMPILER giving Gcc44

grep gcc "OpenFOAM-2.1.1/wmake/rules/linuxGcc44/c"
giving message no such file or directory

grep "g++" "/OpenFOAM-2.1.1/wmake/rules/linuxGcc44/c++"
giving message no such file or directory

BUT,
grep gcc "$HOME//OpenFOAM/OpenFOAM-2.1.1/wmake/rules/linuxGcc44/c"
nothing message appear

grep "g++" "$HOME/OpenFOAM/OpenFOAM-2.1.1/wmake/rules/linuxGcc44/c++"
nothing message appear

************************************************** ***


In OpenFOAM-2.1.x I have done following steps but getting same output.
  1. Go to the "ThirdParty-2.1.1" folder:
    Code:
    foam3rdParty
  2. Clean all:
    Code:
    ./Allclean
  3. Back to the main folder "OpenFOAM-2.1.1":
    Code:
    foam
  4. Clean all as well:
    Code:
    wcleanAll
  5. And now run Allwmake as before.
now what I should to do.
Thanks & Regards
nagendra
nagendra verma is offline   Reply With Quote

Old   February 12, 2013, 08:44
Default
  #11
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,172
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Please attach the latest log file, the same way as you've done before.

I'll try to test this on CentOS 5.1 at the end of today, which will be in about 9h from now.

edited 9h later: sorry, I tried to give it a shot, but I ended up downloading only the livecd and now I'm too tired to stay awake I'll try again tomorrow night.

Last edited by wyldckat; February 12, 2013 at 17:57. Reason: see "edited 9h later"
wyldckat is online now   Reply With Quote

Old   February 13, 2013, 00:33
Default log file for OpenFOAM-2.1.x Installation on RHEL 5.1
  #12
New Member
 
nagendra verma
Join Date: Feb 2013
Posts: 25
Rep Power: 4
nagendra verma is on a distinguished road
sorry I could not sent yesterday...
I am attaching the latest log file.
In OpenFOAM-2.1.x
I have done following steps but getting same output.
  1. Go to the "ThirdParty-2.1.1" folder:
    Code:
    foam3rdParty
  2. Clean all:
    Code:
    ./Allclean
  3. Back to the main folder "OpenFOAM-2.1.1":
    Code:
    foam
  4. Clean all as well:
    Code:
    wcleanAll
  5. And now run Allwmake as before.
Thanks &Regards
nagendra
Attached Files
File Type: zip make3.zip (91.5 KB, 2 views)
nagendra verma is offline   Reply With Quote

Old   February 13, 2013, 05:46
Default
  #13
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,172
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Nagendra,

I think I've spotted the issue you're having. You have RHEL 5.1 x86_64, but you're following the instructions for building the 32bit build of OpenFOAM. Look at the installation instructions again and follow the steps that specifically say "For x86_64".

You probably will have to edit the file "$HOME/.bashrc" manually and remove "WM_ARCH_OPTION=32" from this line:
Code:
source $HOME/OpenFOAM/OpenFOAM-2.1.1/etc/bashrc WM_NCOMPPROCS=4 WM_COMPILER=Gcc44 WM_MPLIB=SYSTEMOPENMPI WM_ARCH_OPTION=32
So it should be this instead:
Code:
source $HOME/OpenFOAM/OpenFOAM-2.1.1/etc/bashrc WM_NCOMPPROCS=4  WM_COMPILER=Gcc44 WM_MPLIB=SYSTEMOPENMPI
edit: Don't forget to start a new terminal!!

Good luck!
Bruno
wyldckat is online now   Reply With Quote

Old   February 15, 2013, 07:15
Default general query In Installation of OpenFOAM on RHEL5.1
  #14
New Member
 
nagendra verma
Join Date: Feb 2013
Posts: 25
Rep Power: 4
nagendra verma is on a distinguished road
Dear sir,


In this step yum install gcc44 gcc44-c++ openmpi openmpi-devel zlib-devel

instead of gcc44-c++ I am having g++44 installed on my system Is it ok or need to install
gcc44-c++.


Thanks&Regards
nagendra
nagendra verma is offline   Reply With Quote

Old   February 15, 2013, 08:22
Default
  #15
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,172
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Nagendra,

The package names probably changed between RHEL 5.1 and 5.8. What matters is what the following two commands output:
Code:
which gcc44
which g++44
If both return valid paths, then all is OK.
Like I wrote in the previous post, the problem seems to be that you were following the instructions for the 32bit installation (i386 or i686), instead of the 64bit installation (x86_64).

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   February 17, 2013, 11:01
Default
  #16
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,172
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Nagendra,

I'm currently testing the instructions on a CentOS 5.1 x86_64 and I've already detected an error in the instructions. Run the following commands:
Code:
cd ~/OpenFOAM
sed -i -e 's=gcc=$(WM_CC)=' OpenFOAM-2.1.1/wmake/rules/linux64Gcc44/c
sed -i -e 's=g++=$(WM_CXX)=' OpenFOAM-2.1.1/wmake/rules/linux64Gcc44/c++
Then continue from step #7 from here: http://openfoamwiki.net/index.php/In...HEL#CentOS_5.8

I hope by the end of the day to have sorted out the problems in the instructions.

edit: Done testing. Page is up-to-date and added section specifically for CentOS 5.1: http://openfoamwiki.net/index.php/In...HEL#CentOS_5.1

Best regards,
Bruno

Last edited by wyldckat; February 17, 2013 at 14:09. Reason: see "edit:"
wyldckat is online now   Reply With Quote

Old   February 18, 2013, 03:01
Default problem in Installation of OpenFOAM-2.1.1 on RHEL Server release 5.1
  #17
New Member
 
nagendra verma
Join Date: Feb 2013
Posts: 25
Rep Power: 4
nagendra verma is on a distinguished road
Thankyou sir,

whatever you have mension its taking g++44 with 64 bit but after certain line its comiplation stops automatic without any intruption.
I have run two time but at same point it stops
first log file is make.log second is make1.log
after first compilation I have done the following commands and again run
wcleanAll
find . | xargs touch
./Allwmake > make1.log 2>&1
I am sending these two log files.


Thanks
nagendra
Attached Files
File Type: zip make.zip (91.5 KB, 3 views)
File Type: zip make1.zip (81.9 KB, 3 views)
nagendra verma is offline   Reply With Quote

Old   February 18, 2013, 05:19
Default
  #18
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,172
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Nagendra,

I think it is now all built properly. There are no error messages, although there are still warnings about "skew clock time".

After a bit of searching, it looks like this clock issue is possibly due to your system using NFS (or similar) for storing your OpenFOAM files.

It should now all be working properly!

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   February 18, 2013, 07:35
Default
  #19
New Member
 
nagendra verma
Join Date: Feb 2013
Posts: 25
Rep Power: 4
nagendra verma is on a distinguished road
Thankyou Sir,

while I am executing the foamInstallationTest script (in the OpenFOAM-2.1.x/bin directory)

flex /usr/bin//flex

ERROR: gcc version is too old for this release of OpenFOAM
User version : 4.1.2
Minimum required: 4.3.2

gcc 4.1.2 /usr/bin//gcc
gzip 1.3.5 /usr/bin//gzip
tar 1.15.1 /bin/tar
icoFoam 2.1.x ...OpenFOAM-2.1.x/platforms/linux64Gcc44DPOpt/bin/icoFoam

Sir why it is giving gcc 4.1.2
I am attaching a make file generated by command foamInstallationTest running in directory OpenFOAM-2.1.x/bin.

Thanks&Regards
nagendra
Attached Files
File Type: zip make2.zip (914 Bytes, 2 views)
nagendra verma is offline   Reply With Quote

Old   February 18, 2013, 07:41
Default
  #20
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,172
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Nagendra,

No need to worry about it. foamInstallationTest is a basic testing script and assumes that only the default "gcc" name is used, which you used gcc44:
Code:
gcc44 --version
What's important is that icoFoam was detected with success!

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Source Pack Installation OpenFOAM Version 2.1.0 on Redhat Linux Indrajit OpenFOAM Installation 1 April 1, 2012 04:39
New OpenFOAM Forum Structure jola OpenFOAM 2 October 19, 2011 06:55
Handling cyclic BC from gambit to openfoam for a cascade airfoil problem - OF 1.6 maverick OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 2 June 18, 2011 04:36
Installation Fluent 6.3 into Red Hat Linux System rashid FLUENT 1 March 1, 2008 09:57
Problem in running CFX in red hat linux Q CFX 0 March 30, 2006 09:11


All times are GMT -4. The time now is 08:05.