CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Install swak4Foam on OpenFOAM1.7.1 on Ubuntu 13.04

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 24, 2013, 05:30
Default Install swak4Foam on OpenFOAM1.7.1 on Ubuntu 13.04
  #1
New Member
 
Join Date: Dec 2013
Posts: 1
Rep Power: 0
kobayashi is on a distinguished road
I’d liked to use OpenFOAM1.7.1 on Ubuntu 13.04/13.10.
And I need to use user defined library swak4Foam.

I installed OpenFOAM1.7.1 on Ubuntu 13.04 successfully but I couldn’t install swak4Foam.
Here is the specific steps of installation:

-----------------------------
Step1: Install svn, bison
sudo apt-get install subversion
sudo apt-get install bison

Step2: Add OpenFOAM1.7.1 to openfoam install list
sudo su
gedit /etc/apt/sources.list.d/openfoam.list
"SAVE THE TEXT AFTER REWRITE AS BELOW"
deb http://www.openfoam.org/download/ubuntu maverick main
sudo apt-get update

Step3: Install OpenFOAM
sudo apt-get install openfoam171
gedit ~/.bashrc
"ADD THE LINE BELOW"
. /opt/openfoam171/etc/bashrc

Step4: Download swak4Foam
run
cd ../
svn checkout svn://svn.code.sf.net/p/openfoam-extend/svn/trunk/Breeder_1.7/libraries/swak4Foam/

Step5: Install swak4Foam
cd swak4Foam
. Allwmake
-----------------------------

Through Step1-4 I have no problem, but I got error message like the attached log file at Step5 and cannot continue installation.


I'd like to know the reason/cause of the error.
I'd like to know if it's possible to solve this problem or I have to downgrade Ubuntu.
If calculation runs, are the simulation results trustworthy?

Thank you for your help.
Attached Files
File Type: gz log.tar.gz (1.8 KB, 6 views)
kobayashi is offline   Reply With Quote

Old   December 25, 2013, 07:08
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,198
Blog Entries: 34
Rep Power: 93
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings kobayashi and welcome to the forum!

Is there any chance you can change to OpenFOAM 1.7.x? Because 1.7.1 is really old by now and there were several modifications made after 1.7.1 was released and are available in 1.7.x.

If you cannot switch to the more recent OpenFOAM 1.7.x, I'll try to have a better look into this.

Better yet would be if you could use the latest OpenFOAM 2.2 series, but I suppose you cannot do so.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   January 5, 2014, 18:33
Default
  #3
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by kobayashi View Post
I’d liked to use OpenFOAM1.7.1 on Ubuntu 13.04/13.10.
And I need to use user defined library swak4Foam.

I installed OpenFOAM1.7.1 on Ubuntu 13.04 successfully but I couldn’t install swak4Foam.
Here is the specific steps of installation:

-----------------------------
Step1: Install svn, bison
sudo apt-get install subversion
sudo apt-get install bison

Step2: Add OpenFOAM1.7.1 to openfoam install list
sudo su
gedit /etc/apt/sources.list.d/openfoam.list
"SAVE THE TEXT AFTER REWRITE AS BELOW"
deb http://www.openfoam.org/download/ubuntu maverick main
sudo apt-get update

Step3: Install OpenFOAM
sudo apt-get install openfoam171
gedit ~/.bashrc
"ADD THE LINE BELOW"
. /opt/openfoam171/etc/bashrc

Step4: Download swak4Foam
run
cd ../
svn checkout svn://svn.code.sf.net/p/openfoam-extend/svn/trunk/Breeder_1.7/libraries/swak4Foam/

Step5: Install swak4Foam
cd swak4Foam
. Allwmake
-----------------------------

Through Step1-4 I have no problem, but I got error message like the attached log file at Step5 and cannot continue installation.


I'd like to know the reason/cause of the error.
I'd like to know if it's possible to solve this problem or I have to downgrade Ubuntu.
If calculation runs, are the simulation results trustworthy?

Thank you for your help.
The problem is not with swak but with the OF sources and your compiler not reacting good to it.

Seems that the compiler on your system (you're using binaries that were compiled on a much older system) doesn't like the call of methods of a parent class in a template without this-> before it (he even says so). In fact: when checking wit 2.2.x the "insert()"-calls were replaced with "this->insert()" in HashPtrTableIO.C. You can try fixing that there, but I'm afraid you'll run into similar problems later. But as I said: this is not a swak-problem. You'll have to fix your OpenFOAM-sources
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Reply

Tags
error, installation, openfoam 1.7.1, swak4foam, ubuntu 13.04

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Environment errors with .deb install and ubuntu 13.04 64 bit jonathanbyrn OpenFOAM Installation 14 September 26, 2013 05:22
swak4foam fails in parallel with -otherTime? Phicau OpenFOAM Post-Processing 3 June 26, 2013 13:00
Installation on ubuntu 13.04 mvee OpenFOAM Installation 7 June 22, 2013 16:02
how to install openfoam on ubuntu 1.4 ? seyedashraf OpenFOAM Installation 8 August 23, 2011 05:50
How to Install OpenFOAM on 64 Ubuntu 9.04 hansel OpenFOAM Installation 62 March 19, 2010 15:43


All times are GMT -4. The time now is 20:19.