CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Installation problem with ParaViewV4

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 30, 2014, 12:28
Default Installation problem with ParaViewV4
  #1
Senior Member
 
Join Date: Nov 2012
Location: Bavaria
Posts: 144
Rep Power: 4
aylalisa is on a distinguished road
Hello Foamers,

due to a crash I had to reinstall my OS (OpenSuse13.1) followed by installation of OF 2.3.0.

I've followed instructions from official OF site:
http://www.openfoam.org/download/source.php

Building ParaView4 with ./makeParaView4 terminates with this error message:

Quote:
/home/ayla/OpenFOAM/ThirdParty-2.3.0/ParaView-4.1.0/Qt/Widgets/pqHelpWindow.cxx:56:21: fatal error: QWebPage: Datei oder Verzeichnis nicht gefunden
# include <QWebPage>
^
compilation terminated.
make[2]: *** [Qt/Widgets/CMakeFiles/pqWidgets.dir/pqHelpWindow.cxx.o] Fehler 1
make[1]: *** [Qt/Widgets/CMakeFiles/pqWidgets.dir/all] Fehler 2
make: *** [all] Fehler 2
OF2.3.0 installation worked well. If I try to start Paraview with paraFoam script I receive
same error message as fusij some time ago:

Quote:
Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV4Readers
./Allwclean
./Allwmake
Environment variables after building ParaViewV4 with ./makeParaView4 are set to these values:
Quote:
export ParaView_DIR=/home/ayla/OpenFOAM/ThirdParty-2.3.0/platforms/linux64Gcc/ParaView-4.1.0
export PATH=$ParaView_DIR/bin:$PATH
export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-4.1
However...
/ThirdParty-2.3.0/platforms is empty
$FOAM_LIBBIN/paraview-4.1 is empty


How can I solve my problem?

Aylalisa

Last edited by aylalisa; May 30, 2014 at 14:28.
aylalisa is offline   Reply With Quote

Old   May 31, 2014, 09:00
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Aylalisa,

Instructions for installing OpenFOAM 2.3.0 are available here: http://openfoamwiki.net/index.php/In...#openSUSE_13.1

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   June 2, 2014, 15:36
Default
  #3
Senior Member
 
Join Date: Nov 2012
Location: Bavaria
Posts: 144
Rep Power: 4
aylalisa is on a distinguished road
Hello Wyldckat,

thanks for your support!

It seems that I run into similar kind of problems:
Quote:
zypper install cmake libqt4-devel qt4-x11-tools qt4-assistant-adp-devel gnuplot openmpi-devel \ boost-devel gmp-devel mpfr-devel libQtWebKit-devel
...leads to that feedback:
Quote:
2 Probleme:
Problem: libQtWebKit-devel-4.8.6+2.3.3-110.1.x86_64 benötigt libqt4-devel >= 4.8.6, was aber nicht angeboten werden kann
Problem: qt4-x11-tools-4.8.6-355.1.x86_64 benötigt libqt4-x11 >= 4.8.6, was aber nicht angeboten werden kann

Problem: libQtWebKit-devel-4.8.6+2.3.3-110.1.x86_64 benötigt libqt4-devel >= 4.8.6, was aber nicht angeboten werden kann
Nicht installierbare Anbieter: libqt4-devel-4.8.6-351.1.i586[Qt4-Release]
libqt4-devel-4.8.6-351.1.x86_64[Qt4-Release]
Lösung 1: libqt4-devel-4.8.5-5.9.2.x86_64 nicht installieren
Lösung 2: libQtWebKit-devel-4.8.6+2.3.3-110.1.x86_64 nicht installieren
Lösung 3: libQtWebKit-devel-4.8.6+2.3.3-110.1.x86_64 beschädigen durch Ignorieren einiger Abhängigkeiten
What choice do I have?
I've only found libqt4-x11 4.8.5-5.6.1 (4.8.5-5.9.2)
Aylalisa




aylalisa is offline   Reply With Quote

Old   June 2, 2014, 16:03
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Aylalisa,

You seem to have the repository "openSUSE Factory" activated in your openSUSE installation.
You'll need to turn off that repository through zypper or YaST and then you can try following the instructions once again.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   June 2, 2014, 16:28
Default
  #5
Senior Member
 
Join Date: Nov 2012
Location: Bavaria
Posts: 144
Rep Power: 4
aylalisa is on a distinguished road
Hello Wyldckat,

I've (in the meantime) continued by choosing...
Quote:
Lösung 3: libQtWebKit-devel-4.8.6+2.3.3-110.1.x86_64 beschädigen durch Ignorieren einiger Abhängigkeiten
and started OF installation .

These are my repos...


I don't see openSUSE Factory repo. Most of them I've add today.
Is it possible that the repo for VLC media player cause the trouble?

OF and PV installation have both sucessfully finished :-) !

Thank's a lot!



Best regards,
Aylalisa
aylalisa is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LINUX newbie with paraView installation problem kenya0514 OpenFOAM Installation 4 January 16, 2013 18:51
Installation problem - calling blockMesh - libblockMesh.so aylalisa OpenFOAM Installation 5 November 28, 2012 10:55
ParaView installation problem on Suse 11.4 victorz OpenFOAM Installation 4 February 6, 2012 18:26
OpenFOAM-2.0.1 installation problem benru OpenFOAM Installation 1 September 14, 2011 09:15
Installation paraFoam - still problem nhl OpenFOAM Installation 7 June 22, 2010 09:22


All times are GMT -4. The time now is 16:23.