CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Trying to install OpenFoam141

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 21, 2007, 08:47
Default I successfully installed 1.2 a
  #1
jam
Member
 
Alain Martin
Join Date: Mar 2009
Posts: 40
Rep Power: 8
jam is on a distinguished road
I successfully installed 1.2 and 1.3 before, but when I try to install 1.4.1 I got only as far as this:
zania@spectr:~/OpenFOAM/OpenFOAM-1.4.1$ ./Allwmake
+ cd wmake
+ ./makeWmake
make: Nothing to be done for `all'.
+ cd src
+ ./Allwmake
+ cd /home/zania/OpenFOAM/OpenFOAM-1.4.1/src/OpenFOAM
+ wmakeLnInclude .
+ wmake libso zlib-1.2.1
g++: no input files
make: *** [libNULL.so] Error 1

But the files are there. If I change "libso" for "all" it start to complile some files.
What could be the cause of this problem?
Thanks,
-Alain
jam is offline   Reply With Quote

Old   December 21, 2007, 14:37
Default I have located where the probl
  #2
jam
Member
 
Alain Martin
Join Date: Mar 2009
Posts: 40
Rep Power: 8
jam is on a distinguished road
I have located where the problem occurs. It is during the execution of the scripts MakefileFiles.
Some files are generated but are empty.
Why?

-Alain
jam is offline   Reply With Quote

Old   December 21, 2007, 17:23
Default I have tried everthing I can t
  #3
jam
Member
 
Alain Martin
Join Date: Mar 2009
Posts: 40
Rep Power: 8
jam is on a distinguished road
I have tried everthing I can think of but with no luck. I still get the message g++ : no input files.
Why such a change in wmake between 1.3 and 1.4.1?

Can anyone gve me a hint to a solution?
Thanks
-Alain
jam is offline   Reply With Quote

Old   December 22, 2007, 10:58
Default Hi Allan I am not sure whet
  #4
Senior Member
 
Join Date: Mar 2009
Posts: 248
Rep Power: 9
jaswi is on a distinguished road
Hi Allan

I am not sure whether I could be able to help you to the solution nevertheless please let me know the following.

-Linux platform, if SUSE which version

-Where did u get the 1.4.1 distribution from; powerlab or openfoam.org

-did u pass the foamInstallation check b4 u start the compilation

As far as my knowledge goes there is no such difference which could lead to this error if you have passed the foamInstallationTest.

If you foamInstallationTest gives some error then post it here as i doubt something is wrong with the location of your gcc compiler and hence the g++ error

Let see what can we achieve together :-)

Happy Holidays

Kind Regards
Jaswinder
jaswi is offline   Reply With Quote

Old   December 22, 2007, 11:32
Default Thank you for your reply. I
  #5
jam
Member
 
Alain Martin
Join Date: Mar 2009
Posts: 40
Rep Power: 8
jam is on a distinguished road
Thank you for your reply.
I am using Slackware 10 distro.
I downloaded from openfoam.org
By fiddling with some system file links, i managed to get it to run without compiling, but this is not mush use if I cannot compile,right?

I've tried to do a recompile on version 1.3 and it still work well.

-----------------
Executing /home/zania/OpenFOAM/OpenFOAM-1.4.1/bin/foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: spectr
OS: Linux version 2.6.13
User: zania
User_config: /home/zania/.bashrc
Foam_config: /home/zania/.OpenFOAM-1.4.1/bashrc sourced correctly.
-------------------------------------------------------------------------------


Checking main FOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/zania/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/zania/OpenFOAM/zania-1.4.1 yes no
$FOAM_JOB_DIR /home/zania/OpenFOAM/jobControl no yes
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/zania/OpenFOAM/OpenFOAM-1.4.1 yes yes yes

$FOAM_USER_APPBIN ...1.4.1/applications/bin/linuxGccDPOpt yes yes no
$FOAM_APPBIN ...1.4.1/applications/bin/linuxGccDPOpt yes yes yes
$WM_DIR .../zania/OpenFOAM/OpenFOAM-1.4.1/wmake yes yes yes
$FOAMX_PATH ...ations/utilities/preProcessing/FoamX yes no yes
$CEI_HOME /usr/local/ensight/CEI no no

$JAVA_PATH /home/zania/OpenFOAM/linux/j2sdk1.4.2_05 yes yes no
$MICO_ARCH_PATH .../mico-2.3.12/platforms/linuxGccDPOpt yes yes yes
$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes no yes
$MPICH_ARCH_PATH --------- env variable not set --------- no
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...OAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt yes no yes
$FOAM_USER_LIBBIN ...enFOAM/zania-1.4.1/lib/linuxGccDPOpt yes no no
$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes no yes
-------------------------------------------------------------------------------
Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.2.1 /home/zania/OpenFOAM/linux/gcc-4.2.1/bin/gcc
java 1.4.2_05
WARNING: Conflicting installations:
foam settings: /usr/lib/java/bin/java
current path : /home/zania/OpenFOAM/linux/j2sdk1.4.2_05/bin/java

gzip 1.3.3 /usr/bin/gzip
tar 1.3.3 /usr/bin/tar
icoFoam .../OpenFOAM-1.4.1/applications/bin/linuxGccDPOpt/icoFoam
-------------------------------------------------------------------------------


Checking file/directory permissions...
-------------------------------------------------------------------------------
File/directory Set Reqd Crit
-------------------------------------------------------------------------------
Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_spectr Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Unsuccessful_connection_refused* yes
FATAL ERROR: No remote shell available.
Foam1.4.1 enviroment requires either ssh and/or rsh.
Contact your system administrator.


-------------------------------------------------------------------------------

The system test has evoked 1 fatal error(s).

Critical systems ok.

Review the output for warning messages and consult
the installation guide for trouble shooting.



Since I am not using any remote, do I need ssh?

Thanks and Happy Holidays
-Alain
jam is offline   Reply With Quote

Old   December 22, 2007, 12:16
Default Hi Allan I am not sure abou
  #6
Senior Member
 
Join Date: Mar 2009
Posts: 248
Rep Power: 9
jaswi is on a distinguished road
Hi Allan

I am not sure about that FATAL ERROR related to ssh. I was expecting that the cause of error might be due to location but then i saw you error message again and it says

********************
zania@spectr:~/OpenFOAM/OpenFOAM-1.4.1$ ./Allwmake
+ cd wmake
+ ./makeWmake
make: Nothing to be done for `all'.
+ cd src
+ ./Allwmake
+ cd /home/zania/OpenFOAM/OpenFOAM-1.4.1/src/OpenFOAM
+ wmakeLnInclude .
+ wmake libso zlib-1.2.1
g++: no input files
make: *** [libNULL.so] Error 1

********************************

so in a way it is unable to locate the input files.

I am no expert so will advice you to take a layman's approach. Make a fresh OpenFOAM directory structure i.e :

OpenFOAM
|__linux64 (can be linux if 32 bit platform)
|__src

Basically the name of the 1st folder depends upon the platform and the architecture and one should look into the .OpenFOAM.1.4.1/bashrc to make sure that it is correct.

download just the source code i.e
OpenFOAM-1.4.1.General.gtgz

and the trinity which is required for other stuff i.e
gcc-4.2.1.linux64.tgz
paraview-2.4.4.linux64.tgz
j2sdk1.4.2_05.linuxAMD64.tgz

Place all that into your src directory.

Now untar your OpenFOAM-1.4.1.General.gtgz into
OpenFOAM. and the other stuff into linux64(linux) directory.

Run foamInstallation check. for correcting the error related to java please take a look into the OpenFOAM/OpenFOAM-1.4.1/.bashrc file. In there under the java section you can rectify the cause of this warning.

Let me know what your foamInstallation spits out.


Kind Regards
Jaswinder
jaswi is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo ebuild for OpenFOAM141 deepblue17 OpenFOAM Installation 3 July 29, 2010 09:27
Adding liftDrag to Openfoam141 srinath OpenFOAM Running, Solving & CFD 9 August 25, 2009 13:39
OpenFoam141 problem after installation mateuszzb OpenFOAM Installation 1 July 2, 2008 04:11
Read native OpenFoam141 with Paraview321 hjg911 OpenFOAM Paraview & paraFoam 1 March 10, 2008 17:57
OpenFOAM141 installation problem on Itanium machine skabilan OpenFOAM Installation 3 February 6, 2008 10:05


All times are GMT -4. The time now is 04:37.