CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

LAMMPI troubles

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 11, 2005, 09:49
Default Hi, I execute the parallel ex
  #1
mer
Member
 
merrouche djemai
Join Date: Mar 2009
Location: ain-oussera, djelfa, algeria
Posts: 46
Rep Power: 8
mer is on a distinguished road
Hi,
I execute the parallel exemple icoFoam in parallel with 2 Pcs running red hat 9.0. At the first time it running well, but when I try to reexecute for a second time (eventually after rebooting), I received the fellowing errors:
Error: LAM/MPI unexpectedly received the following om stderr: permission denied.

For information: my network is composed with 2 Pcs, the file rhosts is located on both Pcs in /home/mer1/.rhosts and /home/mer2/.rhosts resectively with lines : 100.100.100.137 and 100.100.100.138. In /etc the two-files : hosts.allow and hosts has the same adresses IP. I do not declare any user in the lines. Now the two Pcs asked me for a password to rsh or ssh services. What wrong with my network or with LAM/MPI???

The SSH asked me at the final line for : publickey, keyboard, I can't understand what happened.

perhapse, I make mistakes during configuration of network, but I can't find where?

the file machines in /etc works well with the boot of LAM.

please help me, in more details.

thanks
mer is offline   Reply With Quote

Old   September 12, 2005, 12:51
Default Hi, Is there here any one tha
  #2
mer
Member
 
merrouche djemai
Join Date: Mar 2009
Location: ain-oussera, djelfa, algeria
Posts: 46
Rep Power: 8
mer is on a distinguished road
Hi,
Is there here any one that can help me?!
I've got a problem with sshd and I haven't permission to connect to the second Pc due to the (permission denied). I try the recommandation of the ssh, but no solution. In the first time, all works well but now, there a problem and can't find it. please help, I try to generate and declar the public keys, but no way.
thanks
mer is offline   Reply With Quote

Old   September 12, 2005, 13:42
Default Things I would check: - is ss
  #3
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Things I would check:
- is sshd running? Do you have a firewall running?
- is the syntax of hosts.allow correct?
- do /var/log/messages say anything?
mattijs is offline   Reply With Quote

Old   September 12, 2005, 15:23
Default Hi The sshd is running and th
  #4
mer
Member
 
merrouche djemai
Join Date: Mar 2009
Location: ain-oussera, djelfa, algeria
Posts: 46
Rep Power: 8
mer is on a distinguished road
Hi
The sshd is running and the firewall works with medium and authorize the ssh service.
I check the hosts.allow, it seems good.
But there is a point I can't find in $home/.ssh the file related to authorization.
thanks
mer is offline   Reply With Quote

Old   September 13, 2005, 05:41
Default type "man ssh-keygen"
  #5
Senior Member
 
Eugene de Villiers
Join Date: Mar 2009
Posts: 725
Rep Power: 12
eugene is on a distinguished road
type "man ssh-keygen"
eugene is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
UDF troubles Rachel FLUENT 1 June 29, 2008 23:02
AMG troubles - help? Stephanie CD-adapco 1 September 22, 2007 14:03
3d VOF troubles... Mac FLUENT 0 March 12, 2007 09:41
Ssh problem for LAMMPI parallelauvi OpenFOAM Installation 3 April 12, 2006 01:28
Lammpi library hsing OpenFOAM Installation 1 September 1, 2005 22:53


All times are GMT -4. The time now is 18:20.