CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFOAM-1.6.x instllation problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 22, 2011, 17:27
Default OpenFOAM-1.6.x instllation problem
  #1
Member
 
Naveen
Join Date: Feb 2010
Location: Los Angeles
Posts: 65
Rep Power: 7
vetnav is on a distinguished road
Hello foamers,

I have been using OpenFOAM-1.7.1 for some time. I have to develop some applications related to conjugate heat transfer problems. As this is not available in 1.7.1, I decided to install OpenFOAM-1.6.x from the git depository (http://www.openfoam.com/archive/1.6/download/git.php). This needs a gcc version of 4.3.3. I have 4.5.1, so I thought its fine and went ahead with the compilation step in the link. When I executed "foamInstallationTest", below is what it spit out. Could anyone please how to fix these errors.

Executing ./foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: naveen
OS: Linux version 2.6.35.13-92.fc14.x86_64
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/naveen/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/naveen/OpenFOAM/naveen-1.6.x no no
$WM_THIRD_PARTY_DIR /home/naveen/OpenFOAM/ThirdParty-1.6.x yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/naveen/OpenFOAM/OpenFOAM-1.6.x yes yes yes

$FOAM_APPBIN ...6.x/applications/bin/linux64GccDPOpt yes yes yes
$FOAM_SITE_APPBIN ...nFOAM/site/1.6.x/bin/linux64GccDPOpt no no
$FOAM_USER_APPBIN ...6.x/applications/bin/linux64GccDPOpt no no
$WM_DIR ...naveen/OpenFOAM/OpenFOAM-1.6.x/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...M/OpenFOAM-1.6.x/lib/linux64GccDPOpt yes yes yes
$FOAM_SITE_LIBBIN ...nFOAM/site/1.6.x/lib/linux64GccDPOpt no no
$FOAM_USER_LIBBIN ...OAM/naveen-1.6.x/lib/linux64GccDPOpt no no
$MPI_ARCH_PATH ...nmpi-1.3.3/platforms/linux64GccDPOpt yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.3
User version : 4.5.1
Minimum required: 4.3.1

gcc 4.5.1
WARNING: Conflicting installations:
OpenFOAM settings : /home/naveen/OpenFOAM/ThirdParty-1.6.x/gcc-4.5.1/platforms/linux64/bin/gcc
current path : /usr/lib64/ccache/gcc
CRITICAL ERROR

gzip 1.4 /usr/bin/gzip
tar 1.23 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/naveen/OpenFOAM/OpenFOAM-1.6.x/applications/bin/linux64GccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

The foam installation contains 2 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.

done.


Thank you
vetnav
vetnav is offline   Reply With Quote

Old   August 22, 2011, 19:27
Default
  #2
Member
 
Naveen
Join Date: Feb 2010
Location: Los Angeles
Posts: 65
Rep Power: 7
vetnav is on a distinguished road
It's me again. I found a relevant thread
Problem Installing OF 1.6 Ubuntu 9.10 (64 bit) - How to use GCC 4.4.1

In posts #7, Bruno says 1.6.x builds properly with gcc 4.4.? and above. So I modified settings.sh file (compilerInstall=System) and cleaned everything as suggested and then ran Allwmake. Unfortunately I still fail to compile and when I run foamInstallationTest I receive the same info that I pasted in the above post.

Did any of you faced this problem in fedora 14??

Thanks
vetnav
vetnav is offline   Reply With Quote

Old   August 22, 2011, 20:59
Default
  #3
Member
 
Naveen
Join Date: Feb 2010
Location: Los Angeles
Posts: 65
Rep Power: 7
vetnav is on a distinguished road
It's me again. I found a relevant thread
Problem Installing OF 1.6 Ubuntu 9.10 (64 bit) - How to use GCC 4.4.1

In posts #7, Bruno says 1.6.x builds properly with gcc 4.4.? and above. So I modified settings.sh file (compilerInstall=System) and cleaned everything as suggested and then ran Allwmake. Unfortunately I still fail to compile and when I run foamInstallationTest I receive the same info that I pasted in the above post.

Did any of you face this problem in fedora 14??

Thanks
vetnav
vetnav is offline   Reply With Quote

Old   August 23, 2011, 11:16
Default
  #4
Member
 
Naveen
Join Date: Feb 2010
Location: Los Angeles
Posts: 65
Rep Power: 7
vetnav is on a distinguished road
Could somebody please respond, thinking that I can install 1.6.x I completely removed my 1.7.1 which was working fine. I did not know how to maintain two versions in my laptop so I had to remove 1.7.1. Now I am left with none

Thank you
vetnav is offline   Reply With Quote

Old   August 23, 2011, 12:10
Default
  #5
Member
 
Naveen
Join Date: Feb 2010
Location: Los Angeles
Posts: 65
Rep Power: 7
vetnav is on a distinguished road
I found out a similar post
Problem Installing OF 1.6 Ubuntu 9.10 (64 bit) - How to use GCC 4.4.1

As I can not remove this post, I just want to mention that, I will be reposting my question in the above post and please reply in that post. Don't post anything in this thread.

Thank you
vetnav is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM 1.7.1 installation problem on Fedora 14 armonica OpenFOAM Installation 16 March 31, 2011 13:16
a problem of valve simulation in openfoam xck1986 OpenFOAM 2 January 21, 2011 21:08
Cross-compiling OpenFOAM 1.7.0 on Linux for Windows 32 and 64bits with Mingw-w64 wyldckat OpenFOAM Announcements from Other Sources 3 September 8, 2010 06:25
OpenFOAM paraView problem Ronnfors OpenFOAM 2 September 22, 2009 05:32
OpenFOAM 1.6 CreatePatch Problem TarifaPirata OpenFOAM Bugs 1 September 10, 2009 04:35


All times are GMT -4. The time now is 12:28.