CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ...

How to solve"Can not find patchField entry for **"?

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By wyldckat

Reply
 
LinkBack Thread Tools Display Modes
Old   May 4, 2014, 04:38
Unhappy How to solve"Can not find patchField entry for **"?
  #1
New Member
 
Wen Yuan
Join Date: Apr 2014
Posts: 10
Rep Power: 3
WenY is on a distinguished road
Hi
I tried to convert .msh file to openfoam,and have already checked the mesh,it showed success. But I could not see the mesh in paraview, the terminal showed "Can not find patchField entry for circle".ps."circle" is the name of a patch.
Anyone knows how to solve it?
WenY is offline   Reply With Quote

Old   May 4, 2014, 05:53
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,516
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings WenY and welcome to the forum!

If you look at the error message in more detail, you should be able to see that it's very likely complaining about the patch not being present inside a particular field file, for example inside "0/U" or "0/p".

You have at least 2 choices for fixing this:
  1. You properly set-up the boundary conditions inside the field files.
  2. Or you rename the folder "0" to something else, such as "0.org" (it's the standard used in OpenFOAM's tutorials for the original boundary conditions to be used in the case).

Beyond this, please keep in mind that people cannot see what you're seeing, and when it comes to OpenFOAM, every single detail is important. Therefore, giving these vague descriptions to problems will lead to taking longer to be answered... although in this case, you got lucky.
For more information, please read this thread: How to give enough info to get help

Best regards,
Bruno
WenY likes this.
wyldckat is offline   Reply With Quote

Old   May 5, 2014, 02:31
Default
  #3
New Member
 
Wen Yuan
Join Date: Apr 2014
Posts: 10
Rep Power: 3
WenY is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Greetings WenY and welcome to the forum!

If you look at the error message in more detail, you should be able to see that it's very likely complaining about the patch not being present inside a particular field file, for example inside "0/U" or "0/p".

You have at least 2 choices for fixing this:
  1. You properly set-up the boundary conditions inside the field files.
  2. Or you rename the folder "0" to something else, such as "0.org" (it's the standard used in OpenFOAM's tutorials for the original boundary conditions to be used in the case).

Beyond this, please keep in mind that people cannot see what you're seeing, and when it comes to OpenFOAM, every single detail is important. Therefore, giving these vague descriptions to problems will lead to taking longer to be answered... although in this case, you got lucky.
For more information, please read this thread: How to give enough info to get help

Best regards,
Bruno
Hi Bruno
Thanks for your advice, I've already read the information you showed to me.I'm new here and starting to study openfoam. You really help me!!
regards
WenY
WenY is offline   Reply With Quote

Reply

Tags
mesh conversion

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CFX-Pre problem, pls help!!! cth_yao CFX 0 February 17, 2012 01:52
OpenFOAM 1.6-ext git installation on Ubuntu 11.10 x64 Attesz OpenFOAM Installation 45 January 13, 2012 13:38
Problem Building OF on Centos cluster (no admin rights) CKH OpenFOAM Installation 5 November 13, 2011 07:32
Converting Starccm+ mesh Ladnam OpenFOAM 0 September 14, 2011 06:30
Errors running allwmake in OpenFOAM141dev with WM_COMPILE_OPTION%3ddebug unoder OpenFOAM Installation 11 January 30, 2008 21:30


All times are GMT -4. The time now is 22:29.