CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Native Meshers: snappyHexMesh and Others

locationInMesh Error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 16, 2009, 14:42
Default locationInMesh Error
  #1
Member
 
James Baker
Join Date: Dec 2009
Posts: 35
Rep Power: 7
fijinx is on a distinguished road
I am very new to openFoam and am just trying to get it running at this point. However, I keep getting the error:


Refinement phase
----------------



Point (-0.018 -0.018 -0.018) is not inside the mesh or on a face or edge.
Bounding box of the mesh-0.254 -0.762 -0.762) (1.778 0.762 0.762)

From function refinementParameters::findCells(const polyMesh&) const
in file autoHexMesh/autoHexMeshDriver/refinementParameters/refinementParameters.C at line 104.

FOAM exiting

. No matter if I choose a point inside the stl or outside (still within the bounding box) I get the same error. Any help is appreciated.

here is my setup which clearly shows the surface within the bounding box.

fijinx is offline   Reply With Quote

Old   December 16, 2009, 14:49
Default
  #2
Senior Member
 
Anonymous
Join Date: Mar 2009
Posts: 110
Rep Power: 8
madad2005 is on a distinguished road
Have a look here:

http://www.cfd-online.com/Forums/ope...-mesh-but.html

I had the same issue and I finally resolved it by manipulating the order of my initial bounding box. Can't help you much more than that, I'm afraid.
madad2005 is offline   Reply With Quote

Old   December 16, 2009, 15:34
Default
  #3
Member
 
James Baker
Join Date: Dec 2009
Posts: 35
Rep Power: 7
fijinx is on a distinguished road
Worked great, thank you!
fijinx is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile problem ivanyao OpenFOAM Running, Solving & CFD 1 October 12, 2012 09:31
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
Compiling problems with hello worldC fw407 OpenFOAM Installation 21 January 6, 2008 18:38
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31


All times are GMT -4. The time now is 04:54.