CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

how can I make sure rhoSimplecFoam NEVER crashes?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 21, 2012, 17:10
Default how can I make sure rhoSimplecFoam NEVER crashes?
  #1
Senior Member
 
Mihai Pruna
Join Date: Apr 2010
Location: Boston
Posts: 190
Blog Entries: 1
Rep Power: 7
mihaipruna is on a distinguished road
Basically I want it to automatically cut off big numbers, replace divisions by 0 with something else, etc.
I tried relaxation factors and cellLimited gradients.
Is there a way to ensure you get a solution (even inaccurate) , always?
mihaipruna is offline   Reply With Quote

Old   December 25, 2012, 23:55
Default
  #2
Member
 
Haomin Yuan
Join Date: Jan 2012
Location: Madison, Wisconsin, USA
Posts: 53
Rep Power: 5
yhaomin2007 is on a distinguished road
Hi, Mihai

Have you solved your problem, I think I have met the same problem like you.
I am running a simulation with a large area change, which makes the simulation very easy to crash.

Thank you
yhaomin2007 is offline   Reply With Quote

Old   December 27, 2012, 10:12
Default
  #3
Senior Member
 
Mihai Pruna
Join Date: Apr 2010
Location: Boston
Posts: 190
Blog Entries: 1
Rep Power: 7
mihaipruna is on a distinguished road
I had to streamline the geometry further. I was not able to get it to converge on my original model. WIth that, and residuals set to 10E-3, I was able to get it to converge. I had to set residuals this high because divergence occurred after a certain number of iterations. The residuals dropped to a certain level and then they started increasing (p mainly), and then the density would eventually reach either very large or small values, then it would crash.

So, in essence, I have not found a simple solution or a setting that would always ensure convergence just yet.
mihaipruna is offline   Reply With Quote

Old   December 27, 2012, 10:31
Default
  #4
Member
 
Haomin Yuan
Join Date: Jan 2012
Location: Madison, Wisconsin, USA
Posts: 53
Rep Power: 5
yhaomin2007 is on a distinguished road
Is your flow a pressure driven flow or velocity driven flow? I think you can try time varying condition to get approach the condition you want. And I also suggest you try to decrease the relaxation factor to ensure stable.
yhaomin2007 is offline   Reply With Quote

Old   December 27, 2012, 12:10
Default
  #5
Senior Member
 
Mihai Pruna
Join Date: Apr 2010
Location: Boston
Posts: 190
Blog Entries: 1
Rep Power: 7
mihaipruna is on a distinguished road
I decided to go with pressure driven flow (total pressure).
In order to prevent my simulation from crashing right away , I had , for the inlet:

type totalPressure;
gamma 1.400000;
rho rho;
p0 uniform 29400.000000;
value uniform 26500.000000;

the 26500 was the static pressure and that was set to fixed at the outlet. I was not able to get the flow to a Mach number above 0.4 without it eventually crashing. Relaxation factors helped a bit.

So, again, it was a combination of factors and tweaks of residuals, relaxation factors, geometry and boundary conditions that yielded a converged solution.
mihaipruna is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
swak4foam can not be installed hugo17 OpenFOAM Installation 1 September 11, 2012 05:17
reactingFoam crashes mysteriously jose_rodrig OpenFOAM Running, Solving & CFD 8 June 26, 2012 04:42
flo-efd v11.0.0 crashes YoavF FloEFD, FloWorks & FloTHERM 3 June 21, 2012 12:37
use of Gturbo to make turbine blade usman FLUENT 0 December 31, 2007 06:47
[Q]How to make MPEGs with CFD datas??? Bum-Seok Hyun Main CFD Forum 4 February 16, 2000 19:59


All times are GMT -4. The time now is 11:06.