CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

funkySetFields compilation error

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   September 6, 2012, 13:47
Default funkySetFields compilation error
  #1
Member
 
Tayo
Join Date: Aug 2012
Location: FL
Posts: 94
Rep Power: 4
tayo is on a distinguished road
Hi,

I use OF version 2.1.1 and I used svn checkout to downloaded swak4Foam version 2.0. Since I only need funkysetFields for my project, I navigated to the folder and tried to compile it alone but it gave me the error below. Please how do I go about this. Do I get the files- FieldValueExpressionDriver.H, printSwakVersion.H, etc? How do I fix this? I'm new to openfoam. Thanks

Making dependency list for source file funkySetFields.C
could not open file FieldValueExpressionDriver.H for source file funkySetFields.C
could not open file printSwakVersion.H for source file funkySetFields.C
SOURCE=funkySetFields.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/opt/openfoam211/src/finiteVolume/lnInclude -I/opt/openfoam211/src/meshTools/lnInclude -I../../Libraries/swak4FoamParsers/lnInclude/ -IlnInclude -I. -I/opt/openfoam211/src/OpenFOAM/lnInclude -I/opt/openfoam211/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/funkySetFields.o
funkySetFields.C:41:40: fatal error: FieldValueExpressionDriver.H: No such file or directory
compilation terminated.
make: *** [Make/linux64GccDPOpt/funkySetFields.o] Error 1
tayo is offline   Reply With Quote

Old   September 6, 2012, 14:15
Default
  #2
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,912
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tayo View Post
Hi,

I use OF version 2.1.1 and I used svn checkout to downloaded swak4Foam version 2.0. Since I only need funkysetFields for my project, I navigated to the folder and tried to compile it alone but it gave me the error below. Please how do I go about this. Do I get the files- FieldValueExpressionDriver.H, printSwakVersion.H, etc? How do I fix this? I'm new to openfoam. Thanks

Making dependency list for source file funkySetFields.C
could not open file FieldValueExpressionDriver.H for source file funkySetFields.C
could not open file printSwakVersion.H for source file funkySetFields.C
SOURCE=funkySetFields.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/opt/openfoam211/src/finiteVolume/lnInclude -I/opt/openfoam211/src/meshTools/lnInclude -I../../Libraries/swak4FoamParsers/lnInclude/ -IlnInclude -I. -I/opt/openfoam211/src/OpenFOAM/lnInclude -I/opt/openfoam211/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/funkySetFields.o
funkySetFields.C:41:40: fatal error: FieldValueExpressionDriver.H: No such file or directory
compilation terminated.
make: *** [Make/linux64GccDPOpt/funkySetFields.o] Error 1
Sorry. No can-do. You'll have to join the whole cult: essential functionality of funkySetFields have been moved to a separate library that is part of swak4Foam (the swak4FoamParsers). It is possible to compile that on its own and compile FSF using only that but as a beginner it would be easier for you to compile swak4Foam as a whole. It won't do any damage to your installation and you don't have to use the other parts. It's a tolerant cult
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   September 6, 2012, 14:32
Default
  #3
Member
 
Tayo
Join Date: Aug 2012
Location: FL
Posts: 94
Rep Power: 4
tayo is on a distinguished road
Even after I tried compiling the entire swak4Foam, it still gave the same error about the funkySetFields. What do I do? Please help.
tayo is offline   Reply With Quote

Old   September 6, 2012, 14:42
Default
  #4
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,912
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tayo View Post
Even after I tried compiling the entire swak4Foam, it still gave the same error about the funkySetFields. What do I do? Please help.
Is this the FSF you got solo via SVN? Then it is explainable. Or is it the FSF in the swak source tree? Then it is strange (if you compiled swak4Foam with the Allwmake-script)
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   September 6, 2012, 14:55
Default
  #5
Member
 
Tayo
Join Date: Aug 2012
Location: FL
Posts: 94
Rep Power: 4
tayo is on a distinguished road
I got the swak4Foam straight using the command below. Could this be the problem? Because I checked the funckSetFields directory on the website itself and it does not have these files: FieldValueExpressionDriver.H and others. Please what other way can I use in compiling it. Thanks
svn checkout https://openfoam-extend.svn.sourceforge.net/svnroot/openfoam-extend/trunk/Breeder_2.0/
tayo is offline   Reply With Quote

Old   September 6, 2012, 16:35
Default
  #6
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,912
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tayo View Post
I got the swak4Foam straight using the command below. Could this be the problem? Because I checked the funckSetFields directory on the website itself and it does not have these files: FieldValueExpressionDriver.H and others. Please what other way can I use in compiling it. Thanks
svn checkout https://openfoam-extend.svn.sourceforge.net/svnroot/openfoam-extend/trunk/Breeder_2.0/
That should be OK (that's the last released version). And in that directory you ran ./Allwmake and then the error happened? FSF is the last thing compiled so the first error would be very good to see
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   September 6, 2012, 17:36
Default
  #7
Member
 
Tayo
Join Date: Aug 2012
Location: FL
Posts: 94
Rep Power: 4
tayo is on a distinguished road
OK. These are the first set of errors that show up when I run the code. From the first set of errors, I'm thinking I might have missed an important installation step. Here is what I did: I installed the svn and then did the svn checkout, and finally the ./Allwmake. Did I miss anything? Thanks

tayo@ubuntu:~/OpenFOAM/tayo-2.1.1/src/swak4Foam$ ./Allwmake
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
./Allwmake: 9: [[: not found
./Allwmake: 17: [[: not found
./Allwmake: 19: bison: not found
Bison is version
./Allwmake: 33: cannot open 2.3: No such file
./Allwmake: 33: [[: not found
OpenFOAM-version: Major 2 Minor 1 Patch 1
No swak4FoamParsers/foamVersion4swak.H. Generated
wmakeLnInclude: linking include files to ./lnInclude
Making dependency list for source file printSwakVersion.C
Making dependency list for source file SurfacesRepository.C
Making dependency list for source file SetsRepository.C
Making dependency list for source file GlobalVariablesRepository.C
Making dependency list for source file ExpressionDriverWriter.C
Making dependency list for source file ExpressionResult.C
Making dependency list for source file StoredExpressionResult.C
Making dependency list for source file swakRegistryProxySurface.C
Making dependency list for source file swakRegistryProxySet.C
Making dependency list for source file FieldValueExpressionParser.yy
could not open file FieldValueExpressionParser.tab.hh for source file FieldValueExpressionParser.yy
could not open file FixedValuePointPatchField.H for source file FieldValueExpressionParser.yy
could not open file ZeroGradientPointPatchField.H for source file FieldValueExpressionParser.yy
could not open file CalculatedPointPatchField.H for source file FieldValueExpressionParser.yy
Making dependency list for source file PatchValueExpressionParser.yy
could not open file PatchValueExpressionParser.tab.hh for source file PatchValueExpressionParser.yy
Making dependency list for source file SubsetValueExpressionParser.yy
could not open file SubsetValueExpressionParser.tab.hh for source file SubsetValueExpressionParser.yy
Making dependency list for source file CommonValueExpressionDriver.C
Making dependency list for source file makeSwakDataEntry.C
Making dependency list for source file FieldValueExpressionLexer.ll
could not open file FieldValueExpressionParser.tab.hh for source file FieldValueExpressionLexer.ll
could not open file FixedValuePointPatchField.H for source file FieldValueExpressionLexer.ll
could not open file ZeroGradientPointPatchField.H for source file FieldValueExpressionLexer.ll
could not open file CalculatedPointPatchField.H for source file FieldValueExpressionLexer.ll
Making dependency list for source file FieldValueExpressionDriver.C
could not open file FieldValueExpressionParser.tab.hh for source file FieldValueExpressionDriver.C
could not open file FixedValuePointPatchField.H for source file FieldValueExpressionDriver.C
could not open file ZeroGradientPointPatchField.H for source file FieldValueExpressionDriver.C
could not open file CalculatedPointPatchField.H for source file FieldValueExpressionDriver.C
Making dependency list for source file PatchValueExpressionLexer.ll
could not open file PatchValueExpressionParser.tab.hh for source file PatchValueExpressionLexer.ll
Making dependency list for source file PatchValueExpressionDriver.C
could not open file PatchValueExpressionParser.tab.hh for source file PatchValueExpressionDriver.C
could not open file FieldValueExpressionParser.tab.hh for source file PatchValueExpressionDriver.C
could not open file FixedValuePointPatchField.H for source file PatchValueExpressionDriver.C
could not open file ZeroGradientPointPatchField.H for source file PatchValueExpressionDriver.C
could not open file CalculatedPointPatchField.H for source file PatchValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file PatchValueExpressionDriver.C
Making dependency list for source file SubsetValueExpressionLexer.ll
could not open file SubsetValueExpressionParser.tab.hh for source file SubsetValueExpressionLexer.ll
Making dependency list for source file SubsetValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file SubsetValueExpressionDriver.C
Making dependency list for source file SetSubsetValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file SetSubsetValueExpressionDriver.C
Making dependency list for source file CellSetValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file CellSetValueExpressionDriver.C
Making dependency list for source file FaceSetValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file FaceSetValueExpressionDriver.C
Making dependency list for source file CellZoneValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file CellZoneValueExpressionDriver.C
Making dependency list for source file FaceZoneValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file FaceZoneValueExpressionDriver.C
Making dependency list for source file SampledSurfaceValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file SampledSurfaceValueExpressionDriver.C
Making dependency list for source file SampledSetValueExpressionDriver.C
could not open file SubsetValueExpressionParser.tab.hh for source file SampledSetValueExpressionDriver.C
Making dependency list for source file initSwakFunctionObject.C

Last edited by tayo; September 6, 2012 at 18:02.
tayo is offline   Reply With Quote

Old   September 6, 2012, 18:11
Default
  #8
Member
 
Tayo
Join Date: Aug 2012
Location: FL
Posts: 94
Rep Power: 4
tayo is on a distinguished road
And eventually, these are the last sets of errors that does not make funkySetFields compile. What is Python and bison? What do I do from here?

make: *** [Make/linux64GccDPOpt/groovyTotalPressureFvPatchScalarField.o] Error 1
SWAK_PYTHON_INCLUDE not defined .... no Python-Integration
Making dependency list for source file funkyDoCalc.C
make[1]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/src/swak4Foam/Utilities/funkyDoCalc'
SOURCE=funkyDoCalc.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/opt/openfoam211/src/finiteVolume/lnInclude -I/opt/openfoam211/src/meshTools/lnInclude -I../../Libraries/swak4FoamParsers/lnInclude/ -IlnInclude -I. -I/opt/openfoam211/src/OpenFOAM/lnInclude -I/opt/openfoam211/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/funkyDoCalc.o
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/opt/openfoam211/src/finiteVolume/lnInclude -I/opt/openfoam211/src/meshTools/lnInclude -I../../Libraries/swak4FoamParsers/lnInclude/ -IlnInclude -I. -I/opt/openfoam211/src/OpenFOAM/lnInclude -I/opt/openfoam211/src/OSspecific/POSIX/lnInclude -fPIC -Xlinker --add-needed -Xlinker --no-as-needed Make/linux64GccDPOpt/funkyDoCalc.o -L/opt/openfoam211/platforms/linux64GccDPOpt/lib \
-lfiniteVolume -lmeshTools -L/home/tayo/OpenFOAM/tayo-2.1.1/platforms/linux64GccDPOpt/lib -lswak4FoamParsers -lOpenFOAM -ldl -lm -o /home/tayo/OpenFOAM/tayo-2.1.1/platforms/linux64GccDPOpt/bin/funkyDoCalc
/usr/bin/ld: cannot find -lswak4FoamParsers
collect2: ld returned 1 exit status
make[1]: *** [/home/tayo/OpenFOAM/tayo-2.1.1/platforms/linux64GccDPOpt/bin/funkyDoCalc] Error 1
make[1]: Leaving directory `/home/tayo/OpenFOAM/tayo-2.1.1/src/swak4Foam/Utilities/funkyDoCalc'
make: *** [funkyDoCalc] Error 2
Making dependency list for source file funkySetBoundaryField.C
could not open file PatchValueExpressionParser.tab.hh for source file funkySetBoundaryField.C
make[1]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/src/swak4Foam/Utilities/funkySetBoundaryField'
SOURCE=funkySetBoundaryField.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/opt/openfoam211/src/finiteVolume/lnInclude -I/opt/openfoam211/src/meshTools/lnInclude -I../../Libraries/swak4FoamParsers/lnInclude/ -IlnInclude -I. -I/opt/openfoam211/src/OpenFOAM/lnInclude -I/opt/openfoam211/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/funkySetBoundaryField.o
In file included from funkySetBoundaryField.C:41:0:
../../Libraries/swak4FoamParsers/lnInclude/PatchValueExpressionDriver.H:60:45: fatal error: PatchValueExpressionParser.tab.hh: No such file or directory
compilation terminated.
make[1]: *** [Make/linux64GccDPOpt/funkySetBoundaryField.o] Error 1
make[1]: Target `/home/tayo/OpenFOAM/tayo-2.1.1/platforms/linux64GccDPOpt/bin/funkySetBoundaryField' not remade because of errors.
make[1]: Leaving directory `/home/tayo/OpenFOAM/tayo-2.1.1/src/swak4Foam/Utilities/funkySetBoundaryField'
make: *** [funkySetBoundaryField] Error 2
Making dependency list for source file funkySetFields.C
could not open file FieldValueExpressionParser.tab.hh for source file funkySetFields.C
could not open file FixedValuePointPatchField.H for source file funkySetFields.C
could not open file ZeroGradientPointPatchField.H for source file funkySetFields.C
could not open file CalculatedPointPatchField.H for source file funkySetFields
.C
make[1]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/src/swak4Foam/Utilities/funkySetFields'
SOURCE=funkySetFields.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -IMake/linux64GccDPOpt -I/opt/openfoam211/src/finiteVolume/lnInclude -I/opt/openfoam211/src/meshTools/lnInclude -I../../Libraries/swak4FoamParsers/lnInclude/ -IlnInclude -I. -I/opt/openfoam211/src/OpenFOAM/lnInclude -I/opt/openfoam211/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/funkySetFields.o
In file included from funkySetFields.C:41:0:
../../Libraries/swak4FoamParsers/lnInclude/FieldValueExpressionDriver.H:19:45: fatal error: FieldValueExpressionParser.tab.hh: No such file or directory
compilation terminated.
make[1]: *** [Make/linux64GccDPOpt/funkySetFields.o] Error 1
make[1]: Target `/home/tayo/OpenFOAM/tayo-2.1.1/platforms/linux64GccDPOpt/bin/funkySetFields' not remade because of errors.
make[1]: Leaving directory `/home/tayo/OpenFOAM/tayo-2.1.1/src/swak4Foam/Utilities/funkySetFields'
make: *** [funkySetFields] Error 2
Making dependency list for source file replayTransientBC.C
make[1]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/src/swak4Foam/Utilities/replayTransientBC'
SOURCE=replayTransientBC.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -I/opt/openfoam211/src/cfdTools/lnInclude -I/opt/openfoam211/src/cfdTools/general/lnInclude -I/opt/openfoam211/src/finiteVolume/lnInclude -I/opt/openfoam211/src/meshTools/lnInclude -IlnInclude -I. -I/opt/openfoam211/src/OpenFOAM/lnInclude -I/opt/openfoam211/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/replayTransientBC.o
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-100 -I/opt/openfoam211/src/cfdTools/lnInclude -I/opt/openfoam211/src/cfdTools/general/lnInclude -I/opt/openfoam211/src/finiteVolume/lnInclude -I/opt/openfoam211/src/meshTools/lnInclude -IlnInclude -I. -I/opt/openfoam211/src/OpenFOAM/lnInclude -I/opt/openfoam211/src/OSspecific/POSIX/lnInclude -fPIC -Xlinker --add-needed -Xlinker --no-as-needed Make/linux64GccDPOpt/replayTransientBC.o -L/opt/openfoam211/platforms/linux64GccDPOpt/lib \
-lfiniteVolume -lmeshTools -lOpenFOAM -ldl -lm -o /home/tayo/OpenFOAM/tayo-2.1.1/platforms/linux64GccDPOpt/bin/replayTransientBC
make[1]: Leaving directory `/home/tayo/OpenFOAM/tayo-2.1.1/src/swak4Foam/Utilities/replayTransientBC'
make: Target `application' not remade because of errors.
tayo is offline   Reply With Quote

Old   September 6, 2012, 18:15
Default
  #9
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,912
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tayo View Post
OK. These are the first set of errors that show up when I run the code. From the first set of errors, I'm thinking I might have missed an important installation step. Here is what I did: I installed the svn and then did the svn checkout, and finally the ./Allwmake. Did I miss anything? Thanks

tayo@ubuntu:~/OpenFOAM/tayo-2.1.1/src/swak4Foam$ ./Allwmake
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
./Allwmake: 9: [[: not found
./Allwmake: 17: [[: not found
./Allwmake: 19: bison: not found
Bison is version
./Allwmake: 33: cannot open 2.3: No such file
./Allwmake: 33: [[: not found
OpenFOAM-version: Major 2 Minor 1 Patch 1
No swak4FoamParsers/foamVersion4swak.H. Generated
wmakeLnInclude: linking include files to ./lnInclude
Making dependency list for source file printSwakVersion.C
OK. That is not the problem yet (must be bit further down). Minor problem is the business with the "[[" (that is when the script tests whether flex and bison are installed. BTW: you've got these installed, right?). To make that go away replace in the first line of Libraries/Allwmake /bin/sh with /bin/bash
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   September 6, 2012, 18:23
Default
  #10
Member
 
Tayo
Join Date: Aug 2012
Location: FL
Posts: 94
Rep Power: 4
tayo is on a distinguished road
Quote:
Originally Posted by gschaider View Post
OK. That is not the problem yet (must be bit further down). Minor problem is the business with the "[[" (that is when the script tests whether flex and bison are installed. BTW: you've got these installed, right?). To make that go away replace in the first line of Libraries/Allwmake /bin/sh with /bin/bash
Thanks for your help.
No. I don't even know what bison or flex are. Guess the problem starts from here. How do I install them? What about python? Because I've not installed either of these. The basic installation is what I've said earlier. 1) Installed OpenFOAM, then installed svn, then did svn checkout and finally tried to compile swak4Foam. What the list of things that I have to install? Pls provide the link to them. Thanks.
tayo is offline   Reply With Quote

Old   September 6, 2012, 19:27
Default
  #11
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,912
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tayo View Post
Thanks for your help.
No. I don't even know what bison or flex are. Guess the problem starts from here. How do I install them? What about python? Because I've not installed either of these. The basic installation is what I've said earlier. 1) Installed OpenFOAM, then installed svn, then did svn checkout and finally tried to compile swak4Foam. What the list of things that I have to install? Pls provide the link to them. Thanks.
flex and bison are absolutely essential. The parser (the part that "understands" the expressions) is implemented in them. The old standalone funkySetFields wouldn't compile without them too, so swak doesn't make things worse here.

The python thing shouldn't concern you. This is just an optional feature of swak and it won't be compile (an therefor can't fail) if not properly configured. The message you see is just a notification

Anyway. Make sure that the commands flex and bison are installed. Usually they are in packages of the same name
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   September 7, 2012, 16:26
Default
  #12
Member
 
Tayo
Join Date: Aug 2012
Location: FL
Posts: 94
Rep Power: 4
tayo is on a distinguished road
Hi Bernhard,

Thanks for yesterday. So I tried to install bison and flex. I individually downloaded bison-2.6 and flex version 2.5.36 from http://ftp.gnu.org/gnu/bison/ and http://flex.sourceforge.net/. Then I went into each directory to apply the following command:

./configure
make
sudo make install

These are the later part of what was displayed after installing the bison. I don't understand why it's entering and leaving each directory with "nothing to be done for all".

make all-recursive
make[1]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/bison-2.6'
Making all in build-aux
make[2]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/bison-2.6/build-aux'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/tayo/OpenFOAM/tayo-2.1.1/bison-2.6/build-aux'
Making all in po
make[2]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/bison-2.6/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/tayo/OpenFOAM/tayo-2.1.1/bison-2.6/po'
Making all in runtime-po
make[2]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/bison-2.6/runtime-po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/tayo/OpenFOAM/tayo-2.1.1/bison-2.6/runtime-po'
Making all in lib
make[2]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/bison-2.6/lib'



For the flex, these were the later stuffs that were displayed.




make[2]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/flex-2.5.36'
make[3]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/flex-2.5.36'
test -z "/usr/local/bin" || /bin/mkdir -p "/usr/local/bin"
/usr/bin/install -c flex '/usr/local/bin'
test -z "/usr/local/lib" || /bin/mkdir -p "/usr/local/lib"
/usr/bin/install -c -m 644 libfl.a libfl_pic.a '/usr/local/lib'
( cd '/usr/local/lib' && ranlib libfl.a )
( cd '/usr/local/lib' && ranlib libfl_pic.a )
make install-exec-hook
make[4]: Entering directory `/home/tayo/OpenFOAM/tayo-2.1.1/flex-2.5.36'
cd //usr/local/bin && \
ln -s flex flex++
ln: creating symbolic link `flex++': File exists
make[4]: *** [install-exec-hook] Error 1
make[4]: Leaving directory `/home/tayo/OpenFOAM/tayo-2.1.1/flex-2.5.36'
make[3]: *** [install-exec-am] Error 2
make[3]: Leaving directory `/home/tayo/OpenFOAM/tayo-2.1.1/flex-2.5.36'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/home/tayo/OpenFOAM/tayo-2.1.1/flex-2.5.36'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/tayo/OpenFOAM/tayo-2.1.1/flex-2.5.36'
make: *** [install] Error 2



and ultimately, I just tried to install the swak4Foam to see the first few messages that will be displayed. Here is what is got. I'm not even sure if Bison is really installed or not, let alone the flex, but note that while running swak4Foam, it displayed "Bison is version 2.6". Please what do I do? I am not able to properly install flex or bison. All I want to do is to use funkySetFields.
I am not experienced in this at all. Please help.



tayo@ubuntu:~/OpenFOAM/tayo-2.1.1/src/swak4Foam$ ./Allwmake
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
./Allwmake: 9: [[: not found
./Allwmake: 17: [[: not found
Bison is version 2.6
./Allwmake: 33: cannot open 2.3: No such file
./Allwmake: 33: [[: not found
OpenFOAM-version: Major 2 Minor 1 Patch 1
No swak4FoamParsers/foamVersion4swak.H. Generated
wmakeLnInclude: linking include files to ./lnInclude
Making dependency list for source file printSwakVersion.C
Making dependency list for source file SurfacesRepository.C
Making dependency list for source file SetsRepository.C
Making dependency list for source file GlobalVariablesRepository.C
Making dependency list for source file ExpressionDriverWriter.C
Making dependency list for source file ExpressionResult.C
Making dependency list for source file StoredExpressionResult.C
Making dependency list for source file swakRegistryProxySurface.C
Making dependency list for source file swakRegistryProxySet.C
Making dependency list for source file FieldValueExpressionParser.yy
could not open file FieldValueExpressionParser.tab.hh for source file FieldValueExpressionParser.yy
could not open file FixedValuePointPatchField.H for source file FieldValueExpressionParser.yy

Last edited by tayo; September 7, 2012 at 16:50.
tayo is offline   Reply With Quote

Old   September 7, 2012, 16:46
Default
  #13
Member
 
Tayo
Join Date: Aug 2012
Location: FL
Posts: 94
Rep Power: 4
tayo is on a distinguished road
I also tried installing bison and flex using the code below. And yet there was nothing really tangible. Here is what was displayed for each. Please just advice on what can be done. Thanks

sudo apt-get install flex
and
sudo apt-get install bison


tayo@ubuntu:~/Documents$ sudo apt-get install flex
Reading package lists... Done
Building dependency tree
Reading state information... Done
flex is already the newest version.
The following packages were automatically installed and are no longer required:
libstdc++6:i386 libxfixes3:i386 ia32-libs-multiarch:i386 libqt4-declarative:i386
liblcms1:i386 libqt4-qt3support:i386 libcupsimage2:i386 libnss3:i386 libqt4-test:i386
libqt4-script:i386 libqt4-designer:i386 libqt4-network:i386 libqt4-dbus:i386
libxxf86vm1:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386
libfreetype6:i386 libqt4-opengl:i386 libexpat1:i386 libqt4-xmlpatterns:i386
libavahi-common-data:i386 libxcb1:i386 libxau6:i386 libgdbm3:i386 libcups2:i386
libqtcore4:i386 libice6:i386 libxdmcp6:i386 libqt4-sql:i386 libqt4-svg:i386
libxrender1:i386 libnspr4:i386 libqt4-xml:i386 libxss1:i386 libtiff4:i386 libpng12-0:i386
libjpeg62:i386 libqtgui4:i386 libavahi-client3:i386 libx11-6:i386 libfontconfig1:i386
libsm6:i386 libxdamage1:i386 libqt4-scripttools:i386 libxi6:i386 libaudio2:i386 libxt6:i386
libxext6:i386 libavahi-common3:i386 libsqlite3-0:i386 libmng1:i386 libllvm2.9:i386
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Here is what was displayed for bison
.


tayo@ubuntu:~/Documents$ sudo apt-get install bison
Reading package lists... Done
Building dependency tree
Reading state information... Done
bison is already the newest version.
The following packages were automatically installed and are no longer required:
libstdc++6:i386 libxfixes3:i386 ia32-libs-multiarch:i386 libqt4-declarative:i386
liblcms1:i386 libqt4-qt3support:i386 libcupsimage2:i386 libnss3:i386 libqt4-test:i386
libqt4-script:i386 libqt4-designer:i386 libqt4-network:i386 libqt4-dbus:i386
libxxf86vm1:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386
libfreetype6:i386 libqt4-opengl:i386 libexpat1:i386 libqt4-xmlpatterns:i386
libavahi-common-data:i386 libxcb1:i386 libxau6:i386 libgdbm3:i386 libcups2:i386
libqtcore4:i386 libice6:i386 libxdmcp6:i386 libqt4-sql:i386 libqt4-svg:i386
libxrender1:i386 libnspr4:i386 libqt4-xml:i386 libxss1:i386 libtiff4:i386 libpng12-0:i386
libjpeg62:i386 libqtgui4:i386 libavahi-client3:i386 libx11-6:i386 libfontconfig1:i386
libsm6:i386 libxdamage1:i386 libqt4-scripttools:i386 libxi6:i386 libaudio2:i386 libxt6:i386
libxext6:i386 libavahi-common3:i386 libsqlite3-0:i386 libmng1:i386 libllvm2.9:i386
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
tayo is offline   Reply With Quote

Old   September 8, 2012, 14:52
Default
  #14
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings to all!

@Tayo: You seem to have missed Bernhard's previous instructions:
Quote:
Originally Posted by gschaider View Post
OK. That is not the problem yet (must be bit further down). Minor problem is the business with the "[[" (that is when the script tests whether flex and bison are installed. BTW: you've got these installed, right?). To make that go away replace in the first line of Libraries/Allwmake /bin/sh with /bin/bash
To fix these, you can run:
Code:
sed -i -e 's=/bin/sh=/bin/bash=' Libraries/Allwmake
But indeed, these warnings/errors don't affect the building process.


Now, as for the real problem:
  • I was going to ask which Linux distribution you are using, but I'm guessing you're using Ubuntu 12.04.
  • Additionally, I'm guessing you're trying to build the whole swak4Foam on the same folders where you've already tried to build funkySetFields.
  • Therefore, the solution could/should be for you to run in swak4Foam's main folder the following commands:
    Code:
    ./Allwclean
    ./Allwmake
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   September 8, 2012, 17:52
Default
  #15
Member
 
Tayo
Join Date: Aug 2012
Location: FL
Posts: 94
Rep Power: 4
tayo is on a distinguished road
Thanks Bruno,

I use ubuntu 11.10. I've replaced the Libraries/Allwmake/bin/sh with bin/bash. Also I use wclean all before I use ./Allwmake again. I think the problem is kind of clear now: I don't have flex properly installed yet. I think funkySetField.C needs the FixedValuePointPatchField.H file that comes from the flex installation as Bernhard pointed out. Presently, I'm trying to install flex with no progress (surprising). I guess once that is done, funkySetField should be fine.
tayo is offline   Reply With Quote

Old   September 8, 2012, 19:22
Default
  #16
Member
 
Tayo
Join Date: Aug 2012
Location: FL
Posts: 94
Rep Power: 4
tayo is on a distinguished road
This might not be the best place for this but please I need help installing flex because I need it to properly install swak4Foam. I tried using sudo apt-get install flex and it won't just install. Here what I get.

tayo@ubuntu:~$ sudo apt-get install flex
Reading package lists... Done
Building dependency tree
Reading state information... Done
flex is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Then, I tried some online guide that states that I must first install a m4 (general purpose micro processor) before installing flex. I did that and then downloaded flex, extracted it, entered the flex directory and did the following:
./configure
make
sudo make install

Some of the later msg is given below. What can I do? I need this flex to use funkySetFields on swak4Foam. Please help

make[4]: Nothing to be done for `install-exec-am'.
make[4]: Nothing to be done for `install-data-am'.
make[4]: Leaving directory `/home/tayo/flex-2.5.33/tests/test-table-opts'
make[3]: Leaving directory `/home/tayo/flex-2.5.33/tests/test-table-opts'
make[3]: Entering directory `/home/tayo/flex-2.5.33/tests'
make[4]: Entering directory `/home/tayo/flex-2.5.33/tests'
make[4]: Nothing to be done for `install-exec-am'.
make[4]: Nothing to be done for `install-data-am'.
make[4]: Leaving directory `/home/tayo/flex-2.5.33/tests'
make[3]: Leaving directory `/home/tayo/flex-2.5.33/tests'
make[2]: Leaving directory `/home/tayo/flex-2.5.33/tests'
make[1]: Leaving directory `/home/tayo/flex-2.5.33'
tayo is offline   Reply With Quote

Old   September 9, 2012, 03:49
Default
  #17
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Tayo,

By what I can remember, you'll need at least flex 2.5.35. Nonetheless, with Ubuntu 11.10, you do not need to build a custom flex.

Try these steps:
  1. Remove any custom installations you've made.
  2. Then try this:
    Code:
    sudo apt-get purge flex
    sudo apt-get install flex
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   September 10, 2012, 01:00
Default
  #18
Member
 
Tayo
Join Date: Aug 2012
Location: FL
Posts: 94
Rep Power: 4
tayo is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
By what I can remember, you'll need at least flex 2.5.35. Nonetheless, with Ubuntu 11.10, you do not need to build a custom flex.

Try these steps:
  1. Remove any custom installations you've made.
  2. Then try this:
    Code:
    sudo apt-get purge flex
    sudo apt-get install flex
Thanks, I tried it. For some reason, the purge flex uninstalled openfoam along with the flex from my pc. Anyways, I simply backed up my OF files and reinstalled flex as advised and then reinstalled openfoam. Everything seemed fine and I even checked for flex on my ubuntu software center and it shows that I have flex 2.5.35-10ubuntu1 installed. Bison is also installed. Then, I tried to compile the whole swak4Foam and same error again "could not open file FixedValuePointPatchField.H for source file funkySetFields.C". Could it be that I need to update the default flex version to a more current version e.g. Flex.2.5.37 since the 2.5.35 is pretty old (since 2008). I really don't know what I can do.

Last edited by tayo; September 10, 2012 at 01:21.
tayo is offline   Reply With Quote

Old   September 10, 2012, 03:19
Default
  #19
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Tayo,

I'm using Ubuntu 11.10 x86_64 and have successfully built swak4Foam several times on it, with several OpenFOAM versions, without the need to install custom versions of flex and bison.

It's possible that something got broken with all of these steps you've been doing, so I would advise you to get a new copy of swak4Foam from the SVN and try again!

Which reminds me... From your description, you seem to have installed the Deb package of OpenFOAM. Try installing the "build-essentials" package, just in case you don't have it yet:
Code:
sudo apt-get install build-essential
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   September 10, 2012, 04:24
Default
  #20
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,912
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by tayo View Post
Thanks, I tried it. For some reason, the purge flex uninstalled openfoam along with the flex from my pc. Anyways, I simply backed up my OF files and reinstalled flex as advised and then reinstalled openfoam. Everything seemed fine and I even checked for flex on my ubuntu software center and it shows that I have flex 2.5.35-10ubuntu1 installed. Bison is also installed. Then, I tried to compile the whole swak4Foam and same error again "could not open file FixedValuePointPatchField.H for source file funkySetFields.C". Could it be that I need to update the default flex version to a more current version e.g. Flex.2.5.37 since the 2.5.35 is pretty old (since 2008). I really don't know what I can do.
The age is not a problem. I use 2.5.35 on the development version myself.The errors about the missing FixedValuePointPatchField.H should not concern you. That is only the dependency analysis for the sources which can not copy with some #ifdefs that are needed to make the sources compatible with the ext-version
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Native ParaView Reader Bugs tj22 OpenFOAM Paraview & paraFoam 266 July 1, 2015 02:00
OpenFOAM install on Ubuntu Natty 11.04 bkubicek OpenFOAM 13 May 26, 2011 05:48
OpenFOAM on MinGW crosscompiler hosted on Linux allenzhao OpenFOAM Installation 127 January 30, 2009 20:08
Compiling problems with hello worldC fw407 OpenFOAM Installation 21 January 6, 2008 18:38
user defined function cfduser CFX 0 April 29, 2006 10:58


All times are GMT -4. The time now is 03:58.