CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

Foam_user_libbin

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By chegdan

Reply
 
LinkBack Thread Tools Display Modes
Old   November 26, 2013, 11:13
Default Foam_user_libbin
  #1
Member
 
Salam Hassan
Join Date: Nov 2013
Posts: 46
Rep Power: 5
Salam-H is on a distinguished road
HI every one. I am trying to find $FOAM_USER_LIBBIN on my computer, I dont know where it is, I have checked every where. I think when I installed OpenFOAM this folder had been missed, I reinstalled OF many times and yet cannot find the folder. Any suggestions please?

Thank you for you help in advance.

Salam
Salam-H is offline   Reply With Quote

Old   November 26, 2013, 14:58
Default
  #2
Senior Member
 
chegdan's Avatar
 
Daniel P. Combest
Join Date: Mar 2009
Location: St. Louis, USA
Posts: 585
Rep Power: 20
chegdan will become famous soon enoughchegdan will become famous soon enough
if your OpenFOAM installation is installed correctly, go to your terminal and type

Code:
echo $FOAM_USER_LIBBIN
to go there, use

Code:
cd $FOAM_USER_LIBBIN
if OpenFOAM is not installed correctly....then you have more problems.
babakflame likes this.
__________________
Dan

Find me on twitter @dancombest and LinkedIn
chegdan is offline   Reply With Quote

Old   November 26, 2013, 15:07
Default
  #3
Member
 
Salam Hassan
Join Date: Nov 2013
Posts: 46
Rep Power: 5
Salam-H is on a distinguished road
Quote:
Originally Posted by chegdan View Post
if your OpenFOAM installation is installed correctly, go to your terminal and type

Code:
echo $FOAM_USER_LIBBIN
to go there, use

Code:
cd $FOAM_USER_LIBBIN
if OpenFOAM is not installed correctly....then you have more problems.
Hello there,

Thanks a lot for replying, I have done exactly what you have suggested , it seems like I do have the folder. However when I try to run a blockMesh, I get an error which I dont know how to fix it, I thought it might be due to the lack of lib but I can see that I have it. Do you think if I send you the error , you have time to help me please? I really need some help please.

regards,

salam
Salam-H is offline   Reply With Quote

Old   November 26, 2013, 15:23
Default
  #4
Senior Member
 
chegdan's Avatar
 
Daniel P. Combest
Join Date: Mar 2009
Location: St. Louis, USA
Posts: 585
Rep Power: 20
chegdan will become famous soon enoughchegdan will become famous soon enough
Without more information i really can't help you. Have a look through

How to give enough info to get help

And then try to be more descriptive with your question and then i bet more people will help you and get you moving forward.
__________________
Dan

Find me on twitter @dancombest and LinkedIn
chegdan is offline   Reply With Quote

Old   November 26, 2013, 15:37
Default
  #5
Member
 
Salam Hassan
Join Date: Nov 2013
Posts: 46
Rep Power: 5
Salam-H is on a distinguished road
Quote:
Originally Posted by chegdan View Post
Without more information i really can't help you. Have a look through

How to give enough info to get help

And then try to be more descriptive with your question and then i bet more people will help you and get you moving forward.
Hi again, I home I am not bothering you a lot. I truely appreciate your help. I have modelled a case, where I have water in a funnel, the water has to flow out from the funnel. In real life , it takes about 26 seconds for the volume of water to leave the funnel. However when I tried in Openfoam every thing seemed to be fine apart form plotting graphs, such as Alpha1 (VOF ) against Actual time, I tried and I couldn't find the way of doing it. Then suddenly I found a tutorial online, which does exactly what I want, but using Swak4Foam rather than ParaFoam, and I am trying to model the same case but I get error message from the first step, I have attached the error message to this quote and the case which I am trying to run can be found in the following link :

https://www.hpc.ntnu.no/display/hpc/...Postprocessing

I did install swak4foam and all the necessary files I believe.

I would be forever grateful for any help .

Best regards

Salam
Attached Files
File Type: doc logfile.doc (29.0 KB, 4 views)
Salam-H is offline   Reply With Quote

Old   November 26, 2013, 15:41
Default
  #6
Member
 
Salam Hassan
Join Date: Nov 2013
Posts: 46
Rep Power: 5
Salam-H is on a distinguished road
Quote:
Originally Posted by Salam-H View Post
Hi again, I home I am not bothering you a lot. I truely appreciate your help. I have modelled a case, where I have water in a funnel, the water has to flow out from the funnel. In real life , it takes about 26 seconds for the volume of water to leave the funnel. However when I tried in Openfoam every thing seemed to be fine apart form plotting graphs, such as Alpha1 (VOF ) against Actual time, I tried and I couldn't find the way of doing it. Then suddenly I found a tutorial online, which does exactly what I want, but using Swak4Foam rather than ParaFoam, and I am trying to model the same case but I get error message from the first step, I have attached the error message to this quote and the case which I am trying to run can be found in the following link :

https://www.hpc.ntnu.no/display/hpc/...Postprocessing

I did install swak4foam and all the necessary files I believe.

I would be forever grateful for any help .

Best regards

Salam

I uploaded a wrong file in the previous quote, this is the error message.
Attached Files
File Type: doc error.doc (24.7 KB, 5 views)
Salam-H is offline   Reply With Quote

Old   November 26, 2013, 15:44
Default
  #7
Senior Member
 
chegdan's Avatar
 
Daniel P. Combest
Join Date: Mar 2009
Location: St. Louis, USA
Posts: 585
Rep Power: 20
chegdan will become famous soon enoughchegdan will become famous soon enough
all warnings. did it not create a mesh?
__________________
Dan

Find me on twitter @dancombest and LinkedIn
chegdan is offline   Reply With Quote

Old   November 26, 2013, 15:55
Default
  #8
Member
 
Salam Hassan
Join Date: Nov 2013
Posts: 46
Rep Power: 5
Salam-H is on a distinguished road
Quote:
Originally Posted by chegdan View Post
all warnings. did it not create a mesh?
It did create a Mesh but, I get the error messages, when I do setFields it still goes trough however with error messages again , and finally it cant be decompose it.

regards,

salam
Salam-H is offline   Reply With Quote

Old   November 26, 2013, 15:58
Default
  #9
Senior Member
 
chegdan's Avatar
 
Daniel P. Combest
Join Date: Mar 2009
Location: St. Louis, USA
Posts: 585
Rep Power: 20
chegdan will become famous soon enoughchegdan will become famous soon enough
Quote:
Originally Posted by Salam-H View Post
It did create a Mesh but, I get the error messages, when I do setFields it still goes trough however with error messages again , and finally it cant be decompose it.

regards,

salam
What are these error messages that you are getting? I can't go back and forth on this all day...so lets try to get this answered by providing a complete description of the problem and what exactly (not vaguely) you are experiencing.
__________________
Dan

Find me on twitter @dancombest and LinkedIn
chegdan is offline   Reply With Quote

Old   November 26, 2013, 16:11
Default
  #10
Member
 
Salam Hassan
Join Date: Nov 2013
Posts: 46
Rep Power: 5
Salam-H is on a distinguished road
Quote:
Originally Posted by chegdan View Post
What are these error messages that you are getting? I can't go back and forth on this all day...so lets try to get this answered by providing a complete description of the problem and what exactly (not vaguely) you are experiencing.
I think I have attached the error message to the previous quote . and I have given the description of the problem, I have provided a link, the case I want to run can be found in the link.

I attached the error message to this quote so you dont have to go back up and look for it, and the link is :

https://www.hpc.ntnu.no/display/hpc/...Postprocessing

in the link there is a tutorial, all the files are provided and I want to run the tutorial, because my case is very similar to it, but I get error messages.

The only reason I want to run this tutorial is to plot a graph similar to the one that can be seen in the provided link.

Best regards,
Attached Files
File Type: doc error.doc (24.7 KB, 2 views)
Salam-H is offline   Reply With Quote

Old   November 26, 2013, 16:14
Default
  #11
Senior Member
 
chegdan's Avatar
 
Daniel P. Combest
Join Date: Mar 2009
Location: St. Louis, USA
Posts: 585
Rep Power: 20
chegdan will become famous soon enoughchegdan will become famous soon enough
Read your attachment carefully, its full of warnings and not errors. I suggest you think about what you want to ask, compose a very thorough description of your issue and open a new thread. you may want to open a thread in the subforum for running and solving cases located at

http://www.cfd-online.com/Forums/openfoam-solving/

Good luck!
__________________
Dan

Find me on twitter @dancombest and LinkedIn
chegdan is offline   Reply With Quote

Old   November 26, 2013, 16:18
Default
  #12
Member
 
Salam Hassan
Join Date: Nov 2013
Posts: 46
Rep Power: 5
Salam-H is on a distinguished road
Quote:
Originally Posted by chegdan View Post
Read your attachment carefully, its full of warnings and not errors. I suggest you think about what you want to ask, compose a very thorough description of your issue and open a new thread. you may want to open a thread in the subforum for running and solving cases located at

http://www.cfd-online.com/Forums/openfoam-solving/

Good luck!
Ok , thanks a lot for your help, sorry for taking your time, and honestly even though I couldnt fix my problem but I learnt something useful from you, thank you again.

best regards,

salam
Salam-H is offline   Reply With Quote

Old   November 26, 2013, 17:04
Default
  #13
Member
 
Salam Hassan
Join Date: Nov 2013
Posts: 46
Rep Power: 5
Salam-H is on a distinguished road
Quote:
Originally Posted by Salam-H View Post
Ok , thanks a lot for your help, sorry for taking your time, and honestly even though I couldnt fix my problem but I learnt something useful from you, thank you again.

best regards,

salam
Hello again

I have just opened a new thread as you suggested , it can be accessed in the following link, if you are willing to help more please have a look at it.

Best regards,

Salam
Salam-H is offline   Reply With Quote

Old   November 26, 2013, 17:28
Default
  #14
Member
 
Salam Hassan
Join Date: Nov 2013
Posts: 46
Rep Power: 5
Salam-H is on a distinguished road
Quote:
Originally Posted by Salam-H View Post
Hello again

I have just opened a new thread as you suggested , it can be accessed in the following link, if you are willing to help more please have a look at it.

Best regards,

Salam
The link to the new thread is : http://www.cfd-online.com/Forums/ope...-warnings.html

Cheers,

Salam
Salam-H is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 14:57.