CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

Vacuum flow - Janaf error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 2, 2011, 06:14
Default Vacuum flow - Janaf error
  #1
Senior Member
 
Join Date: Mar 2011
Posts: 174
Rep Power: 6
anon_a is on a distinguished road
I have been trying to simulate time dependent, pressure driven
flow through a cylindrical orifice (4.8mm diameter, 0.2mm thickness)
as an intermediate step to my final geometry. The pressure upstream
is 10^5 Pa and downstream 2500Pa, the temperature is 300K on
every boundary surface and the gas is nitrogen.

The solver I am using is rhoCentralFoam. It is reasonable to expect
that the temperature drops significantly in this case (ANSYS gives
a minimum temperature around 10K) and as a result I get an
"out of Janaf range" error. My fvSchemes and fvSolution are the same
as in the Ladenburg example.

I have tried the following without success:
- Changed Tlow for Janaf to 1K
- Refined the mesh
- Set the Max Co to 0.1
and I am currently trying an even denser mesh (200,000 elements).

Any ideas? I must also note that this happens for any downstream
pressure below 60000 Pa.
anon_a is offline   Reply With Quote

Old   November 4, 2011, 04:07
Default
  #2
Senior Member
 
Join Date: Mar 2011
Posts: 174
Rep Power: 6
anon_a is on a distinguished road
The dense grid improves the situation
but I still can't get beyond 10^-4 sec
for an outlet pressure of 10kPa.

Any suggestions?
anon_a is offline   Reply With Quote

Old   November 14, 2011, 04:52
Default
  #3
Senior Member
 
Join Date: Mar 2011
Posts: 174
Rep Power: 6
anon_a is on a distinguished road
I don't understand why is this type of error activated,
since the temperature is much higher in the moments before
the divergence (minimum 280K).

I am pretty sure I am doing something wrong with the boundary
conditions. Any suggestions on pressure BCs for a vacuum opening
of known pressure? I have already tried fixedValue, waveTransmissive
and zeroGradient (which does not work because of the nature of the
flow).
anon_a is offline   Reply With Quote

Reply

Tags
janaf, rhocentralfoam, vacuum

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing phi from a fvPatchField at same patch johndeas OpenFOAM 1 September 13, 2010 20:23
groovyBC sega OpenFOAM Running, Solving & CFD 12 February 17, 2010 10:30
error while running paraFoam! padmanathan OpenFOAM 9 October 13, 2009 05:17
Installation OF1.5-dev ttdtud OpenFOAM Installation 46 May 5, 2009 02:32
Errors running allwmake in OpenFOAM141dev with WM_COMPILE_OPTION%3ddebug unoder OpenFOAM Installation 11 January 30, 2008 21:30


All times are GMT -4. The time now is 06:34.