CFD Online Logo CFD Online URL
Home > Forums > FLUENT

unrecgonized function :static

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree3Likes
  • 3 Post By Hathaway

LinkBack Thread Tools Display Modes
Old   April 6, 2012, 20:29
Thumbs down unrecgonized function :static
New Member
Join Date: Aug 2010
Posts: 5
Rep Power: 8
houghston is on a distinguished road
When I start running iteration in parallel mode (8 nodes)

it shows the error in the first step like:
primitive error at node 0: Cell_Function_Values: unrecognized function: static,

primitive error at node 1: Cell_Function_Values: unrecognized function: static,

...etc. for all of 8 nodes.

Then if I start running in serial mode, I got the error like

Cell_Function_Values: unrecognized function: static

Anybody knows what is going on here? My cell volume skewness is less than 0.81, though there are about 18M cells. And I tried disabling both energy and turbulence equation already...

Any help is appreciated.
houghston is offline   Reply With Quote

Old   September 20, 2012, 16:09
New Member
Brandon Hathaway
Join Date: Oct 2010
Location: Minneapolis
Posts: 9
Rep Power: 8
Hathaway is on a distinguished road
Send a message via ICQ to Hathaway
Hey, I found your post while I was trying to find a remedy for the same error message. I was able to find a fix for my situation and thought I'd share it in case it will help in the future.

In my case the problem was that I still had a few custom monitors defined to observe the progress of the simulation. However I had recently changed my modeling methods, so one of the variables I was monitoring no longer existed, resulting in this error for every node after the first time step. Simply removing these monitors fixed the issue for me.
Katja, ilNannino and VictorWUR like this.
Hathaway is offline   Reply With Quote

Old   March 12, 2014, 00:23
Default Thanks bro
New Member
adnan aziz
Join Date: Oct 2013
Posts: 5
Rep Power: 4
ade4921 is on a distinguished road
thank you HATHAWAY. it worked. thanks again
ade4921 is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
ParaView for OF-1.6-ext Chrisi1984 OpenFOAM Installation 0 December 31, 2010 07:42
latest OpenFOAM-1.6.x from git failed to compile phsieh2005 OpenFOAM Bugs 25 February 9, 2010 05:37
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
LibvtkFoamso fred OpenFOAM Paraview & paraFoam 2 November 18, 2005 20:01
Please help about the VTKFoam liugx212 OpenFOAM Running, Solving & CFD 0 November 18, 2005 19:27

All times are GMT -4. The time now is 17:26.