CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation on Windows, Mac and other Unsupported Platforms

openFoam 2.3.x for windows from cfdsupport.com

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   July 18, 2014, 04:43
Default openFoam 2.3.x for windows from cfdsupport.com
  #1
Senior Member
 
Paritosh Vasava
Join Date: Oct 2012
Location: Lappeenranta, Finland
Posts: 605
Rep Power: 14
vasava will become famous soon enough
Now you can download openFoam 2.3.x for windows from the give link (http://www.cfdsupport.com/openfoam-for-windows.html). I have downloaded and checking it right now. There is ready-to-install .exe files. No-cross compiling is needed and it looks quite promising.

There is no read-me file so I am not sure about the sequence of installation. If would be nice to hear what everyone else has to say.
vasava is offline   Reply With Quote

Old   July 18, 2014, 04:48
Default
  #2
Senior Member
 
Paritosh Vasava
Join Date: Oct 2012
Location: Lappeenranta, Finland
Posts: 605
Rep Power: 14
vasava will become famous soon enough
My bad. There is a link about installation instructions (http://www.cfdsupport.com/install-op...r-windows.html).
vasava is offline   Reply With Quote

Old   July 23, 2014, 10:40
Default looks nice
  #3
New Member
 
OH il seok
Join Date: Sep 2010
Posts: 17
Rep Power: 7
oilsok is on a distinguished road
I tested this complied OpenFoam for windows.
It works well

but I wonder how to compile OpenFOAM on cygwin...I need to combine some solver
oilsok is offline   Reply With Quote

Old   July 24, 2014, 02:34
Default
  #4
Senior Member
 
Paritosh Vasava
Join Date: Oct 2012
Location: Lappeenranta, Finland
Posts: 605
Rep Power: 14
vasava will become famous soon enough
I am not sure about that you can ask the support at cfdsupport.
vasava is offline   Reply With Quote

Old   July 24, 2014, 10:07
Default
  #5
Member
 
Join Date: Mar 2009
Posts: 39
Rep Power: 9
Fabio is on a distinguished road
Hi all, i'm stuck at point 6 of step 3, i don't have any

C:\cygwin64\opt\OpenFOAM\ folder, shuold i create it?

I haven't restrted the system after

run OpenFOAM-2.3.x-reg.bat

shoul be that the problem?
Fabio is offline   Reply With Quote

Old   August 26, 2014, 09:58
Question OpenFoam 2.3.x for Windows installation trouble
  #6
New Member
 
Theodor C
Join Date: Aug 2014
Posts: 1
Rep Power: 0
Theodor is on a distinguished road
Hi all!
I'm newbie to OpenFOAM. I tried to install it using cfdsupport.com instructions. But when I try to run example icoFoam I recieve this error:
-bash: blockmesh: command not found
What is the reason?
Thanks in advance,
Theodor C
Theodor is offline   Reply With Quote

Old   October 1, 2014, 10:07
Default
  #7
New Member
 
Xiaopeng Wang
Join Date: Sep 2014
Posts: 7
Rep Power: 3
Wang@nitech is on a distinguished road
Quote:
Originally Posted by Fabio View Post
Hi all, i'm stuck at point 6 of step 3, i don't have any

C:\cygwin64\opt\OpenFOAM\ folder, shuold i create it?

I haven't restrted the system after

run OpenFOAM-2.3.x-reg.bat

shoul be that the problem?
Hi Fabio,

Yes, you should create the directory yourself.

Wang@NIT
Wang@nitech is offline   Reply With Quote

Old   October 1, 2014, 10:10
Default
  #8
New Member
 
Xiaopeng Wang
Join Date: Sep 2014
Posts: 7
Rep Power: 3
Wang@nitech is on a distinguished road
Quote:
Originally Posted by Theodor View Post
Hi all!
I'm newbie to OpenFOAM. I tried to install it using cfdsupport.com instructions. But when I try to run example icoFoam I recieve this error:
-bash: blockmesh: command not found
What is the reason?
Thanks in advance,
Theodor C
Hi Theodor,

You should also install MS-MPI contained in the installation directory.
The file name is MSMPISetup.

Wang@NIT
Wang@nitech is offline   Reply With Quote

Old   October 1, 2014, 10:25
Default
  #9
Member
 
Join Date: Mar 2009
Posts: 39
Rep Power: 9
Fabio is on a distinguished road
Oh thank you!

This installation process is valid also for other linux only packages lika Code Aster?
Fabio is offline   Reply With Quote

Old   October 1, 2014, 20:58
Default
  #10
New Member
 
Xiaopeng Wang
Join Date: Sep 2014
Posts: 7
Rep Power: 3
Wang@nitech is on a distinguished road
Quote:
Originally Posted by Fabio View Post
Oh thank you!

This installation process is valid also for other linux only packages lika Code Aster?
I'm sorry. I am new to OpenFOAM, I have no idea about that.
Wang@nitech is offline   Reply With Quote

Old   October 5, 2014, 04:53
Default
  #11
Member
 
Simas
Join Date: Mar 2012
Posts: 37
Rep Power: 6
zombiaska is on a distinguished road
As I undertand this installation is only for win 64
zombiaska is offline   Reply With Quote

Old   October 6, 2014, 01:37
Default
  #12
Senior Member
 
Paritosh Vasava
Join Date: Oct 2012
Location: Lappeenranta, Finland
Posts: 605
Rep Power: 14
vasava will become famous soon enough
Quote:
Originally Posted by Fabio View Post
Oh thank you!

This installation process is valid also for other linux only packages lika Code Aster?
This process is for installing openFoam on windows. You can look at openFoam website for instructions for installation on linux. Perhaps this link could help.
vasava is offline   Reply With Quote

Old   October 6, 2014, 04:30
Default
  #13
New Member
 
Nikolay Nosorev
Join Date: Oct 2014
Location: Russia
Posts: 2
Rep Power: 0
Logrus is on a distinguished road
After installation some days ago it worked,
but recently it "crashed".Inputing commands has no respond.I checked system variables (PATH), but openfoam commands ignored(.Bash is not write that commands not found,but they are not works anymore.
Logrus is offline   Reply With Quote

Old   October 12, 2014, 00:06
Default
  #14
New Member
 
Xinping Zhou
Join Date: Oct 2014
Posts: 2
Rep Power: 0
Markzhou is on a distinguished road
Dear Theodor,
I have the same problem as yours. How did you solve this problem?
Thank you.
Mark

Quote:
Originally Posted by Theodor View Post
Hi all!
I'm newbie to OpenFOAM. I tried to install it using cfdsupport.com instructions. But when I try to run example icoFoam I recieve this error:
-bash: blockmesh: command not found
What is the reason?
Thanks in advance,
Theodor C
------------------------

Dear Wang,
I have the same problem as Theodor's, though I installed MS-MPI contained in the installation directory. How should I DO in order to solve this problem?
Thank you.
Mark

Quote:
Originally Posted by Wang@nitech View Post
Hi Theodor,

You should also install MS-MPI contained in the installation directory.
The file name is MSMPISetup.

Wang@NIT

Last edited by wyldckat; October 12, 2014 at 02:22. Reason: merged posts, which were posted 2 minutes apart
Markzhou is offline   Reply With Quote

Old   October 29, 2014, 07:20
Default
  #15
New Member
 
Join Date: Apr 2009
Posts: 11
Rep Power: 9
deepinheart is on a distinguished road
Quote:
Originally Posted by oilsok View Post
I tested this complied OpenFoam for windows.
It works well

but I wonder how to compile OpenFOAM on cygwin...I need to combine some solver
Hi Oilsok,

I'm wondering the same and have asked cfd support but no reply jet. Have you got any info?

Thanks!
deepinheart is offline   Reply With Quote

Old   October 29, 2014, 09:28
Default
  #16
Senior Member
 
Paritosh Vasava
Join Date: Oct 2012
Location: Lappeenranta, Finland
Posts: 605
Rep Power: 14
vasava will become famous soon enough
@ Logrus and @ deepinheart: Did you update your windows installation recently? May be some one more expert can comment if updating windows has something to do with this.

Also have you tried re-installing openFoam from scratch?
vasava is offline   Reply With Quote

Old   November 6, 2014, 09:25
Default can't find blockMesh
  #17
New Member
 
Isha Schoots
Join Date: Nov 2014
Posts: 3
Rep Power: 3
schootsi is on a distinguished road
I installed OpenFOAM on windows using cygwin64. I'm trying to do the first tutorial, but when I run blockMesh it says:

admin@-PC /opt/OpenFOAM/OpenFOAM-2.3.x/tutorials/incompressible/icoFoam/cavity
$ blockMesh
/opt/OpenFOAM/OpenFOAM-2.3.x/platforms/cygwin64mingw-w64DPOpt/bin/blockMesh.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory

Whereas the file is in that location, as far as I can tell. In fact it can find the directory, and in Windows I can see the file is there.

admin@-PC /opt/OpenFOAM/OpenFOAM-2.3.x/tutorials/incompressible/icoFoam/cavity
$ cd C:/cygwin64/opt/OpenFOAM/OpenFOAM-2.3.x/platforms/cygwin64mingw-w64DPOpt/bin

admin@-PC /opt/OpenFOAM/OpenFOAM-2.3.x/platforms/cygwin64mingw-w64DPOpt/bin
$ blockMesh
/opt/OpenFOAM/OpenFOAM-2.3.x/platforms/cygwin64mingw-w64DPOpt/bin/blockMesh.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory

It seems to me this error is different from the 'command not found' blockmesh error? Does anyone have a clue what I might be doing wrong?
schootsi is offline   Reply With Quote

Old   November 12, 2014, 13:43
Default Solution for "error while loading shared libraries: ?"
  #18
New Member
 
Andras Horvath
Join Date: Mar 2009
Posts: 29
Rep Power: 9
andras is on a distinguished road
1) Start "OpenFOAM-2.3.x-reg.bat" with admin rights (right click -> Run as Administrator). The install instructions from cfdsupport.com are missing this crucial step. Admin rights are needed for the registry key "HKLM\SYSTEM\CurrentControlSet\Control\SessionMana ger\kernel".

2) Don't source $WM_PROJECT_DIR/etc/bashrc in bash like you are used to for standard installations of OpenFOAM unter *NIX systems.

3) Simply run the solver (paths are searched automatically).


Cheers
Andras
andras is offline   Reply With Quote

Old   November 12, 2014, 13:52
Default
  #19
New Member
 
Isha Schoots
Join Date: Nov 2014
Posts: 3
Rep Power: 3
schootsi is on a distinguished road
So I reinstalled the whole thing again and blockmesh is working now. I think I may have installed the components in the wrong order or skipped ms-mpi before

Both blockMesh and icoFoam work now, and paraview works as well (also from cygwin), however paraFoam returns the error: -bash: paraFoam: command not found. I've seen this error on this forum on other OS's, but I couldn't find anything for the Windows situation.

Has anyone had this problem? Any thoughts on how to solve it?

Thanks in advance!
schootsi is offline   Reply With Quote

Old   November 12, 2014, 14:38
Default Work-around for parafoam:
  #20
New Member
 
Andras Horvath
Join Date: Mar 2009
Posts: 29
Rep Power: 9
andras is on a distinguished road
In your case directory:

$ touch .foam

$ paraview .foam


Cheers
Andras
schootsi likes this.
andras is offline   Reply With Quote

Reply

Tags
openfoam, windows

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM Foundation Releases OpenFOAM v2.3.0 opencfd OpenFOAM Announcements from OpenFOAM Foundation 3 December 23, 2014 04:43
Frequently Asked Questions about Installing OpenFOAM wyldckat OpenFOAM Installation 0 January 1, 2014 20:21
Critical errors during OpenFoam installation in OpenSuse 11.0 amscosta OpenFOAM 5 May 1, 2009 14:06
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07
OpenFOAM Training and Workshop Hrvoje Jasak Main CFD Forum 0 October 7, 2005 07:14


All times are GMT -4. The time now is 10:00.