CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] Installing OpenFOAM 2.3.x on Ubuntu 14.04

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By wyldckat

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   January 19, 2015, 08:04
Default Installing OpenFOAM 2.3.x on Ubuntu 14.04
  #1
Senior Member
 
Samuele Z
Join Date: Oct 2009
Location: Mozzate - Co - Italy
Posts: 516
Rep Power: 14
samiam1000 is on a distinguished road
Dear Foamers, I am having some problems while installing OpenFOAM 2.3.x on my laptop (with Ubuntu 14.04).

I need to use OpenFOAM in parallel, but when I give the command
Code:
mpirun -np 2 twoPhaseEulerFoam -parallel
I get the following error:
Code:
'mpirun' not found
In which package I can find the command mpirun?

Thanks a lot,
Samuele
samiam1000 is offline   Reply With Quote

Old   January 24, 2015, 11:19
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,943
Blog Entries: 42
Rep Power: 121
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Greetings Samuele,

Which installation instructions did you follow?
Because according to that error message, it seems that:
  1. Either you did not fully build OpenFOAM properly;
  2. Or you built it with some other MPI toolbox, for example with MPICH, which would use by default mpiexec and not mpirun.
Best regards,
Bruno
__________________
wyldckat is offline   Reply With Quote

Old   January 24, 2015, 13:10
Default
  #3
Senior Member
 
Samuele Z
Join Date: Oct 2009
Location: Mozzate - Co - Italy
Posts: 516
Rep Power: 14
samiam1000 is on a distinguished road
Hi Bruno,

thanks for answering.

I solved the question: the point was that I was trying to install foam-extend in a different directory.

Anyway, everything is fine, now.

I have a couple of questions about foam-extend:

1. how does my compter know that I want to use the solver of the exted version and not the regular one?
2. also, is the solver presented in this beamer ( http://sourceforge.net/projects/open...SlidesOFW7.pdf ) available in foam-extend 3.1?

Thanks a lot,
Samuele
samiam1000 is offline   Reply With Quote

Old   January 24, 2015, 13:40
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,943
Blog Entries: 42
Rep Power: 121
wyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to allwyldckat is a name known to all
Quick answers:
Quote:
Originally Posted by samiam1000 View Post
1. how does my computer know that I want to use the solver of the exted version and not the regular one?
Answer: http://openfoamwiki.net/index.php/In...ment_Variables

Quote:
Originally Posted by samiam1000 View Post
2. also, is the solver presented in this beamer ( http://sourceforge.net/projects/open...SlidesOFW7.pdf ) available in foam-extend 3.1?
I see you asked about this here: http://www.cfd-online.com/Forums/ope...tml#post528693 post #18 - I'll answer there.
samiam1000 likes this.
wyldckat is offline   Reply With Quote

Old   January 26, 2015, 03:44
Default
  #5
Senior Member
 
Samuele Z
Join Date: Oct 2009
Location: Mozzate - Co - Italy
Posts: 516
Rep Power: 14
samiam1000 is on a distinguished road
Thank you very very much Bruno!
samiam1000 is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.org] Installing OpenFOAM 2.3 on Ubuntu 18.04 Joe1best OpenFOAM Installation 13 August 24, 2018 14:46
[OpenFOAM.org] OpenFOAM 3.0.1 installation on Ubuntu 14.04 Hrushi OpenFOAM Installation 6 July 8, 2017 19:47
[OpenFOAM.org] Ubuntu 14.04 LTS OpenFoam 4.1 Installation Error behzad-cfd OpenFOAM Installation 2 March 5, 2017 03:44
[foam-extend.org] Installing foam-extend 3.1 on Ubuntu 14.04 stephie OpenFOAM Installation 16 April 23, 2015 17:18
Prolem installing OpenFOAM Ver 2.3.0 source in Ubuntu 13.1.0 on VMware zandi OpenFOAM Installation 5 March 31, 2014 04:57


All times are GMT -4. The time now is 12:50.