CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

installing OF 1.6 ext

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By wyldckat

Reply
 
LinkBack Thread Tools Display Modes
Old   September 10, 2012, 13:03
Default installing OF 1.6 ext
  #1
Member
 
Haomin Yuan
Join Date: Jan 2012
Location: Madison, Wisconsin, USA
Posts: 54
Rep Power: 5
yhaomin2007 is on a distinguished road
Hi, All foamers,

Have any body tried to install OF 1.6 ext recently.

When I was running the ThirdParty Allwmake, when it is connecting the www.mgnet.org, there is no respond. I have tried to log on this website in IE, but failed. It seems this website is down.

Does anyone have the same problem I have??

thank you in advance
yhaomin2007 is offline   Reply With Quote

Old   September 10, 2012, 17:35
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,312
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings yhaomin2007,

I haven't tested this yet, but you can try these steps:
  1. Edit the file "AllMake.stage3" that is on the folder "ThirdParty";
  2. Find this line:
    Code:
    ( rpm_make -p ParMGridGen-1.0 -s ParMGridGen-1.0.spec -u http://www.mgnet.org/mgnet/Codes/parmgridgen/ParMGridGen-1.0.tar.gz       )
  3. Change it to:
    Code:
    ( rpm_make -p ParMGridGen-1.0 -s ParMGridGen-1.0.spec -u www-users.cs.umn.edu/~moulitsa/download/ParMGridGen-1.0.tar.gz        )

Best regards,
Bruno
fumiya likes this.
wyldckat is offline   Reply With Quote

Old   September 10, 2012, 22:07
Default
  #3
Member
 
Haomin Yuan
Join Date: Jan 2012
Location: Madison, Wisconsin, USA
Posts: 54
Rep Power: 5
yhaomin2007 is on a distinguished road
Hi, Bruno,

thank you, your method works. Now I can complete the Allwmake of ThirdParty. But when I was running the Allwmake of OpenFOAM-1.6-ext, it stops and prompt up "make: Target `application' not remade because of errors."

it seems that it has some part of OF running, but some part are not.
Do you met this problem before?

thank you very much
yhaomin2007 is offline   Reply With Quote

Old   September 11, 2012, 16:52
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,312
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Haomin,

OK, that usually means that something along the line didn't build properly, so everything else that depended on the first one that broke, will also break...

To diagnose this, run Allwmake like this:
Code:
./Allwmake > make.log 2>&1
Then search for the first occurrence of "Error " and check what the error is. If you have trouble diagnosing the error, search-and-replace any sensitive data (user name and special paths), compress the file and attach the compressed file on your next post.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM 1.6 ext - Compilation errors - Fedora 17(32bit) toolpost OpenFOAM Installation 15 September 21, 2012 09:38
Problem Installing OF 1.6 Ubuntu 9.10 (64 bit) - How to use GCC 4.4.1 Future Science OpenFOAM Installation 43 November 10, 2011 08:17
Installing OF 1.6 on Mac OS X gschaider OpenFOAM Installation 140 June 19, 2010 09:23
Installing OpenFOAM 1.6 on ubuntu 9.10 nabeels OpenFOAM Installation 32 May 10, 2010 03:09
problems with installing OpenFOAM 1.6 su_junwei OpenFOAM Installation 8 September 10, 2009 12:54


All times are GMT -4. The time now is 07:18.