CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

ParaFoam with OF-1.6-ext

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 12, 2012, 18:53
Default ParaFoam with OF-1.6-ext
  #1
New Member
 
Kanuk
Join Date: Oct 2010
Posts: 24
Rep Power: 6
kanuk is on a distinguished road
Hi all, I'm having a bit of a problem getting paraFoam to work with 1.6-ext.

I followed the build instructions on a fresh Ubuntu 12.04 install (the ones located in /doc/buildInstructions/Ubuntu/12.04) for several 64-bit machines, several times. Each time, the installations go smoothly (no errors) and apart from some warning about different gcc compilers, foamInstallationTest seems to think things are OK.

The problem is, whenever I call paraFoam from a case directory (for example, the mixer2D tutorial in icoDyMFoam), it opens with the message:

"A reader for '....../mixer2D.OpenFOAM' could not be found. Please choose one:"
And when I choose OpenFOAM from the list, it spits out the following after trying to view results:

Code:
 $ paraFoam 
created temporary 'mixer2D.OpenFOAM'
Read float past end of buffer
Read float past end of buffer
Read float past end of buffer
Read float past end of buffer
Warning: In /home/me/OpenFOAM/OpenFOAM-1.6-ext/ThirdParty/rpmBuild/BUILD/ParaView-3.12.0/VTK/IO/vtkOpenFOAMReader.cxx, line 4728
vtkOpenFOAMReaderPrivate (0x27d0aa0): Numbers of faces in faces 2416 and owner 2380 does not match

ERROR: In /home/me/OpenFOAM/OpenFOAM-1.6-ext/ThirdParty/rpmBuild/BUILD/ParaView-3.12.0/VTK/Filtering/vtkExecutive.cxx, line 756
vtkPVCompositeDataPipeline (0x1e89f00): Algorithm vtkPOpenFOAMReader(0x2807160) returned failure for request: vtkInformation (0x2a8a790)
  Debug: Off
  Modified Time: 133628
  Reference Count: 1
  Registered Events: (none)
  Request: REQUEST_DATA
  FORWARD_DIRECTION: 0
  FROM_OUTPUT_PORT: 0
  ALGORITHM_AFTER_FORWARD: 1
I have been searching around for a solution for awhile, and it *appears* as of the problem is with qt, but I am hesitant to play around with that.

Any thoughts?
kanuk is offline   Reply With Quote

Old   October 12, 2012, 20:29
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Kanuk,

If I'm not mistaken, the fix should be an old one... so I'll quote myself :
Quote:
Originally Posted by wyldckat View Post
With OpenFOAM's environment active, edit the file "$WM_PROJECT_DIR/bin/paraFoam" and insert somewhere before it calls paraview, the following line:
Code:
export LC_ALL=C
This will force the english standard language settings to be used by Paraview and it's plugins. It will only affect them and not the whole system.
edit: As for ".OpenFOAM" not being detected automatically, try the instructions on this post: OF 1.6.x installation, Suse 11.2, ParaView Segementation fault post #6

Best regards,
Bruno

Last edited by wyldckat; October 12, 2012 at 20:32. Reason: see "edit:"
wyldckat is offline   Reply With Quote

Old   October 12, 2012, 21:16
Default
  #3
New Member
 
Kanuk
Join Date: Oct 2010
Posts: 24
Rep Power: 6
kanuk is on a distinguished road
Hello Bruno,

Thanks very much for your response. I rebuilt the PV3FoamReader as per your suggestion, but that didn't change anything - nor did editing the $WM_PROJECT_DIR/bin/paraFoam file...

I have no idea what the problem may be, but I think I'll try and resolve my gcc problem first (start with the easy stuff) by uncommenting the

#compilerInstall=OpenFOAM

line in etc/settings.sh

Hopefully this works... I will report back in a few hours

Dave
kanuk is offline   Reply With Quote

Old   October 15, 2012, 16:07
Default
  #4
New Member
 
Kanuk
Join Date: Oct 2010
Posts: 24
Rep Power: 6
kanuk is on a distinguished road
So, I tried compiling again the system compilers, but alas paraFoam didn't get built.

It's not the best situation, but I suppose I can live with foamToVTK for now. I was hoping that the build instructions for a stock ubuntu 12.04 would work - but I can't complain. I'll keep trying and post back if I find a solution.
kanuk is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FSI solver for openFoam 1.6 ext Whyman OpenFOAM 4 October 26, 2013 06:11
OpenFOAM 1.6 ext - Compilation errors - Fedora 17(32bit) toolpost OpenFOAM Installation 15 September 21, 2012 09:38
installing OF 1.6 ext yhaomin2007 OpenFOAM Installation 3 September 11, 2012 16:52
paraFoam reader for OpenFOAM 1.6 smart OpenFOAM Installation 13 November 16, 2009 22:41
Can't run paraFoam with OpenFOAM 1.6 Fed11 OpenFOAM Installation 1 October 30, 2009 20:54


All times are GMT -4. The time now is 07:25.