CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

Some problem with paraview

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 22, 2005, 05:24
Default I've just installed OpenFOAM,
  #1
thermo
Guest
 
Posts: n/a
I've just installed OpenFOAM, which can calculate normally. But there seem some problems with paraview. At first,when I execute paraview, it simply tells that '.../paraview: cannot execute binary file'. So I download another paraview(version-2.2.1) instead. This time,the paraview can work! But a new problem arises,when execute:
paraFoam ... ...
it refers:

ErrorMessage
# Error or warning: ERROR: In /home/amy/ParaViewReleaseRoot/paraview-2.2.1/Utilities/VTKClientServer/vtkClient ServerInterpreter.cxx, line 866
vtkClientServerInterpreter (0x805cf40): Cannot find module "libPVFoamReader.so". The following paths were searched:
/home/wzx/OpenFOAM/linux/paraview-2.2.0/lib/paraview-2.2
/home/wzx/OpenFOAM/OpenFOAM-1.2/lib/linuxGcc4Opt/lam-7.1.1
/home/wzx/OpenFOAM/OpenFOAM-1.2/src/lam-7.1.1/platforms/linuxGcc4Opt/lib
/home/wzx/OpenFOAM/linux/gcc-4.0.1/lib
/home/wzx/OpenFOAM/wzx-1.2/lib/linuxGcc4Opt
/home/wzx/OpenFOAM/OpenFOAM-1.2/lib/linuxGcc4Opt
/opt/intel/fc/9.0/lib
/home/wzx/OpenFOAM/linux/paraview-2.2.0/lib
/home/wzx/OpenFOAM/OpenFOAM-1.2/src/lam-7.1.1/platforms/linuxGcc4Opt/bin
/home/wzx/OpenFOAM/OpenFOAM-1.2/src/mico-2.3.11/platforms/linuxGcc4Opt/bin
/home/wzx/OpenFOAM/linux/j2sdk1.4.2_05/bin
/home/wzx/OpenFOAM/linux/gcc-4.0.1/bin
/home/wzx/OpenFOAM/wzx-1.2/applications/bin/linuxGcc4Opt
/home/wzx/OpenFOAM/OpenFOAM-1.2/applications/bin/linuxGcc4Opt
/home/wzx/OpenFOAM/OpenFOAM-1.2/wmake
/home/wzx/OpenFOAM/OpenFOAM-1.2/bin
/opt/intel/fc/9.0/bin
/usr/local/bin
/usr/bin
/usr/X11R6/bin
/bin
/usr/games
/opt/gnome/bin
/opt/kde3/bin
/usr/lib/mit/bin
/usr/lib/mit/sbin
/home/wzx/OpenFOAM/linux/paraview-2.2.0/bin
/usr/lib
/usr/lib/vtk
/usr/local/lib
/usr/local/lib/vtk

ERROR: In /home/amy/ParaViewReleaseRoot/paraview-2.2.1/GUI/Client/vtkPVXMLPackageParser.cx x, line 677
vtkPVXMLPackageParser (0x8636630): Error loading Library component PVFoamReader

ErrorMessage end


There isn't the dir '/home/amy...' at all. And there is no 'PVFoamReader' too.
who can help me to solve it, thanks a lot.
  Reply With Quote

Old   November 22, 2005, 08:41
Default Hi, here it is, I would thi
  #2
Member
 
Niklas Wikstrom
Join Date: Mar 2009
Posts: 85
Rep Power: 8
wikstrom is on a distinguished road
Hi,

here it is, I would think (from above):

/home/wzx/OpenFOAM/linux/paraview-2.2.0/bin

You have to set $ParaView_VERSION in

$WM_PROJECT_DIR/$FOAM_DOT_DIR/apps/paraView/{bashrc,cshrc}

Assuming that you keep your new paraview-2.2.1 in $WM_PROJECT_INST_DIR/$WM_ARCH/
wikstrom is offline   Reply With Quote

Old   November 22, 2005, 10:28
Default I tried as suggested,but it ha
  #3
thermo
Guest
 
Posts: n/a
I tried as suggested,but it has no effect. The situation looks like the same as I posted at first.
hmmm,it mainly mentions:

ERROR: In /home/amy/ParaViewReleaseRoot/paraview-2.2.1/GUI/Client/vtkPVXMLPackageParser.cx x, line 677
vtkPVXMLPackageParser (0x864ddb0): Error loading Library component PVFoamReader
/home/wzx/OpenFOAM/OpenFOAM-1.2/bin/paraFoam: line 57: 3608 section wrong paraview paraFoam.pvs

The dir, '/home/amy/....', seems strange. I cannot find it at all.
Execute 'paraFoam paraFoam.pvs' directly, paraview starts,but ends at once, hehe.
  Reply With Quote

Old   November 22, 2005, 10:40
Default The /home/amy-part comes from
  #4
Senior Member
 
Rasmus Hemph
Join Date: Mar 2009
Location: Sweden
Posts: 108
Rep Power: 8
hemph is on a distinguished road
The /home/amy-part comes from the directory where the PVFoamReader was built originally, it is ok. You must use the paraview supplied with OpenFoam to be able to use paraFoam. Here it looks like you are using the version you downloaded from paraview homepage instead. If you wish, you can run foamToVTK on your case and use paraview to look at the results.

Did you download the correct paraview for your architecture from OpenFOAM download page?
hemph is offline   Reply With Quote

Old   November 22, 2005, 10:46
Default en,i did download the paraview
  #5
thermo
Guest
 
Posts: n/a
en,i did download the paraview supplied with OpenFoam...but it didn't work at all.
it happens that another person meet the same problem, look down.
  Reply With Quote

Old   November 22, 2005, 10:54
Default I downloaded paraview for linu
  #6
Senior Member
 
Rasmus Hemph
Join Date: Mar 2009
Location: Sweden
Posts: 108
Rep Power: 8
hemph is on a distinguished road
I downloaded paraview for linux a couple of days ago without any problems (for OpenFOAM-1.2). (I believe the problem of below is different, paraview was not found which indicate some error in the installation process.)
My libPVFoamReader.so is in
${HOME}/OpenFOAM/OpenFOAM-1.2/lib/linuxGcc40pt/libPVFoamReader.so
if yours is not there, you should try a reinstall of the OpenFOAM binary pack for linux.
hemph is offline   Reply With Quote

Old   November 25, 2005, 14:44
Default Strange, suddenly I also got m
  #7
unoder
Guest
 
Posts: n/a
Strange, suddenly I also got myself a problem with paraview/parafoam. I has worked for 2 months and when I start it now it says:

/home/martin/OpenFOAM/OpenFOAM-1.2/bin/paraFoam: line 57: 8710 Segmentation fault paraview paraFoam.pvs

This is really strange. I restarted and still got this problem with all my cases. Perhaps reinstallation is the only way out now...
  Reply With Quote

Old   November 25, 2005, 17:37
Default 1. Maybe there is something in
  #8
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
1. Maybe there is something in your ~/.Paraview* files it is not happy about?

2. Unsetenv PV_INTERFACE_PATH and try running paraview instead of paraFoam.
mattijs is offline   Reply With Quote

Old   November 26, 2005, 18:09
Default Hey, thanks a lot Mattijs,
  #9
unoder
Guest
 
Posts: n/a
Hey, thanks a lot Mattijs,

I just did a:

martin@linux:~> rm .ParaViewlmk
martin@linux:~> rm .ParaViewrc

And now everything seems to work again. I have absolutely no idea what might have screwed those files up, but the important thing is that now it works again and it was easy to fix :-)
  Reply With Quote

Old   December 20, 2005, 20:32
Default Dear Martin Jørgensen: I ha
  #10
Senior Member
 
Guoxiang
Join Date: Mar 2009
Posts: 109
Rep Power: 8
liugx212 is on a distinguished road
Dear Martin Jørgensen:

I have the same question as you. But I really do not know what you said "martin@linux:~> rm .ParaViewlmk
martin@linux:~> rm .ParaViewrc ".

Could you please give more help?

Thank you very much.
Xiang
liugx212 is offline   Reply With Quote

Old   December 25, 2005, 14:20
Default Those are hidden files. Theref
  #11
unoder
Guest
 
Posts: n/a
Those are hidden files. Therefore you wont see them unless you write "ls -a". As I remember it, they were placed in your home directory. So you should be able to type:

1) cd ~ (or I think just "cd" would do the same)
2) rm .ParaViewlmk
3) rm .ParaViewrc

And then everything worked, at least for me.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with paraview and paraFoam openfoam_user OpenFOAM Paraview & paraFoam 36 May 13, 2014 07:37
ParaView display problem holzmichel OpenFOAM Bugs 7 April 27, 2009 18:42
Paraview installation problem mcjicpm2 OpenFOAM Paraview & paraFoam 0 March 9, 2009 08:15
Paraview installation problem please help mcjicpm2 OpenFOAM Installation 0 March 9, 2009 07:55
Paraview problem nzy102 OpenFOAM Paraview & paraFoam 7 April 12, 2007 09:20


All times are GMT -4. The time now is 05:54.