CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Pre-Processing

printStack error in parallel run of coalChemistryFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 3, 2013, 13:32
Default printStack error in parallel run of coalChemistryFoam
  #1
New Member
 
Join Date: Jun 2013
Posts: 1
Rep Power: 0
Dingens is on a distinguished road
Hello,

first of all: I'm (relatively) new to OpenFOAM, so I would really appreciate if you had a little patience with me
I did choose this subforum because I think my mistake is somewhere in the pre-processing.


Back to the topic - initially some description of the case I'm running:

I'm running Ubuntu 12.10 in a VirtualBox under Windows7. OF should be the up-to-date 2.2.0.

I'm trying to simulate coal combustion in OpenFOAM with the coalChemistryFoam solver. The Mesh is a (quarter of) a burner in tube-shape. I have one primary inlet for air and coal particels and a secondary inlet for air only. There is an outlet at the opposite end. A cellSet (IgnitionCells) near the primary inlet is set to a fixedTemperatureConstraint of 1800K, which should start the combustion reaction.
The mesh was generated in Fluent (i got it from the University assistant who supervises the project). The rest of the case is a modified simplifiedSiwek tutorial case. Parallelisation method is "simple" in this case, but I also tried "scotch" with a similar result. The decomposeParDict is attached.

The case runs without errors in serial (although there are some problems concerning the combustion I will have to adress). It also works in parallel in OpenFOAM 2.1.x. But when I try to run it in parallel under 2.2.0 I get a nasty printStack error I can't get rid of. My mesh is pretty large and it is really annoying to run the case in serial, so i figured out I'd ask you for help

I'll attatch the log of the terminal including the error to this post.

I would be really grateful, if someone could take a look at it and maybe give me a hint how to solve this problem. If any additional information is needed please tell me, i will post it as fast as possible.

Thank you very much for your attention and help!

Greetings
Dingens
Attached Files
File Type: txt Logfile.txt (29.3 KB, 4 views)
File Type: txt decomposeParDict.txt (1.2 KB, 3 views)
Dingens is offline   Reply With Quote

Old   June 16, 2013, 13:40
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,453
Blog Entries: 33
Rep Power: 73
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings Dingens and welcome to the forum!

Sorry for the late reply, but I was hoping that someone else would answer you sooner... but I guess everyone if busy with tasks for the end of the middle of the year

OK, based on the information you've provided, there are only two suggestions I can think of:
  1. You can run topoSet in parallel, the same way you do for the solvers:
    Code:
    mpirun -np 4 topoSet -parallel
  2. OpenFOAM 2.2.0 might have some issues in the combustion part that might have already been solved in 2.2.x, as you can inspect in the following online folder: https://github.com/OpenFOAM/OpenFOAM...n/intermediate
Beyond this, the only way to help you is if you create a very small example of your case that reproduces the same problem, so that I or anyone else can test with 2.2.x. Because this way, you'll also have a test case that can be used for a bug report, in case this relates to a bug that exists only in 2.2.x.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Case running in serial, but Parallel run gives error - Please help! urgent ! atmcfd OpenFOAM Running, Solving & CFD 10 November 24, 2013 07:35
parallel Grief: BoundaryFields ok in single CPU but NOT in Parallel JR22 OpenFOAM Running, Solving & CFD 2 April 19, 2013 17:49
Parallel run in fluent for multiphase flow apurv FLUENT 2 August 3, 2011 20:44
Unable to run OF in parallel on a multiple-node cluster quartzian OpenFOAM 3 November 24, 2009 14:37
Run in parallel a 2mesh case cosimobianchini OpenFOAM Running, Solving & CFD 2 January 11, 2007 07:33


All times are GMT -4. The time now is 01:09.