CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Programming & Development

Upgrading a solver from OF 1.7.1 to OF 2.3.0

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By blais.bruno

Reply
 
LinkBack Thread Tools Display Modes
Old   January 19, 2016, 22:18
Default Upgrading a solver from OF 1.7.1 to OF 2.3.0
  #1
New Member
 
Ehsan
Join Date: Aug 2010
Location: QC, Canada
Posts: 28
Rep Power: 8
ehsan_am86 is on a distinguished road
Hi Dear Foamers,

In fact, I have a solver which has been written based on OpenFOAM 1.7.1 and I want to upgrade that into OpenFOAM 2.3.

Could you please give me some advises how I could start to change?

It is possible for a person who is not professional in developing OpenFOAM solvers?

I would be appreciated if somebody give me some recommendations.
ehsan_am86 is offline   Reply With Quote

Old   January 20, 2016, 10:08
Default
  #2
Member
 
Bruno Blais
Join Date: Sep 2013
Location: Canada
Posts: 55
Rep Power: 4
blais.bruno is on a distinguished road
My suggestion would be to look for a similar solver in OpenFOAM 2.3 and see which part have changed.

Most likely, some of the included libraries have changed and some member function calls (most likely within the pressure corrector loop) have change. It is doable, but it really depends on the complexity of what was done within the solver.

If you can post the solver maybe others can give you a hand.

Cheers and good luck.


Quote:
Originally Posted by ehsan_am86 View Post
Hi Dear Foamers,

In fact, I have a solver which has been written based on OpenFOAM 1.7.1 and I want to upgrade that into OpenFOAM 2.3.

Could you please give me some advises how I could start to change?

It is possible for a person who is not professional in developing OpenFOAM solvers?

I would be appreciated if somebody give me some recommendations.
ehsan_am86 likes this.
blais.bruno is offline   Reply With Quote

Old   January 20, 2016, 14:28
Default
  #3
New Member
 
Ehsan
Join Date: Aug 2010
Location: QC, Canada
Posts: 28
Rep Power: 8
ehsan_am86 is on a distinguished road
Thanks for your suggestion.

In fact, my solver is twoPhaseEulerFoam which has been coupled with population balance.

If I understood correctly, you meant I can compare twoPhaseEulerFoam in OF 1.7.1 with twoPhaseEulerFoam in OF 2.3.0? And then, I will be able to upgrade my costume solver (twoPhaseEulerFoam+population balance) to O.F 2.3.0 one?

However, my view is this fact that I could compare the costume solver with standard solver in O.F 1.7.1 and then, moving forward into O.F 2.3.0?

I would be appreciated if you let me know your comment.
ehsan_am86 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
solver for evaporation/condensation modeling gaza OpenFOAM Programming & Development 30 March 8, 2016 06:11
thobois class engineTopoChangerMesh error Peter_600 OpenFOAM 4 August 2, 2014 09:52
3d vof Smaras FLUENT 2 February 19, 2013 07:58
why the solver reject it? Anyone with experience? bearcat CFX 6 April 28, 2008 14:08
Error during Solver cfd guy CFX 4 May 8, 2001 06:04


All times are GMT -4. The time now is 11:02.