CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

paraFoam crash

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 2 Post By FabOr

Reply
 
LinkBack Thread Tools Display Modes
Old   July 27, 2010, 07:03
Default paraFoam crash
  #1
Member
 
Join Date: May 2010
Posts: 33
Rep Power: 8
FabOr is on a distinguished road
Hi,

after starting paraFoam I get following error message:

***:~/OpenFOAM/***-1.6/run/Vak200$ paraFoam
created temporary 'Vak200.OpenFOAM'
fileName::stripInvalid() called for invalid fileName H2(Kopie)~
For debug level (= 2) > 1 this is considered fatal
Aborted

I appreciate any hints!

Thanks
FabOr is offline   Reply With Quote

Old   July 27, 2010, 18:45
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,651
Blog Entries: 39
Rep Power: 99
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings FabOr,

The message seems self explanatory, but I'll break it down for you:
Quote:
Originally Posted by FabOr
fileName::stripInvalid() called for invalid fileName H2(Kopie)~
fileName::stripInvalid() - This method tries to remove unwanted characters from file names. Since the file is meant to be read, then it will only check if the name is kosher, i.e., valid.

H2(Kopie)~ - this name seems to have one too many invalid characters! If I'm not mistaken, the tilde '~' is a bad one, and the parenthesis '()' might be two other characters that aren't acceptable. My guess is that you copied the file in the same folder as a backup - H2(Kopie) - but your text editor also created another backup of your backup - H2(Kopie)~.

Sooo... the moral of this error: keep the contents of the time folders sanitized

Best regards,
Bruno
__________________
wyldckat is offline   Reply With Quote

Old   August 3, 2010, 04:00
Default
  #3
Member
 
Join Date: May 2010
Posts: 33
Rep Power: 8
FabOr is on a distinguished road
Hi wyldckat,

thanks for your answer.

Unfortunately i donīt have any copied files in my time directories.

To be sure that it is not a problem connected to the file names,i have renamed all the H2-files to H2. but i get the same error message again...

maybe it is important that i use chemkin and reactingFoam!?

best regards,
FabOr
FabOr is offline   Reply With Quote

Old   October 20, 2010, 21:42
Question was a solution found?
  #4
lth
Member
 
lth's Avatar
 
lth
Join Date: Mar 2009
Location: Madison, WI, USA
Posts: 31
Blog Entries: 32
Rep Power: 9
lth is on a distinguished road
Hi FabOr,

Wonder if a solution to this error was found? I have the exact problem for a case i ran and want to view in paraFoam.

Thank you for any insight, Lori




Quote:
Originally Posted by FabOr View Post
Hi wyldckat,

thanks for your answer.

Unfortunately i donīt have any copied files in my time directories.

To be sure that it is not a problem connected to the file names,i have renamed all the H2-files to H2. but i get the same error message again...

maybe it is important that i use chemkin and reactingFoam!?

best regards,
FabOr
lth is offline   Reply With Quote

Old   October 21, 2010, 03:43
Default
  #5
Member
 
Join Date: May 2010
Posts: 33
Rep Power: 8
FabOr is on a distinguished road
Hi Lori,

wyldckat was right.

iīve found files which were invalid named, but they were invisible.

youīve got to type " strg+h " to see the invisible files, then you have to delete the invalid ones.

hope that helps.

best regards
IsabelleT and StefanW like this.
FabOr is offline   Reply With Quote

Old   October 21, 2010, 10:20
Default
  #6
lth
Member
 
lth's Avatar
 
lth
Join Date: Mar 2009
Location: Madison, WI, USA
Posts: 31
Blog Entries: 32
Rep Power: 9
lth is on a distinguished road
Hi FabOR

works, thank you for the post!!! -Lori
lth is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
pointVectorField in ParaFoam s_braendli OpenFOAM Paraview & paraFoam 0 April 22, 2010 08:36
Segmentation fault with paraFoam and paraview 3.6.1 on Fedora 11 32 and 64 bit nanes OpenFOAM Paraview & paraFoam 2 September 11, 2009 09:12
Parafoam basic questions qtian OpenFOAM Paraview & paraFoam 0 July 20, 2007 11:52
ParaFoam OF 14 decomposed cases philippose OpenFOAM Paraview & paraFoam 4 April 18, 2007 05:17
Both paraview and paraFoam crash on Redhat Linux WS v4 64bit sek OpenFOAM Paraview & paraFoam 4 August 17, 2006 16:26


All times are GMT -4. The time now is 13:25.