CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

unable to install openfoam 1.7 using apt-get

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 22, 2010, 13:53
Default unable to install openfoam 1.7 using apt-get
  #1
New Member
 
Maaz Ahmed
Join Date: Jul 2010
Posts: 2
Rep Power: 0
maazhmd is on a distinguished road
Hi,

I am a complete newbie to openfoam and am trying to install it,

I get the following message on the screen

root@maaz-laptop:/home/maaz/OpenFoam# apt-get install openfoam170
Reading package lists... Done
Building dependency tree
Reading state information... Done
openfoam170 is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
openfoam170: Depends: libc6 (>= 2.11) but 2.9-4ubuntu6.2 is to be installed
Depends: libopenmpi1.3 but it is not installable
Depends: libqt4-help (>= 4:4.5.3) but it is not going to be installed
Depends: libqt4-network (>= 4:4.5.3) but it is not going to be installed
Depends: libqt4-sql (>= 4:4.5.3) but it is not going to be installed
Depends: libqt4-webkit (>= 4:4.5.3) but it is not going to be installed
Depends: libqt4-xml (>= 4:4.5.3) but it is not going to be installed
Depends: libqtcore4 (>= 4:4.6.1) but it is not going to be installed
Depends: libqtgui4 (>= 4:4.5.3) but it is not going to be installed
Depends: libscotch-5.1 but it is not installable
Depends: libstdc++6 (>= 4.4.0) but 4.3.3-5ubuntu4 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


this gives a clearer picture I guess

root@maaz-laptop:/home/maaz/OpenFoam# dpkg -i openfoam170_0-1_i386.deb
Selecting previously deselected package openfoam170.
(Reading database ... 110089 files and directories currently installed.)
Unpacking openfoam170 (from openfoam170_0-1_i386.deb) ...
dpkg: dependency problems prevent configuration of openfoam170:
openfoam170 depends on libc6 (>= 2.11); however:
Version of libc6 on system is 2.9-4ubuntu6.2.
openfoam170 depends on libopenmpi1.3; however:
Package libopenmpi1.3 is not installed.
openfoam170 depends on libqt4-help (>= 4:4.5.3); however:
Package libqt4-help is not installed.
openfoam170 depends on libqt4-network (>= 4:4.5.3); however:
Version of libqt4-network on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libqt4-sql (>= 4:4.5.3); however:
Version of libqt4-sql on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libqt4-webkit (>= 4:4.5.3); however:
Version of libqt4-webkit on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libqt4-xml (>= 4:4.5.3); however:
Version of libqt4-xml on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libqtcore4 (>= 4:4.6.1); however:
Version of libqtcore4 on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libqtgui4 (>= 4:4.5.3); however:
Version of libqtgui4 on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libscotch-5.1; however:
Package libscotch-5.1 is not installed.
openfoam170 depends on libstdc++6 (>= 4.4.0); however:
Version of libstdc++6 on system is 4.3.3-5ubuntu4.
dpkg: error processing openfoam170 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
openfoam170

I have a .deb package of openfoam download which was available on the site for a few days.


and when i do a apt-get -f install,

root@maaz-laptop:/home/maaz/OpenFoam# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
libstdc++6-4.3-dev libsm-dev libice-dev x11proto-kb-dev libscotch-dev libgfortran3 g++-4.3 m4 libxdmcp-dev g++ xtrans-dev x11proto-core-dev csh binutils-dev
libxt-dev zlib1g-dev x11proto-input-dev libpthread-stubs0-dev flex libxau-dev libpthread-stubs0 openmpi-bin libscotch-5.0.6 libibverbs1 openmpi-common libx11-dev
libopenmpi-dev libxcb1-dev libopenmpi1
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
openfoam170
0 upgraded, 0 newly installed, 1 to remove and 8 not upgraded.
1 not fully installed or removed.
After this operation, 352MB disk space will be freed.
Do you want to continue [Y/n]?

I gave a no and tried installing the dependencies one by one. For this I built a dependency tree amongst the pakages not installed as

libc6
libstdc++6
libscotch-5.1
libopenmpi1.3
libqtcore4
Depends: libc6 (>= 2.4)
Depends: libstdc++6 (>= 4.1.1)
libqtgui4
Depends: libc6 (>= 2.4)
Depends: libqtcore4 (= 4.5.0-0ubuntu4)
Depends: libstdc++6 (>= 4.1.1)
libqt4-webkit
Depends: libc6 (>= 2.3.6-6~)
Depends: libqtcore4 (= 4.5.0-0ubuntu4)
Depends: libqtgui4 (= 4.5.0-0ubuntu4)
Depends: libstdc++6 (>= 4.1.1)
libqt4-xml
Depends: libc6 (>= 2.4)
Depends: libqtcore4 (= 4.5.0-0ubuntu4)
Depends: libstdc++6 (>= 4.1.1)
libqt4-sql
Depends: libc6 (>= 2.1.3)
Depends: libqtcore4 (= 4.5.0-0ubuntu4)
Depends: libstdc++6 (>= 4.1.1)


and started with libc6 and got the following message

root@maaz-laptop:/home/maaz/OpenFoam# apt-get install libc6 -t '4.4*'
Reading package lists... Done
Building dependency tree
Reading state information... Done
libc6 is already the newest version.
The following packages were automatically installed and are no longer required:
libstdc++6-4.3-dev libsm-dev libice-dev x11proto-kb-dev libscotch-dev libgfortran3 g++-4.3 m4 libxdmcp-dev g++ xtrans-dev x11proto-core-dev csh binutils-dev
libxt-dev zlib1g-dev x11proto-input-dev libpthread-stubs0-dev flex libxau-dev libpthread-stubs0 openmpi-bin libscotch-5.0.6 libibverbs1 openmpi-common libx11-dev
libopenmpi-dev libxcb1-dev libopenmpi1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

so I believe I need a source where I can get these libraries but I see quiet a few successful instalation done here need help for the same.
maazhmd is offline   Reply With Quote

Old   July 23, 2010, 05:57
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Maaz and welcome to the forum!

Wow! By what I can see in your post, you know your way around apt-get and dpkg! But I've got a strange feeling you didn't check one thing - right at the beginning of the page with the instructions for installing in Ubuntu, it has this information:
Quote:
Originally Posted by http://www.openfoam.com/download/ubuntu.php
OpenFOAM and Paraview are currently available for the following versions of Ubuntu:
  • 10.04 LTS, codename lucid
And by what I've can deduce from your post, you either have installed Ubuntu 9.04 or 9.10! To confirm what version you are using, run:
Code:
lsb_release -a
Sooo... you must either upgrade Ubuntu up to 10.04, or you will have to follow the instructions in "install from source" page: http://www.openfoam.com/download/source.php

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   July 23, 2010, 09:02
Default
  #3
New Member
 
Join Date: Jul 2010
Posts: 1
Rep Power: 0
gdisalvo is on a distinguished road
I experienced this same issue with a new install of Lucid Lynx (Ubuntu 10.04). I think the default install does not enable the "Universe" repositories. These are required to satisfy these dependencies. You can enable these by editing /etc/apt/sources.list and running "apt-get update".

I hope this helps!
gdisalvo is offline   Reply With Quote

Old   July 24, 2010, 00:32
Default
  #4
New Member
 
Maaz Ahmed
Join Date: Jul 2010
Posts: 2
Rep Power: 0
maazhmd is on a distinguished road
Thanks wyldckat
And thanks again for a spot on diagnosis, ya I have been using 9.04 and how could I have overlooked the first line :-(.
Trying to build from the source now.

That reminds me.... I am using a ubuntu 9.04 installation on a virtualBox. Anybody has any idea if the virtual box can handle the graphics.

Last edited by maazhmd; July 24, 2010 at 00:40. Reason: Question added
maazhmd is offline   Reply With Quote

Old   July 25, 2010, 14:08
Default
  #5
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Maaz,

Quote:
Originally Posted by maazhmd View Post
That reminds me.... I am using a ubuntu 9.04 installation on a virtualBox. Anybody has any idea if the virtual box can handle the graphics.
I haven't got any experience with Virtual Box, but do I have experience with VMPlayer. So, I can only infer that Virtual Box behaves like VMPlayer: they have virtual graphics drivers for the guest OS (in your case, Ubuntu 9.04), that rely on the CPU. Usually 3D hardware acceleration isn't transparent to the guest machine, so you will only have as much power as the CPU on your real machine can handle, with no accelerated GPU assistance So, it should work, but waaaay slower than you are use to

Hopefully this will stop being an issue in the next few months, since Intel has been injecting their own brand of GPU into the new processors, so hopefully they will start providing a VT bit/flag for hardware graphics acceleration in virtual machines!

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   July 24, 2011, 00:44
Default
  #6
New Member
 
Basy's Avatar
 
behzad
Join Date: Oct 2010
Location: Technical University of Malaysia(UTM)
Posts: 14
Rep Power: 6
Basy is on a distinguished road
Quote:
Originally Posted by gdisalvo View Post
I experienced this same issue with a new install of Lucid Lynx (Ubuntu 10.04). I think the default install does not enable the "Universe" repositories. These are required to satisfy these dependencies. You can enable these by editing /etc/apt/sources.list and running "apt-get update".

I hope this helps!
yes you are right, in case of "maazhmd" maybe it was because of his Linux version but as you said i have just installed a 10.04 lucid on virtual box and same error shows up:
"the following packages have unmet dependencies.."
you suggested editing the "etc/apt/source.lict" but i dont really get you. how should i edit it?

have any one else faced or solved this problem??

thanks to all
Basy is offline   Reply With Quote

Old   July 24, 2011, 06:38
Default
  #7
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Basy,

Quote:
Originally Posted by Basy View Post
have any one else faced or solved this problem??
Just a week ago someone else also got this problem: openfoam installation for algeria (dz)
Read that thread and you should find the solutions for your questions

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   July 24, 2011, 11:18
Default
  #8
New Member
 
Basy's Avatar
 
behzad
Join Date: Oct 2010
Location: Technical University of Malaysia(UTM)
Posts: 14
Rep Power: 6
Basy is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Greetings Basy,


Just a week ago someone else also got this problem: openfoam installation for algeria (dz)
Read that thread and you should find the solutions for your questions

Best regards,
Bruno
thank you so much wyldkat for your attention, after I posted my question here I tried once more and this time every thing was ok!! I'm not sure why. the only thing I changed was in ubuntu software center> software sources> download from, that I choose "Main server".
at the moment I'm not sure if it could be the reason or not, because it is my first day ever in ubuntu. if this was not the reason, the only thing i can think of, is a problem in their website or bad internet connection at first times, that interrupted download procedure and files couldn't transfer completely.

cheers
Basy is offline   Reply With Quote

Reply

Tags
installataion, openfoam 1.7.0

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Install OpenFOAM on 64 Ubuntu 9.04 hansel OpenFOAM Installation 62 March 19, 2010 15:43
install openfoam 1.6 on opensuse 11.0 andresbh OpenFOAM Installation 8 September 30, 2009 00:48
OpenFOAM Install problem masb OpenFOAM 3 May 25, 2009 11:32
Need help with the error cfdproject OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 0 April 14, 2009 15:45
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07


All times are GMT -4. The time now is 06:46.