CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFOAM-1.7 bugs-Try to remove it

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By wyldckat

Reply
 
LinkBack Thread Tools Display Modes
Old   August 17, 2010, 22:20
Default OpenFOAM-1.7 bugs-Try to remove it
  #1
New Member
 
hc
Join Date: May 2010
Location: Perth, Australia
Posts: 11
Rep Power: 7
watashiwa is on a distinguished road
Hi,


I'm a Ubuntu noobie and newbie. My OpenFOAM-1.7 (Ubuntu 10.04) seems to gone crazy, I couldn't press Apply button in the paraView. It happened few days back and my research is halted at the moment.

Should I completely remove OpenFOAM? or there is better way to solve it.

I would rather remove it and install fresh 1. And how to do I remove the OpenFOAM? What are command to type in ?

PLease help me. THAnk you
watashiwa is offline   Reply With Quote

Old   August 18, 2010, 06:37
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,308
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings watashiwa,

Quote:
Originally Posted by watashiwa View Post
My OpenFOAM-1.7 (Ubuntu 10.04) seems to gone crazy, I couldn't press Apply button in the paraView.
OK, lets go through this step by step:
  1. Is the problem associated directly to OpenFOAM, or is it just ParaView that isn't working properly?
  2. Please specify what you mean by «I couldn't press Apply button». Is the button disabled? Is it enabled, but when you press it, it doesn't do anything? Does any error message appear when starting ParaView or during execution of ParaView?
  3. Have you updated your Ubuntu installation?
I believe the only thing you might have to remove is ParaView. But only if we get to the conclusion that it really doesn't work.


There is also another thing you can try: using the built-in plugin for reading OpenFOAM cases. For that, do the following steps:
  1. Run:
    Code:
    gksu gedit /opt/openfoam170/bin/paraFoam
  2. Replace every entry ".OpenFOAM" with ".foam".
  3. Now save and close the file.
Now try running paraFoam again and see if it jams up again or not.


So, the more information you can provide, the better... otherwise we are only going to be able to attempt to predict the reasons...

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   August 18, 2010, 08:56
Default
  #3
New Member
 
hc
Join Date: May 2010
Location: Perth, Australia
Posts: 11
Rep Power: 7
watashiwa is on a distinguished road
Hi Bruno,

As you can see from the screenshot, the "Apply" button is unable to click. I have changed all of the .OpenFOAM ( there are only 2) to .foam based on to command you given me. Usually, when you get into paraView, you can click "Apply" button whenever you want to change something. I have no idea this things happen all of sudden.

Result -> Problem remain the same.
Attached Images
File Type: jpg Screenshot-2.jpg (44.4 KB, 31 views)
watashiwa is offline   Reply With Quote

Old   August 18, 2010, 09:13
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,308
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi watashiwa,

Try removing this file: $HOME/.config/ParaView/ParaView3.8.0.ini

ParaView 3.6.1 had some quirks and 3.8.0 has a few more. Possibly something got stuck in the configuration file.

If this starts happening too often, then you better use the "big guns" and use a fix that also works for rescaling problems that might occur sooner or later: paraview 3.8 auto rescale doesn't work #6

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   August 18, 2010, 09:40
Default
  #5
New Member
 
hc
Join Date: May 2010
Location: Perth, Australia
Posts: 11
Rep Power: 7
watashiwa is on a distinguished road
Hi wyldckat,

It works now. Thank you so much.

Yeah, it doesn't seems as good as before.
DO you know any link where I can read on completely remove the OpenFoam as you have posted before.

Thank you so much.
watashiwa is offline   Reply With Quote

Old   August 18, 2010, 09:51
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,308
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
I'm glad it worked! The problem you have experienced isn't OpenFOAM's fault, it's ParaView's fault...

Anyway, the installation/removal in Ubuntu is pretty straight forward, once the repository address has been added:
  • To install:
    Code:
    sudo apt-get install openfoam170 paraviewopenfoam380
  • To uninstall:
    Code:
    sudo apt-get remove openfoam170 paraviewopenfoam380
  • To uninstall everything that is visible about these packages (i.e., configuration files):
    Code:
    sudo apt-get purge openfoam170 paraviewopenfoam380
Or start Synaptic from the menu "System->Administration->Synaptic Package Manager", search for "openfoam" or "paraview", and remove/install using the mouse.

Don't forget to remove the line you added to the end of "~/.bashrc":
Code:
gedit ~/.bashrc
If you want to install from source in Ubuntu 10.04, here is a thread with the lists of packages usually needed: Building OpenFOAM1.7.0 from source post #4 and onward

Best regards,
Bruno
DineshramBalaji likes this.

Last edited by wyldckat; August 18, 2010 at 09:51. Reason: removed strange spaces...
wyldckat is offline   Reply With Quote

Old   November 12, 2014, 17:46
Default
  #7
New Member
 
shravan
Join Date: Oct 2014
Posts: 2
Rep Power: 0
shravan471 is on a distinguished road
How to uninstall just the paraview? can I get any code to UNINSTALL just the PARAVIEW
shravan471 is offline   Reply With Quote

Old   November 16, 2014, 17:49
Default
  #8
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,308
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings shravan and welcome to the forum!

Quote:
Originally Posted by shravan471 View Post
How to uninstall just the paraview? can I get any code to UNINSTALL just the PARAVIEW
Without knowing how you installed it in the first place, it's a bit complicated to be able to give you the correct answer.

For example, using the previous post as an example, if you had used this command to install ParaView:
Code:
sudo apt-get install openfoam170 paraviewopenfoam380
You could simply use this one to remove only ParaView:
Code:
sudo apt-get remove paraviewopenfoam380
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   November 17, 2014, 18:47
Default
  #9
New Member
 
shravan
Join Date: Oct 2014
Posts: 2
Rep Power: 0
shravan471 is on a distinguished road
Hi I am new to this OpenFoam, I have installed openfoam from this link
http://www.openfoam.org/download/ubuntu.php .. I did not install paraview separately.. now my paraview is not working in the openfoam, So how can i reinstall my paraview?

I have ubuntu 12.10 package in my system
shravan471 is offline   Reply With Quote

Old   November 18, 2014, 17:40
Default
  #10
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,308
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Quick answer - try running these commands:
Code:
sudo apt-get purge paraviewopenfoam410

sudo apt-get install paraviewopenfoam410
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM 1.7 installation on Redhat linux maxims OpenFOAM Installation 2 November 30, 2012 05:29
unable to install openfoam 1.7 using apt-get maazhmd OpenFOAM Installation 7 July 24, 2011 11:18
OpenFOAM 1.6 and 1.7 with interFoam, groovyBC give different strange results Arnoldinho OpenFOAM 7 December 9, 2010 17:29
OpenFOAM 1.7 - openSUSE 11.3 - gcc 4.5.0 alberto OpenFOAM 12 July 28, 2010 11:59
Modified OpenFOAM Forum Structure and New Mailing-List pete Site News & Announcements 0 June 29, 2009 05:56


All times are GMT -4. The time now is 12:38.