CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > ANSYS > ANSYS Meshing & Geometry

[ICEM] Volume Meshing Problem; YOUR GEOMETRY HAS A HOLE

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   September 14, 2014, 05:41
Default Volume Meshing Problem; YOUR GEOMETRY HAS A HOLE
  #1
Member
 
Join Date: Jan 2010
Posts: 54
Rep Power: 13
mariachi is on a distinguished road
Hi Dear All,

I really appreciate the effort and time that people spend here helping each other, which makes cfd-online as the last resort whenever i get stuck up

My problem is to analyze the flow over an Aircraft. I'd like to mention all the steps in detail here:

1. First i make its model in CATIA.
2. I then save this as CATIA V4 file format i.e. .model in order to import it to ICEM.
3. After importing (no curves, points etc. but only surfaces), i then visually check all surfaces to make sure that everything appears as they did in CATIA. So far so good.
4. I run build topology to extract curves and points from these surfaces with a tolerance value of '0.2' and single edge tolerance value of '4'. I get all RED lines everywhere except for a few YELLOW ones which i repair manually. At the end, i still have 3 to 4 YELLOW lines which cant be repaired. I zoom in and find that some of these YELLOW lines are single whereas some are double(when magnified). i leave the single ones as it is and delete one from all double YELLOW curves which could not be repaired.
5. I now assign different max mesh size to all surfaces individually, depending upon their shapes and sizes, so that the geometry is adequately represented.
6. I set the global surface mesh method to All TRi Patch Independent.
7. I set global volume mesh method to ROBUST OCTREE. Here i also change the edge crierion from the default value to '0.01' because my geometry has some sharp edges, such as at the horizontal and vertical tail trailing edges.
8. In the global mesh parameters, i set Curv/Prox based refinement to 'ON' with a refinement value of '10' and Min size limit of '1' and elements in gap value of '2'.
9. I make the outer domain in the shape of a bullet.
10. I define material point 'ORFN' inside the Aircraft fuselage by selecting the centroid of two fuselage points. I also define material point 'FLUID' by selecting centroid of two domain points.
11. I hit compute volume mesh and wait for the mesh to generate. During meshing, i see a lot of errors appearing in the message window at the bottom but the mesher keeps on running.
12. After compute volume mesh, i get this message; YOUR GEOMETRY HAS A HOLE, DO YOU WANT TO REPAIR IT? When i try to repair, i see a lot of holes (in thousands) which even i tried to repair individual elements by using mesh editing tools available such as merge nodes etc but that is impractical as the holes are far too many to repair. (While repairing, i delete all volume elements so that im only left with the surface mesh)

Sorry for such a long post, but i wanted to mention all the tiny bits and details intentionally for troubleshooting purpose.

Now i have these questions:

1. What am i Doing wrong with this supposedly simple problem? Why i call it simple because, my geometry of Aircraft is as simplified as it could be and also the mesh which im trying to grow is the easiest for ICEM to grow.
2. I also tried growing surface mesh alone but when i do single edges check, i still get a lot of elements(in thousands). Why is this if all lines are RED during build topology?
3. Should i consider using another mesher? Although at this point in time, that will be a huge setback.
4. Should i consider importing geometry in some other format?
5. Should i consider using some other mesh method?
6. It says in the help section that ROBUST OCTREE can overlook holes even if there are some in the geometry. Well in my case its the opposite, as ICEM is making holes in mesh even at those places where i have all RED lines and the Geometry curvature also isnt too much.

(Almost 90% of the single edge elements appear wherever there are curves in my model. Yes, those curves which i extracted from build topology and which are all RED)

Thankyou Guys!

p.s. ive been reading and searching this forum for similar problems, and ive applied different approaches particularly mentioned by PSYMN in related posts...
mariachi is offline   Reply With Quote

Old   September 15, 2014, 11:30
Default
  #2
Member
 
Join Date: Jan 2010
Posts: 54
Rep Power: 13
mariachi is on a distinguished road
Quick help needed please
mariachi is offline   Reply With Quote

Old   September 15, 2014, 14:11
Default
  #3
Senior Member
 
Sebastian Engel
Join Date: Jun 2011
Location: Germany
Posts: 532
Rep Power: 17
bluebase will become famous soon enough
Can you post some screenshots of your problems?
bluebase is offline   Reply With Quote

Old   September 25, 2014, 16:02
Default
  #4
Member
 
Join Date: Jan 2010
Posts: 54
Rep Power: 13
mariachi is on a distinguished road
Hello everyone, and apologies to Sebastian Engel for my late response.

Actually my problem has been solved by importing the geometry in IGES file format, instead of CATIA V4 file format.

Anybody here could explain why?
mariachi is offline   Reply With Quote

Old   May 28, 2018, 05:00
Wink Holes repair
  #5
Member
 
MWRS
Join Date: Apr 2018
Posts: 98
Rep Power: 4
waseeqsiddiqui is on a distinguished road
DEAR FRIEND,
In regards to the "your geometry has holes" problem, it is always in myc experience concerned with the build topology tolerance of your geometry. Make sure your minimum size is at least 10 times greater than the value of tolerance in Build Topology.
Sometimes it can also be fixed by removing ORFN body.
waseeqsiddiqui is offline   Reply With Quote

Old   May 30, 2018, 03:52
Wink
  #6
New Member
 
saeed_karami, s_karami_mut_ac@dr.com
Join Date: Nov 2014
Location: Iran, Mazandaran City
Posts: 10
Rep Power: 8
saeed_karami is on a distinguished road
Quote:
Originally Posted by mariachi View Post
Quick help needed please
again build topology with tolerance value of '0.000002' and then repeat the other steps or in Build topology closed hole with toolbox
saeed_karami is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Volume meshing problem Tensian enGrid 1 January 23, 2014 18:06
Problem Importing Geometry ProE to CFX fatb0y CFX 3 January 14, 2012 20:42
Volume 1 has invalid topology for mapped brick meshing georgewar ANSYS 0 July 24, 2011 17:02
'Tetrahedral meshing has failed for volume...' Murat FLUENT 5 February 19, 2011 05:22
Meshing a hole geometry Aly FLUENT 0 January 5, 2006 09:59


All times are GMT -4. The time now is 10:35.