CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > ANSYS

Enclosure failed in SpaceClaim

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   May 13, 2018, 18:09
Default Enclosure failed in SpaceClaim [Problem solved]
  #1
Member
 
Marcello Asciolla
Join Date: Apr 2018
Location: Italy
Posts: 43
Rep Power: 3
MarcelloAsciolla is on a distinguished road
EDIT: problem solved, there was a little overlap between the 2 solids in the model.

I am trying to solve a problem of a fan in a duct, so I need the creation of a rotating domain and a steady one.
I created the rotating domain in a CAD environment, because the geometry is very complex. It is imported in SpaceClaim of ANSYS as a solid.

I need the evaluation of the field of motion inside and outside the duct, so I thought to solve the problem through the creation of an enclosure around:
-the geometry of the duct (let's call it "solid 1")
-the rotating domain inside the duct ("solid 2").

But everytime the creation of this domain fails with this message of error:
"An error occurred while creating the enclosure - the selected body could not be subtracted from the enclosure body"

I noticed that if I try to create the enclosure around only one of them (1 or 2) it works. I also noticed that if I put the rotating domain (the solid 2) out of the duct in a place very far from the solid 1 (the duct) the creation of the enclosure around both of them it also works.

Does anyone know why if I try to create the enclosure around the 2 solids (when the rotating domain is inside the duct) it fails?

I have to say that the geometry is very complex and the distance between the blade and the duct itself is very very little, so also the distance between the rotating domain and the duct is little. It is around 0,1mm.
And I thought that maybe this is the problem.

Are there any constraints on the minimum distance between solids for the creation of the enclosure in SpaceClaim?

How can I solve the problem?

Last edited by MarcelloAsciolla; May 14, 2018 at 17:49.
MarcelloAsciolla is offline   Reply With Quote

Reply

Tags
enclosure, solid, spaceclaim

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Foam::error::printStack(Foam::Ostream&) with simpleFoam -parallel U.Golling OpenFOAM 40 August 30, 2018 03:05
Initial conditions for uniform flow andreas OpenFOAM 5 November 16, 2012 16:00
[OpenFOAM] ParaView/Parafoam error when making animation Disco_Caine ParaView 6 September 28, 2010 10:54
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31
user defined function cfduser CFX 0 April 29, 2006 11:58


All times are GMT -4. The time now is 15:59.