CFD Online Logo CFD Online URL
Home > Forums > Software User Forums > ANSYS > CFX

Icemcfd: Preventing prism inflation collisions?

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Search this Thread Display Modes
Old   July 31, 2007, 09:08
Default Icemcfd: Preventing prism inflation collisions?
Posts: n/a

I have a geometry that varies widely in extent. I am trying to create a prism layer from one side of the geometry (A in pic). The basic idea is to set a large number of prism layers (e.g. 20) with the expectation that in the narrow portions of the geometry the prism columns will stop early due to collisions with the opposite wall ("Distorted tets" in pic). In regions of the geometry with a larger depth, the full 20-layer prism layer can be inflated without collisions.

In principle this approach works with the default prism settings, creating "stair steps" to transition between the varying number of inflation layers ("stair step" in pic). However, the problem is that the prism mesher is extremely aggressive in forcing tets out of the way as it inflates. This creates very poor quality tets "squashed" up against the opposite wall (B in pic). In my full geometry, which is very intricate and complex, this "squashing" results in very poor quality tets: Quality < 1e-4 even after extensive efforts at smoothing.

I have played extensively with all the prism mesher's options including the advanced prism settings to no avail. None of the available options lets me control the quality of the final "squished" tet layer.

The only workaround I have come up at the moment is to manually subdivide surface "A" and manually set the maximum number of prism layers inflated on each subdivision. In this way I can ensure the final prism layer is sufficiently far away from surface B. The problem is that in a complex geometry this is an extremely tedious and cumbersome process.

Does anyone know of any prism mesher tricks to achieve the following logic (in plain English): "If the current prism column front is within distance X of another non-inflating wall, stop this particular prism column" ? Ideally distance X would be some fraction of the surface mesh size on the non-inflating wall "B" e.g. 0.5-1.0.

Any tricks and/or suggestions on how to achieve this?

  Reply With Quote

Old   July 31, 2007, 09:13
Default Re: Icemcfd: Preventing prism inflation collisions
Posts: n/a
PS: These are the current prism settings I'm using:

Min prism quality 0.1 Ortho weight 0.0 Fillet ratio 1.0

(I have tried various combos of Max height over base and Prism height limit factor.)

(I have tried various combos of auto reduction, max size ratio, etc.)

  Reply With Quote


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting prism to inflate into mixed tet-hex meshes Joe CFX 16 October 10, 2011 07:06
Prism layer in ICEMCFD shankar1221989 ANSYS Meshing & Geometry 1 January 8, 2011 15:03
can any one tell how to do split prism in icemcfd ashish agrahari Main CFD Forum 0 December 6, 2010 08:40
problem coming during prism creation in icemcfd ashish agrahari ANSYS 7 August 11, 2010 15:51
ICEMCFD - Prism, Advanced Parameters Andreas CFX 0 January 16, 2009 11:02

All times are GMT -4. The time now is 22:55.