CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > General Forums > Main CFD Forum

Problem with Running OpenFOAM Parallel Case

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   January 4, 2021, 02:38
Default Problem with Running OpenFOAM Parallel Case
  #1
New Member
 
Homer Bacanto
Join Date: Dec 2020
Posts: 13
Rep Power: 5
hmrbcnt is on a distinguished road
Hey guys, I'm trying to run an OpenFOAM case in parallel, specifically in 56 cores/processors. When I try running the Allrun file, I get through everything just fine until I reach the solver. It solves for a couple of minutes until it terminates because I get the following error:



Code:
[amd64-TRX40-AORUS-PRO-WIFI:11125] *** An error occurred in MPI_Bsend
[amd64-TRX40-AORUS-PRO-WIFI:11125] *** reported by process [1304035329,1]
[amd64-TRX40-AORUS-PRO-WIFI:11125] *** on communicator MPI COMMUNICATOR 3 SPLIT FROM 0
[amd64-TRX40-AORUS-PRO-WIFI:11125] *** MPI_ERR_BUFFER: invalid buffer pointer
[amd64-TRX40-AORUS-PRO-WIFI:11125] *** MPI_ERRORS_ARE_FATAL (processes in this communicator will now abort,
[amd64-TRX40-AORUS-PRO-WIFI:11125] ***    and potentially your MPI job)
[amd64-TRX40-AORUS-PRO-WIFI:11112] PMIX ERROR: UNREACHABLE in file ../../../src/server/pmix_server.c at line 2193
[amd64-TRX40-AORUS-PRO-WIFI:11112] PMIX ERROR: UNREACHABLE in file ../../../src/server/pmix_server.c at line 2193
[amd64-TRX40-AORUS-PRO-WIFI:11112] 2 more processes have sent help message help-mpi-errors.txt / mpi_errors_are_fatal
[amd64-TRX40-AORUS-PRO-WIFI:11112] Set MCA parameter "orte_base_help_aggregate" to 0 to see all help / error messages
I'm not sure what I'm doing wrong, since I think mpi is properly installed because I can see the processor0-x folders being created.


If anyone can point me in the right direction, I'd be very grateful.
hmrbcnt is offline   Reply With Quote

Reply

Tags
blastfoam, mpirun error, openfoam

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[snappyHexMesh] Problem with boundaries with sHM in parallel running Loekatoni OpenFOAM Meshing & Mesh Conversion 0 January 24, 2019 08:56
Running OpenFOAM parallel with different OpenFoam directories? massive_turbulence OpenFOAM Running, Solving & CFD 0 November 19, 2018 16:08
Problem running movingCylinders case in parallel with foam-extend-3.1 mhkenergy OpenFOAM Running, Solving & CFD 5 March 3, 2017 06:20
running multiple parallel cases in openfoam slows the simulation kkpal OpenFOAM Running, Solving & CFD 2 August 21, 2015 12:08
Kubuntu uses dash breaks All scripts in tutorials platopus OpenFOAM Bugs 8 April 15, 2008 08:52


All times are GMT -4. The time now is 15:01.