CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

Python support when building Paraview ?

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By francois

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   June 16, 2014, 14:54
Default Python support when building Paraview ?
  #1
Senior Member
 
Francois Beaubert
Join Date: Mar 2009
Location: Lille, France
Posts: 147
Rep Power: 17
francois is on a distinguished road
Hi all,

I've just switched from Ubuntu 13.10 to 14.04, so I build OpenFOAM from source with the excellent wiki page.

http://openfoamwiki.net/index.php/In...M-2.3.0/Ubuntu

Everything seems OK in the compilation stage but it looks like Paraview was not build with Python support.

Did I miss something ?
Thank you very much.

François
francois is offline   Reply With Quote

Old   June 16, 2014, 15:00
Default
  #2
Senior Member
 
Francois Beaubert
Join Date: Mar 2009
Location: Lille, France
Posts: 147
Rep Power: 17
francois is on a distinguished road
Is it the withPYTHON flag in the makeParaView4 build script ?
francois is offline   Reply With Quote

Old   June 16, 2014, 15:37
Default
  #3
Senior Member
 
Francois Beaubert
Join Date: Mar 2009
Location: Lille, France
Posts: 147
Rep Power: 17
francois is on a distinguished road
I've used the following parameters in makeParaView4:

# Python support:
# note: script will try to determine the appropriate python library.
# If it fails, specify the path using the PYTHON_LIBRARY variable
withPYTHON=true
PYTHON_LIBRARY="/usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0"

and I've got a fresh Paraview with Python support

Cheers
Romarius likes this.
francois is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[General] Building Paraview 4.1.0 with MPI and Python support reynoldsStress ParaView 10 July 27, 2017 08:38
[foam-extend.org] Error compiling OpenFOAM-1.6-ext Canesin OpenFOAM Installation 137 January 20, 2016 14:56
[OpenFOAM] paraview v4 - building with python - OF2.3.0, PVv4, Python 2.7 aylalisa ParaView 4 June 13, 2014 08:52
How to get Python Shell into ParaView 3.8.1? blaise OpenFOAM Installation 3 July 24, 2012 04:58
Compilation error OF1.5-dev on Suse10.3 darenyang OpenFOAM Installation 0 April 29, 2009 04:55


All times are GMT -4. The time now is 07:35.