CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.com] compile v1806 on Ubuntu 1804?

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   July 8, 2018, 16:49
Default compile v1806 on Ubuntu 1804?
  #1
Senior Member
 
Pei-Ying Hsieh
Join Date: Mar 2009
Posts: 334
Rep Power: 18
phsieh2005 is on a distinguished road
Dear OpenFOAMers,


I just tried to compiled v1806 on ubuntu 18.04 LTS, but, immedicately got an error message as follows:

:~/OpenFOAM$ source ~/OpenFOAM/OpenFOAM-v1806/etc/bashrc


No completion added for /home/phsieh-plus/OpenFOAM/OpenFOAM-v1806/platforms/linux64GccDPInt32Opt/bin
... incorrect platform, or not yet compiled?
--------------------------------------------------------------


Has anyone seen this? Any suggestions?


Pei-Ying
phsieh2005 is offline   Reply With Quote

Old   July 10, 2018, 02:34
Default
  #2
Senior Member
 
matej forman
Join Date: Mar 2009
Location: Brno, Czech Republic
Posts: 182
Rep Power: 17
matejfor is on a distinguished road
Hi, do not worry. After you source the bashrc it checks for some compiled binaries. It does not find them, as you do not have them so it prints a warning saying ....not yet compiled?

To compile, you simply type:


>> foam
>> ./Allwmake -j -log

...to use all cores for compilation.

It is very important survival skill to read the error and warning messages and try to understand them, at least in OpenFOAM.
matejfor is offline   Reply With Quote

Old   July 12, 2018, 20:52
Default
  #3
Senior Member
 
Pei-Ying Hsieh
Join Date: Mar 2009
Posts: 334
Rep Power: 18
phsieh2005 is on a distinguished road
Thanks!


I have been using OpenFOAM since it became open source. Never seen this before.


Now, I have a new problem with compiling paraview.



Pei-Ying
phsieh2005 is offline   Reply With Quote

Old   July 13, 2018, 13:49
Default
  #4
Senior Member
 
matej forman
Join Date: Mar 2009
Location: Brno, Czech Republic
Posts: 182
Rep Power: 17
matejfor is on a distinguished road
Quote:
Originally Posted by phsieh2005 View Post
Thanks!


I have been using OpenFOAM since it became open source. Never seen this before.


Now, I have a new problem with compiling paraview.



Pei-Ying


Oh you have not mentioned any paraview related problem. the Allwmake script is updated to give meaningful warnings and error messages.

And paraview compilation is a story on its own especially when you are compiling it on distros which are updating libraries and cmake and others in a different pace.

Let me know if you need more help.

Mat
matejfor is offline   Reply With Quote

Old   July 14, 2018, 16:00
Smile
  #5
Senior Member
 
Pei-Ying Hsieh
Join Date: Mar 2009
Posts: 334
Rep Power: 18
phsieh2005 is on a distinguished road
HI, Mat,


Thanks!


OpenFOAM v1806 itself compiled successfully.


I noticed another thread discussing compiling ParaView. I will see if I can get ParaView to compile by following suggestions there.


Best regards,


Pei-Ying
phsieh2005 is offline   Reply With Quote

Old   July 24, 2018, 12:50
Default
  #6
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: https://olesenm.github.io/
Posts: 1,713
Rep Power: 40
olesen has a spectacular aura aboutolesen has a spectacular aura about
Quote:
Originally Posted by phsieh2005 View Post
Thanks!


I have been using OpenFOAM since it became open source. Never seen this before.
Yes, makes sense since the bash completions are reasonably new, but most convenient.
olesen is online now   Reply With Quote

Old   August 23, 2018, 12:38
Default
  #7
Senior Member
 
Daniel
Join Date: Mar 2013
Location: Noshahr, Iran
Posts: 348
Rep Power: 21
Daniel_Khazaei will become famous soon enough
Quote:
Originally Posted by phsieh2005 View Post
HI, Mat,


Thanks!


OpenFOAM v1806 itself compiled successfully.


I noticed another thread discussing compiling ParaView. I will see if I can get ParaView to compile by following suggestions there.


Best regards,


Pei-Ying

Hi,


I have compiled paraview v5.5.2 using cmake 3.12.1 and Qt 5.9.5 (pre-installed) on ubuntu 18.04...What is the problem you are facing?
Daniel_Khazaei is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu for W10: How to scroll up to see compile errors? msaravia OpenFOAM Programming & Development 2 August 9, 2018 20:15
[OpenFOAM.org] compile OpenFOAM v5 source on Ubuntu 1706? phsieh2005 OpenFOAM Installation 3 August 26, 2017 14:57
Cannot compile utilities in Ubuntu 12.04 skyinventorbt OpenFOAM Programming & Development 2 January 7, 2014 00:19
Compile problems on ubuntu 810 with gcc432 deepblue17 OpenFOAM Bugs 10 March 2, 2009 07:32
Can someone PLEASE document the development version installation bernd OpenFOAM Installation 76 November 14, 2008 21:51


All times are GMT -4. The time now is 14:34.