CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.com] Installing OpenFOAM 2.4.0 on Ubuntu 20.04 for Windows

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   August 26, 2020, 05:49
Default Installing OpenFOAM 2.4.0 on Ubuntu 20.04 for Windows
  #1
New Member
 
R Kyle
Join Date: Feb 2017
Location: Scotland
Posts: 11
Rep Power: 6
RKyle is on a distinguished road
Hi all,

I've been trying to install OpenFOAM 2.4.0 (a requirement for SOWFA, for those curious to why) using Ubuntu 20.04 LTS for Windows. There's a lot of good advice out there but some don't seem to work for this version unfortunately. I've been following the guidelines below by OpenFOAM.org, but first concerns are that it appears this version of Ubuntu hasn't been tested with OF yet - indeed, the guy who got OF 2.4.x installed did it with Ubuntu 14.04 (see Steps for SOWFA installation below). Next concern is that it looks like libqt is no longer there as I get an install message back saying eg "Package libqt4-dev is not available, but is referred to by another package". Appears that this is only for ParaView anyway so I tried going ahead. No issues with the "OpenFOAM Dependant packages for Ubuntu" apt-get install for OpenFOAM. After sourcing bashrc and kicking off the ./Allwmake, starts off promising but then looks like "/usr/bin/ld: cannot find..." starts to kick in and break the install. But looks like it might fail at Third Party first...

Does anyone have any advice on how to get the install to work? Build log attached, as well as my env and bashrc (as a .txt) file. Any and all help is much appreciated!

Attached Files
File Type: gz log.make.gz (138.1 KB, 3 views)
File Type: txt env.txt (5.8 KB, 1 views)
File Type: txt bashrc.txt (7.2 KB, 4 views)
RKyle is offline   Reply With Quote

Old   September 23, 2020, 14:20
Default
  #2
New Member
 
R Kyle
Join Date: Feb 2017
Location: Scotland
Posts: 11
Rep Power: 6
RKyle is on a distinguished road
This still has me stumped. Nobody out there has any idea? I would really appreciate the help!
RKyle is offline   Reply With Quote

Old   September 24, 2020, 06:32
Default
  #3
Senior Member
 
Join Date: Aug 2013
Posts: 404
Rep Power: 13
Antimony is on a distinguished road
Hi,

Have you tried switching to using all the tools from ThirdParty? My guess is that the newer OS versions have higher versions of the tools that might not be compatible.

From your log file, what seems to happen is that the libraries don't get compiled. Which means that this in turn will not allow you to compile your applications.

Maybe switch to lower versions/ThirdParty versions for everything and give it a shot?

Hope this helps.

Cheers,
Antimony
Antimony is offline   Reply With Quote

Old   October 2, 2020, 07:01
Default
  #4
New Member
 
R Kyle
Join Date: Feb 2017
Location: Scotland
Posts: 11
Rep Power: 6
RKyle is on a distinguished road
Thanks, Antimony! I'll give that a shot and see how I get on.
RKyle is offline   Reply With Quote

Old   October 2, 2020, 10:43
Default
  #5
New Member
 
R Kyle
Join Date: Feb 2017
Location: Scotland
Posts: 11
Rep Power: 6
RKyle is on a distinguished road
I can close this issue, it now appears that SOWFA works with OpenFOAM v6 so this could solve my issues. Thanks anyway!
RKyle is offline   Reply With Quote

Old   Yesterday, 11:45
Default
  #6
New Member
 
Jeffrey Johnston
Join Date: Oct 2020
Location: Belfast, Northern Ireland
Posts: 18
Rep Power: 3
NotDrJeff is on a distinguished road
Hello RKyle,

Sorry for reawakening an old thread, but could you confirm where you heard that SOWFA can run with OpenFOAM 6? I'm in a similar position as you were.

Thanks!
NotDrJeff is offline   Reply With Quote

Reply

Tags
installation, openfoam 2.4.0, sowfa, ubuntu 20.04

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.org] OpenFOAM 5 installation on Ubuntu 20.04 azamat OpenFOAM Installation 5 November 24, 2021 06:33
[OpenFOAM.com] openfoam v2006 wsl2 ubuntu 20.04 GLIBCXX_3.4.26 not found adisaurabh OpenFOAM Installation 1 July 7, 2020 03:12
OpenFOAM v3.0+ ?? SBusch OpenFOAM 22 December 26, 2016 15:24
[OpenFOAM.org] Problems installing OpenFOAM 2.3.0 on Ubuntu 12.04 arieljeds OpenFOAM Installation 6 August 19, 2015 08:39
Prolem installing OpenFOAM Ver 2.3.0 source in Ubuntu 13.1.0 on VMware zandi OpenFOAM Installation 5 March 31, 2014 04:57


All times are GMT -4. The time now is 23:50.