CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[foam-extend.org] Problem in installing foam-extend-4.1 on HPC

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   October 5, 2020, 03:59
Default Problem in installing foam-extend-4.1 on HPC
  #1
New Member
 
Arman N
Join Date: Mar 2019
Posts: 13
Rep Power: 5
Arman_N is on a distinguished road
Hello all,

I am trying to install foam-extend-4.1 on an HPC. The operating system is CentOS 6.10, with g++ version 4.9.4 2015.
I don't have the required permissions, so I asked them to compile foam-extend for me. However, it gives lots of errors and doesn't compile properly.

I have attached two output files which they gave me.
Most of the errors are of this form:
Code:
+ make install DESTDIR=/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/rpmBuild/BUILDROOT/mesquite-2.3.0-linux64GccDPInt32Opt.x86_64
libtool: install: warning: remember to run `libtool --finish /share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib'
Makefile:679: warning: overriding recipe for target 'all-recursive'
Makefile:376: warning: ignoring old recipe for target 'all-recursive'
Makefile:679: warning: overriding recipe for target 'all-recursive'
Makefile:376: warning: ignoring old recipe for target 'all-recursive'
Makefile:679: warning: overriding recipe for target 'all-recursive'
Makefile:376: warning: ignoring old recipe for target 'all-recursive'
libtool: install: warning: `../src/libmesquite.la' has not been installed in `/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib'
libtool: install: warning: `../src/libmesquite.la' has not been installed in `/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib'
libtool: install: warning: `../src/libmesquite.la' has not been installed in `/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib'
libtool: install: warning: `../src/libmesquite.la' has not been installed in `/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib'
+ echo ''
+ echo 'Generating foam-extend specific .csh and .sh files for the package mesquite-2.3.0'
+ echo ''
+ mkdir -p /share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/rpmBuild/BUILDROOT/mesquite-2.3.0-linux64GccDPInt32Opt.x86_64//share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/etc
+ cat
+ cat
+ mkdir -p /share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/rpmBuild/TGZS/x86_64
+ cd /share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/rpmBuild/BUILDROOT/mesquite-2.3.0-linux64GccDPInt32Opt.x86_64//share/apps/OpenFOAM/foam-extend-4.1/ThirdParty
+ tar -zcvf /share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/rpmBuild/TGZS/x86_64/mesquite-2.3.0.tgz packages/mesquite-2.3.0
+ /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
*******************************************************************************
*
* WARNING: 'check-rpaths' detected a broken RPATH and will cause 'rpmbuild'
*          to fail. To ignore these errors, you can set the '$QA_RPATHS'
*          environment variable which is a bitmask allowing the values
*          below. The current value of QA_RPATHS is 0x0000.
*
*    0x0001 ... standard RPATHs (e.g. /usr/lib); such RPATHs are a minor
*               issue but are introducing redundant searchpaths without
*               providing a benefit. They can also cause errors in multilib
*               environments.
*    0x0002 ... invalid RPATHs; these are RPATHs which are neither absolute
*               nor relative filenames and can therefore be a SECURITY risk
*    0x0004 ... insecure RPATHs; these are relative RPATHs which are a
*               SECURITY risk
*    0x0008 ... the special '$ORIGIN' RPATHs are appearing after other
*               RPATHs; this is just a minor issue but usually unwanted
*    0x0010 ... the RPATH is empty; there is no reason for such RPATHs
*               and they cause unneeded work while loading libraries
*    0x0020 ... an RPATH references '..' of an absolute path; this will break
*               the functionality when the path before '..' is a symlink
*          
*
* Examples:
* - to ignore standard and empty RPATHs, execute 'rpmbuild' like
*   $ QA_RPATHS=$[ 0x0001|0x0010 ] rpmbuild my-package.src.rpm
* - to check existing files, set $RPM_BUILD_ROOT and execute check-rpaths like
*   $ RPM_BUILD_ROOT=<top-dir> /usr/lib/rpm/check-rpaths
*  
*******************************************************************************
ERROR   0002: file '/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/bin/msqshape' contains an invalid rpath '/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib' in [/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib]
ERROR   0002: file '/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/bin/vtkrandom' contains an invalid rpath '/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib' in [/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib]
ERROR   0002: file '/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/bin/vtkxform' contains an invalid rpath '/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib' in [/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib]
ERROR   0002: file '/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/bin/msqquality' contains an invalid rpath '/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib' in [/share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/packages/mesquite-2.3.0/platforms/linux64GccDPInt32Opt/lib]
error: Bad exit status from /share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/rpmBuild/tmp/rpm-tmp.MnorPc (%install)
    Bad exit status from /share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/rpmBuild/tmp/rpm-tmp.MnorPc (%install)
error: open of /share/apps/OpenFOAM/foam-extend-4.1/ThirdParty/rpmBuild/RPMS/x86_64/mesquite-2.3.0-linux64GccDPInt32Opt.x86_64.rpm failed: No such file or directory
and:
Code:
+ wmakePrintBuild -check
+ /bin/rm -f 'foam/Make/linux64GccDPInt32Opt/global.?'
+ wmakeLnInclude foam
+ wmakeLnInclude meshTools
+ wmakeLnInclude OSspecific/POSIX
+ wmake libo OSspecific/POSIX
Making dependency list for source file signals/sigQuit.C
Making dependency list for source file signals/sigSegv.C
Making dependency list for source file regExp.C
Making dependency list for source file fileStat.C
Making dependency list for source file timer.C
Making dependency list for source file signals/sigFpe.C
Making dependency list for source file cpuTime/cpuTime.C
Making dependency list for source file signals/sigInt.C
Making dependency list for source file memInfo/memInfo.C
Making dependency list for source file POSIX.C
Making dependency list for source file clockTime/clockTime.C
Making dependency list for source file printStack.C
Making dependency list for source file fileMonitor.C
Making dependency list for source file multiThreader/multiThreader.C
cc1plus: error: unrecognized command line option "-std=c++11"
cc1plus: error: unrecognized command line option "-std=c++11"
cc1plus: error: unrecognized command line option "-std=c++11"
cc1plus: error: unrecognized command line option "-std=c++11"
cc1plus: error: unrecognized command line option "-std=c++11"
cc1plus: error: unrecognized command line option "-std=c++11"
cc1plus: error: unrecognized command line option "-std=c++11"
cc1plus: error: unrecognized command line option "-std=c++11"
cc1plus: error: unrecognized command line option "-std=c++11"
cc1plus: error: unrecognized command line option "-std=c++11"cc1plus: error: unrecognized command line option "-std=c++11"

make: *** [POSIX.dep:119: Make/linux64GccDPInt32Opt/POSIX.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [signals/sigInt.dep:137: Make/linux64GccDPInt32Opt/sigInt.o] Error 1
make: *** [memInfo/memInfo.dep:117: Make/linux64GccDPInt32Opt/memInfo.o] Error 1
make: *** [clockTime/clockTime.dep:27: Make/linux64GccDPInt32Opt/clockTime.o] Error 1
make: *** [signals/sigQuit.dep:137: Make/linux64GccDPInt32Opt/sigQuit.o] Error 1
make: *** [signals/sigSegv.dep:137: Make/linux64GccDPInt32Opt/sigSegv.o] Error 1
make: *** [regExp.dep:111: Make/linux64GccDPInt32Opt/regExp.o] Error 1
make: *** [fileStat.dep:116: Make/linux64GccDPInt32Opt/fileStat.o] Error 1
make: *** [signals/sigFpe.dep:139: Make/linux64GccDPInt32Opt/sigFpe.o] Error 1
make: *** [timer.dep:54: Make/linux64GccDPInt32Opt/timer.o] Error 1
make: *** [cpuTime/cpuTime.dep:7: Make/linux64GccDPInt32Opt/cpuTime.o] Error 1
cc1plus: error: unrecognized command line option "-std=c++11"
cc1plus: error: unrecognized command line option "-std=c++11"
make: *** [multiThreader/multiThreader.dep:122: Make/linux64GccDPInt32Opt/multiThreader.o] Error 1
cc1plus: error: unrecognized command line option "-std=c++11"
make: *** [printStack.dep:118: Make/linux64GccDPInt32Opt/printStack.o] Error 1
make: *** [fileMonitor.dep:156: Make/linux64GccDPInt32Opt/fileMonitor.o] Error 1
It seems that some files are not located where they are supposed to be; and there are some command line options that are unrecognized by the compiler.
However, this is the standard version of foam-extend-4.1 and I didn't change anything in it.

I honestly don't know much about this stuff and can't figure out what's going on. Any help on how to resolve this issue would be much appreciated. Really need to get this going.

Many thanks,
Arman
Attached Files
File Type: zip err.zip (68.1 KB, 1 views)
File Type: zip out.zip (183.1 KB, 1 views)
Arman_N is offline   Reply With Quote

Old   October 7, 2020, 06:12
Default
  #2
Senior Member
 
Join Date: Aug 2013
Posts: 407
Rep Power: 14
Antimony is on a distinguished road
Hi,

Looks like you have run into a gcc requirement issue. Here is what I found at openfoamwiki for foam-extend 4.1 install

Quote:
CentOS comes with the gcc toolchain 4.8.5, which is not compatible with foam-extend-4.1 (but is the correct one for foam-extend 4.0). Foam-extend-4.1 requires the gcc toolchain 7
Hope this helps.

Cheers,
Antimony
Antimony is offline   Reply With Quote

Old   October 13, 2020, 05:42
Default
  #3
New Member
 
Arman N
Join Date: Mar 2019
Posts: 13
Rep Power: 5
Arman_N is on a distinguished road
Dear Antimony,
Thank you for your reply.

I have already gave the link to the HPC host and they told me that devtoolset-8 was used for the compilation.
Anyway, I think that as you mentioned, foam-extend-4.1 may not be compatible with CentOS 6.10.

Therefore, I tried installing foam-extend-4.0. This time, the second type of error about "unrecognized command line option" did not occur.
However, the first error type still remains:
Code:
libtool: install: warning: `../../../ompi/libmpi.la' has not been installed in `/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/packages/openmpi-1.8.8/platforms/linux64GccDPOpt/lib'
libtool: install: warning: `../../../oshmem/liboshmem.la' has not been installed in `/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/packages/openmpi-1.8.8/platforms/linux64GccDPOpt/lib'
libtool: install: warning: `/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/rpmBuild/BUILD/openmpi-1.8.8/ompi/libmpi.la' has not been installed in `/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/packages/openmpi-1.8.8/platforms/linux64GccDPOpt/lib'
libtool: install: warning: `/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/rpmBuild/BUILD/openmpi-1.8.8/orte/libopen-rte.la' has not been installed in `/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/packages/openmpi-1.8.8/platforms/linux64GccDPOpt/lib'
libtool: install: warning: `../../../orte/libopen-rte.la' has not been installed in `/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/packages/openmpi-1.8.8/platforms/linux64GccDPOpt/lib'
libtool: install: warning: `/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/rpmBuild/BUILD/openmpi-1.8.8/opal/libopen-pal.la' has not been installed in `/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/packages/openmpi-1.8.8/platforms/linux64GccDPOpt/lib'
libtool: install: warning: `../../../opal/libopen-pal.la' has not been installed in `/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/packages/openmpi-1.8.8/platforms/linux64GccDPOpt/lib'
+ echo ''
+ echo 'Generating foam-extend specific .csh and .sh files for the package openmpi-1.8.8'
+ echo ''
+ mkdir -p /share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/rpmBuild/BUILDROOT/openmpi-1.8.8-linux64GccDPOpt.x86_64//share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/packages/openmpi-1.8.8/platforms/linux64GccDPOpt/etc
+ cat
+ cat
+ mkdir -p /share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/rpmBuild/TGZS/x86_64
+ cd /share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/rpmBuild/BUILDROOT/openmpi-1.8.8-linux64GccDPOpt.x86_64//share/apps/OpenFOAM/foam-extend-4.0/ThirdParty
+ tar -zcvf /share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/rpmBuild/TGZS/x86_64/openmpi-1.8.8.tgz packages/openmpi-1.8.8
+ /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
*******************************************************************************
*
* WARNING: 'check-rpaths' detected a broken RPATH and will cause 'rpmbuild'
*          to fail. To ignore these errors, you can set the '$QA_RPATHS'
*          environment variable which is a bitmask allowing the values
*          below. The current value of QA_RPATHS is 0x0000.
*
*    0x0001 ... standard RPATHs (e.g. /usr/lib); such RPATHs are a minor
*               issue but are introducing redundant searchpaths without
*               providing a benefit. They can also cause errors in multilib
*               environments.
*    0x0002 ... invalid RPATHs; these are RPATHs which are neither absolute
*               nor relative filenames and can therefore be a SECURITY risk
*    0x0004 ... insecure RPATHs; these are relative RPATHs which are a
*               SECURITY risk
*    0x0008 ... the special '$ORIGIN' RPATHs are appearing after other
*               RPATHs; this is just a minor issue but usually unwanted
*    0x0010 ... the RPATH is empty; there is no reason for such RPATHs
*               and they cause unneeded work while loading libraries
*    0x0020 ... an RPATH references '..' of an absolute path; this will break
*               the functionality when the path before '..' is a symlink
*          
*
* Examples:
* - to ignore standard and empty RPATHs, execute 'rpmbuild' like
*   $ QA_RPATHS=$[ 0x0001|0x0010 ] rpmbuild my-package.src.rpm
* - to check existing files, set $RPM_BUILD_ROOT and execute check-rpaths like
*   $ RPM_BUILD_ROOT=<top-dir> /usr/lib/rpm/check-rpaths
*  
*******************************************************************************
ERROR   0002: file '/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/packages/openmpi-1.8.8/platforms/linux64GccDPOpt/lib/libopen-rte.so.7.0.6' contains an invalid rpath '/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/packages/openmpi-1.8.8/platforms/linux64GccDPOpt/lib' in [/share/apps/OpenFOAM/foam-extend-4.0/ThirdParty/packages/openmpi-1.8.8/platforms/linux64GccDPOpt/lib]
The output files are attached below.

As far as I have understood, it is a problem with the system RPM checking RPATHs. I found in some forums (i.e. here and here) that removing the entry "/usr/lib/rpm/check-rpaths" from "~/.rpmmacros" file would solve the problem. But I could not locate such a file on the remote system.

I am not familiar with these settings and I don't know what to do.
I would appreciate if anyone could help me out on this.

Thanks
Attached Files
File Type: zip err.zip (17.8 KB, 1 views)
File Type: zip out.zip (137.2 KB, 1 views)
Arman_N is offline   Reply With Quote

Reply

Tags
centos, compilation error, foam-extend-4.1, installation issue

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Other] mesh airfoil NACA0012 anand_30 OpenFOAM Meshing & Mesh Conversion 13 March 7, 2022 18:22
Adapting a limitedScheme from foam extend 4.1 to Openfoam 1812 hbulus OpenFOAM Programming & Development 0 July 6, 2020 03:04
[foam-extend.org] A problem about installation of open foam extend 3.1 Toalchemist OpenFOAM Installation 1 May 31, 2018 09:58
is internalField(U) equivalent to zeroGradient? immortality OpenFOAM Running, Solving & CFD 7 March 29, 2013 02:27
problem about installing FOAM linux freshman Main CFD Forum 6 November 4, 2004 11:59


All times are GMT -4. The time now is 13:58.