CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Installation

[OpenFOAM.org] undefined reference when executing Allwmake

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 25, 2023, 10:54
Question undefined reference when executing Allwmake
  #1
New Member
 
Jasmine Feng
Join Date: Feb 2023
Posts: 12
Rep Power: 3
JasmineFeng is on a distinguished road
I want to install OpenFOAM-10 (org version) on CentOS-7 through compilation.

When I ran `./Allwmake` in the directory OpenFOAM-10, it seemed normal at the beginning but showed many 'undefined reference' after about 20 minutes, and exited compilation then. What does this mean? How could I fix it?

I collected the information log from the undefined reference and put it in the attachment.

Thanks in advance!
Attached Files
File Type: gz log.Allwmake.gz (19.3 KB, 1 views)
JasmineFeng is offline   Reply With Quote

Reply

Tags
installation by sources, undefined reference

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.org] Not found many .so files when installing OpenFOAM 6 lengjun OpenFOAM Installation 2 December 12, 2022 22:08
can not complie fluentDataToFoam in OF2.1.1 hewei OpenFOAM Pre-Processing 20 September 8, 2018 09:19
LiencubiclowRemodel nzy102 OpenFOAM Bugs 14 January 10, 2012 08:53
compile error about FJMPI chiven OpenFOAM Installation 11 March 31, 2010 06:27
OpenFOAM on MinGW crosscompiler hosted on Linux allenzhao OpenFOAM Installation 127 January 30, 2009 19:08


All times are GMT -4. The time now is 06:36.