CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

ParaFoam basic_string::_S_create error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 1, 2010, 12:53
Default ParaFoam basic_string::_S_create error
  #1
New Member
 
Patrick Begou
Join Date: Mar 2009
Location: Grenoble, France
Posts: 17
Rep Power: 9
begou is on a distinguished road
I've installed OpenFOAM from binaries:
  • OpenFOAM-1.6.General.gtgz
  • OpenFOAM-1.6.linux64GccDPOpt.gtgz
  • ThirdParty-1.6.General.gtgz
  • ThirdParty-1.6.linux64Gcc.gtgz

Unpacked these files in /home/OpenFOAM

run:
export FOAM_INST_DIR=/home/OpenFOAM/
. /home/OpenFOAM/OpenFOAM-1.6/etc/bashrc


then following the "2.1 Lid-driven cavity flow" tutorial
tut (because $FOAM_RUN/tutorials/incompressible/icoFoam/cavity does not exist)
cd incompressible/icoFoam/cavity
blockMesh
and then, to see the mesh:
paraFoam -case /home/OpenFOAM/OpenFOAM-1.6/tutorials/incompressible/icoFoam/cavity


I answer I want to open "OpenFOAM Files" and I get the error messages:
NVIDIA: could not open the device file /dev/nvidiactl (Permission non accordée).
NVIDIA: Direct rendering failed; attempting indirect rendering.
terminate called after throwing an instance of 'std::length_error'
what(): basic_string::_S_create
/home/OpenFOAM//OpenFOAM-1.6/bin/paraFoam: line 109: 22727 Abandon paraview --data="$caseFile"

and:
# ls -l /dev/nvidiactl
crw-rw---- 1 root video 195, 255 janv. 27 07:51 /dev/nvidiactl
# groups
turb visiteur cvsgroup stagiaire book postdoc trio triobin video


Any idea ?

Thanks

Patrick
begou is offline   Reply With Quote

Old   February 2, 2010, 03:44
Default
  #2
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 10
gwierink is on a distinguished road
Hi Patrick,

It probably happens because you need to build ParaView and (especially) the PV3FoamReader. The line
Code:
/home/OpenFOAM//OpenFOAM-1.6/bin/paraFoam: line 109: 22727 Abandon                 paraview --data="$caseFile"
shows that the shell has a problem with the paraview command. So, I would suggest to follow the README instructions to build Qt and ParaView (including the reader).
__________________
Regards, Gijs
gwierink is offline   Reply With Quote

Old   February 2, 2010, 03:52
Default
  #3
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 784
Rep Power: 19
olesen will become famous soon enough
Quote:
Originally Posted by begou View Post
terminate called after throwing an instance of 'std::length_error'
what(): basic_string::_S_create
This is a typical message that you get if you've loaded files with '.foam' and not '.OpenFOAM'. The '.foam' is the default OpenFOAM reader built into VTK and previous versions are buggy (the forum and paraview lists will also mention this). A newer version (from Takuya Oshima) is now in the ParaView CVS/git (eg, http://github.com/Kitware/ParaView) and shouldn't have this problem. The library-based reader included in OpenFOAM itself (uses the '.OpenFOAM' extension) is not know to have this problem.

Quote:
Originally Posted by begou View Post
NVIDIA: could not open the device file /dev/nvidiactl (Permission non accordée).
NVIDIA: Direct rendering failed; attempting indirect rendering.
...

# ls -l /dev/nvidiactl
crw-rw---- 1 root video 195, 255 janv. 27 07:51 /dev/nvidiactl
# groups
turb visiteur cvsgroup stagiaire book postdoc trio triobin video
This is a typical problem associated with the nvidia driver. You either need to add yourself to the video group (okay if your user is local and not NIS) or simply adjust the nvidia permissions accordingly (this is what we do).

  • look for the file /etc/modprobe.d/nvidia or /etc/modprobe.d/NN-nvidia.conf (depending on your installation and driver version).
  • let everyone with access to the workstation use the video driver (presumably the rest of your firewall is okay). Edit the file to have NVreg_DeviceFileMode=0666 permissions.
  • you can manually adjust the permissions chmod 666 /dev/nvidia* but you'll generally need to either reboot or use init 3 followed by init 5 to retain the changes. If you don't do this, the kernel module remains loaded and will continue to use the old permissions at the next xdm/kdm/gdm user login.

Finally, if you will be working with OpenFOAM, be sure to get the patches and fixes that are contained in the git repository: http://repo.or.cz/w/OpenFOAM-1.6.x.git
olesen is offline   Reply With Quote

Old   February 2, 2010, 04:36
Default
  #4
New Member
 
Patrick Begou
Join Date: Mar 2009
Location: Grenoble, France
Posts: 17
Rep Power: 9
begou is on a distinguished road
Thanks for your detailed answers. So you mean that the binary distribution of OpenFOAM 1.6 is not operational and that I have to rebuild the binaries from the last availables sources
My idea was just to use the PC for visualisations without the need to compile again OpenFOAM 1.6.x (I compile it on an Altix for the simulations and I'm not allowed to run graphic applications on it)


About nvidia, I have the group video (see the groups command). This is why the message is strange....

Lets go for a full OpenFOAM 1.6.x compilation now!

Patrick
begou is offline   Reply With Quote

Old   February 2, 2010, 05:31
Default
  #5
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 784
Rep Power: 19
olesen will become famous soon enough
Quote:
Originally Posted by begou View Post
Thanks for your detailed answers. So you mean that the binary distribution of OpenFOAM 1.6 is not operational and that I have to rebuild the binaries from the last availables sources
You only need the git version if you want a version with bugfixes in it.
You'll be the only one who can tell if the various bugfixes are important to you or not.
olesen is offline   Reply With Quote

Old   February 2, 2010, 12:41
Default
  #6
New Member
 
Patrick Begou
Join Date: Mar 2009
Location: Grenoble, France
Posts: 17
Rep Power: 9
begou is on a distinguished road
Problem solved.

I want to thanks all for your suggestions. The problem was with the binaries of OpenFOAM-1.6 & ThirdParty-1.6 not working on my computer
openSUSE 11.0 (X86-64) Linux 2.6.25.20-0.5-default #1 SMP.

I've ran
wcleanAll
./Allwmake
in the toplevel directory and after a couple of hours of compilation, all is working fine immediatly.
No need of any patch!

Thanks again
begou is offline   Reply With Quote

Old   February 7, 2010, 16:05
Default i don't see the mesh in Paraview
  #7
Member
 
angel
Join Date: May 2009
Location: Spain
Posts: 46
Rep Power: 9
anmartin is on a distinguished road
Hello to everybody
I've installed OpenFOAM from binaries:
  • OpenFOAM-1.6.General.gtgz
  • OpenFOAM-1.6.linux64GccDPOpt.gtgz
  • ThirdParty-1.6.General.gtgz
  • ThirdParty-1.6.linux64Gcc.gtgz
Unpacked these files in /home/OpenFOAM
I run the foamInstallationTest script with no critical error but one warning:
Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.3
User version :
Minimum required: 4.3.1

gcc ...OAM/ThirdParty-1.6/gcc-4.3.3/platforms/linux64/bin/gcc
gzip 1.3.12 /bin/gzip
tar 1.22 /bin/tar
icoFoam 1.6 .../OpenFOAM-1.6/applications/bin/linux64GccDPOpt/icoFoam
-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

Critical systems ok.

When i try to run the cavity tutorial, blockmesh works well but when i try to see the mesh with parafoam, paraview open a the cavity.foam (created temporary 'cavity.OpenFOAM') but i don't see the results.

I would be very grateful if someone can help me

Best regards
anmartin is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile problem ivanyao OpenFOAM Running, Solving & CFD 1 October 12, 2012 09:31
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
Compiling problems with hello worldC fw407 OpenFOAM Installation 21 January 6, 2008 18:38
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
user subroutine error CFDUSER CFX 2 December 9, 2006 07:31


All times are GMT -4. The time now is 15:25.