CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Pre-Processing

preservepatches for cyclicAMI

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   November 9, 2021, 08:47
Default
  #21
Member
 
Join Date: May 2017
Posts: 31
Rep Power: 7
sqek is on a distinguished road
Hello
Have you run topoSet since changing the actions in topoSetDict?
The names of the sets shouldn't cause an error, as long as they're the same in actions in topoSetDict as they are in singleProcessorFaceSets in decomposeParDict.
I'd suggest using the original names, as openFOAM sometimes automatically generates cellSets called region0, region1 etc, which would then get confused with the faceSets you're making
So put the original names in both topoSetDict and singleProcessorFaceSets,
then run topoSet (and look through the output - it should tell you the size of each set it makes, check that the number of faces in each is something reasonable)
If it's making too much output to easily read, run topoSet &>log.topoSet, then look at the log.topoSet file
then try decomposePar again
sqek is offline   Reply With Quote

Old   November 9, 2021, 09:44
Default works
  #22
Member
 
qutadah
Join Date: Jun 2021
Location: Germany
Posts: 91
Rep Power: 3
qutadah.r is on a distinguished road
So, thanks alot for the advices and hints! It finally works @sqek


here is how my files look like, for purposes of documentation for anyone who runs through this problem again


1- in topoSetDict i added:
Code:
actions
(
{
name INT_BLADE_1;
type faceSet;
action new;
source patchToFace;
sourceInfo
{
name "INT_BLADE_1-SIDE-1";
}
}

{
name INT_BLADE_1;
type faceSet;
action add;
source patchToFace;
sourceInfo
{
name "INT_BLADE_1-SIDE-2";
}
}
.
.
.
and so on for all my patches to gather them in sets like above....




2- in decomposeParDict i added:


Code:
constraints
{
singleProcessorFaceSets
{
        type singleProcessorFaceSets;
        singleProcessorFaceSets (
                (INT_BLADE_1 -1)
                (INT_BLADE_2 -1)
                (INT_BLADE_3 -1)
                (INT_BLADE_4 -1)
                (INT_BLADE_5 -1)
                (INT_BLADE_6 -1)
                (INT_IMP_VOL -1)
                (INT_SP_IMP -1)
                );
        enabled true;
    }
}
and then i ran topoSet and then decomposePar like said.


Thanks alot for your help!
qutadah.r is offline   Reply With Quote

Reply

Tags
cyclicami, preservepatches

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CyclicAMI BC preservePatches Parallel Run - again!?! hxaxtma OpenFOAM Pre-Processing 4 August 31, 2015 18:47
The preservePatches Option in decomposePar Hisham OpenFOAM Pre-Processing 4 November 19, 2012 18:45
Cyclic patches and parallel postprocessing problems askjak OpenFOAM Bugs 18 October 27, 2010 04:35


All times are GMT -4. The time now is 10:36.