CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Pre-Processing

decomposePar fails "Cannot find patchField entry for maxY"

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 31, 2017, 21:56
Default decomposePar fails "Cannot find patchField entry for maxY"
  #1
New Member
 
Jason Quinn
Join Date: Apr 2012
Posts: 2
Rep Power: 0
JasonQuinn is on a distinguished road
I've been having difficulty with a simple blockMesh and then decomposePar failing due to a "Cannot find patchField entry for maxY"

I would expect I've setup something wrong but I ran thus file before christmas on the same CFD Direct OF4.1 on AWS and it ran fine. Now I can run blockMesh but when I run decomposePar it fails.

I've loaded just the constant and 0 folders and the output to the below dropbox. I'd appreciate any ideas folks have.

https://www.dropbox.com/sh/cmrfvkzl8...JjGkQLYla?dl=0
JasonQuinn is offline   Reply With Quote

Old   April 2, 2017, 09:19
Default
  #2
Member
 
Join Date: Mar 2014
Posts: 39
Rep Power: 10
Traction is on a distinguished road
Hey,
there is a clear inconsistency between the patches you created within blockMesh and the patches you adress in your initial / boundary conditions. For example: you create a patch "maxY" in your blockMeshDict which is not present in your initial / boundary conditions.
Besides the structure of your blockMeshDict with the "patches" keyword looks very unfamiliar to me. This could be a source of additional problems so be sure to check the structure of blockMeshDict (for example from tutorials) and correct your blockMeshDict according to that - it should be consistent with the OF version you want to use.

No chance that this case ran fine in the past.
Traction is offline   Reply With Quote

Old   April 4, 2017, 02:07
Default Thanks for that. You are right the b.c.
  #3
New Member
 
Jason Quinn
Join Date: Apr 2012
Posts: 2
Rep Power: 0
JasonQuinn is on a distinguished road
The b.c. files do not line up with the patches. No idea how I made this error. This was working so I must've made a mistake and then archived it as I do have reasonable results from this model - obviously with different b.c. and initial condition files.

Thank you.
JasonQuinn is offline   Reply With Quote

Reply

Tags
decomposepar, patchfield

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1.5-dev: decomposePar pointDisplacement fails when a globalFaceZone is present matteoL OpenFOAM Bugs 9 May 5, 2013 06:09
OpenFOAM 1.6-ext git installation on Ubuntu 11.10 x64 Attesz OpenFOAM Installation 45 January 13, 2012 13:38
Converting Starccm+ mesh Ladnam OpenFOAM 0 September 14, 2011 07:30
Error "cannot find -lz" athlonshi OpenFOAM Installation 2 September 19, 2010 16:59
Errors running allwmake in OpenFOAM141dev with WM_COMPILE_OPTION%3ddebug unoder OpenFOAM Installation 11 January 30, 2008 21:30


All times are GMT -4. The time now is 15:54.