CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Running, Solving & CFD

Unexpected fail in mass conservation in ACMI case

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   December 12, 2015, 08:03
Default Unexpected fail in mass conservation in ACMI case
  #1
New Member
 
Albert
Join Date: Dec 2015
Posts: 1
Rep Power: 0
albertbuzafdz is on a distinguished road
Dear all,

I'm working on a case which consists in a mini-gear pump. The geometry is divided into two parts, the pump body (static part) and the gear profiles (moving part). I am currently still trying to perform some static simulations, but I have noticed a problem which I'm trying to solve. All the simulation seems to be running properly, but there's an unbalance between the phi at the inlet and outlet. I mean, is entering more fluid that is leaving the mechanism. Specifically, when these values are stabilized, the difference is around the 17%.
I've carried out the static simulation without the gear profiles (only the pump body) and everything runs o.k. The mass is conserved every time step (as is expected, I think). So, I've though that the error comes from the ACMI preparation. I've followed this like in the oscilatingInletACMI2D tutorial. Also, I've already tried several changes in my case in order to find where's the error such as changing tolerance values in fvSolution. But I'm not able to find what's happening with the loss of mass. I've checked the phi in the rest of patches and is 0, or almost 0 in the case of couple patches. But in any case the 17% phi difference. Has anyone find a similar situation working with the combination ACMI + rotative movement (pimpleDyMFoam) ? I've forgot to tell that I'm working with 2M cells more or less. I've also tried to increase the number of cells (7,5M) but the problem is remaining. So it's neither the origin of the problem. Has anyone any idea? Thank you very much in advance.

I've attached the boundary conditions files (0), and fvSchemes and fvSolution. OFVersion: 2.3.1

pointMotionU.txt

U.txt

p.txt

fvSchemes.txt

fvSolution.txt
albertbuzafdz is offline   Reply With Quote

Reply

Tags
acmi, failed mass conservation, mass conservation

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
DPMFoam - Serious Error --particle-laden flow in simple geometric config benz25 OpenFOAM Running, Solving & CFD 27 December 19, 2017 20:47
Mass conservation problem, Finite Element iahmedimtiaz System Analysis 0 September 19, 2015 20:09
Mass conservation law violation in stationary case vitmalin CFX 3 September 3, 2007 13:32
Free surface boudary conditions with SOLA-VOF Fan Main CFD Forum 10 September 9, 2006 12:24
Question on Sediment Mass Conservation Scheme Wen Long Main CFD Forum 0 July 6, 2004 15:45


All times are GMT -4. The time now is 04:38.