CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Running, Solving & CFD

Problem while installing the LEMOS-2.4.x

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   August 8, 2016, 02:43
Default Problem while installing the LEMOS-2.4.x
  #1
Member
 
Manjunath Reddy
Join Date: Jun 2013
Posts: 47
Rep Power: 12
manju819 is on a distinguished road
Hii Foamers,
I'm trying to install LEMOS-2.4.x for using the boundary condition inflowGenerator. While installing the LEMOS-2.4.x I'm getting the following error.

Code:
/usr/bin/ld: cannot find -lgsl
/usr/bin/ld: cannot find -lgslcblas
collect2: error: ld returned 1 exit status
make: *** [/home/manjunath/OpenFOAM/OpenFOAM-2.4.x/platforms/linux64GccDPOpt/lib/libLEMOS-2.4.x.so] Error 1
+ cd applications
+ wmake all solvers
make[1]: Entering directory `/home/manjunath/OpenFOAM/manjunath-2.4.x/src/LEMOS-2.4.x/applications/solvers/basic'
make[2]: Entering directory `/home/manjunath/OpenFOAM/manjunath-2.4.x/src/LEMOS-2.4.x/applications/solvers/basic/PODSolver'
Making dependency list for source file PODSolver.C
could not open file PODODE.H for source file PODSolver.C due to No such file or directory
could not open file ODESolver.H for source file PODSolver.C due to No such file or directory

And log file is also attached to the mail. Please help me to overcome this problem.


Thanks
Manjunath
Attached Files
File Type: txt lemos.txt (149.1 KB, 3 views)
manju819 is offline   Reply With Quote

Old   August 8, 2016, 05:38
Default Problem solved
  #2
Member
 
Manjunath Reddy
Join Date: Jun 2013
Posts: 47
Rep Power: 12
manju819 is on a distinguished road
Hi All,
After installing the additional library file libgsl0-dev problem has been solved. If someone gets the same problem it may help.

Thanks
Manjunath
manju819 is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[OpenFOAM.com] v3.0+ Problem compiling/installing in Ubuntu 16.04 LTS Azkono OpenFOAM Installation 6 June 23, 2016 00:35
[swak4Foam] foam-extend-3.2 installing problem: swak4Foam failed to install due to Bison lxwd OpenFOAM Community Contributions 1 March 20, 2016 16:03
Problem with installing OpenFOAM 2.0.X mohsen.boojari OpenFOAM Installation 3 February 3, 2016 11:41
Problem installing OpenFOAM-1.6-ext on Ubuntu 14.04 afrotimy OpenFOAM Installation 4 October 4, 2014 11:36
Problem in installing OpenFOAM-ParaView-0.1.1-1.x86_64 hassan5565 OpenFOAM Installation 1 August 5, 2014 13:05


All times are GMT -4. The time now is 13:52.