CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Running, Solving & CFD

interfoam parallel running exit code 145

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   July 25, 2019, 03:40
Default interfoam parallel running exit code 145
  #1
New Member
 
kindi jan
Join Date: Jul 2019
Posts: 2
Rep Power: 0
fatlem is on a distinguished road
Hello,


I have an issue running a simulation with interFoam solver (openfoam version 5.0.0).
My simulation is RANS k-w SST with VOF model of a free surface flow in channel managing a structure in it. and i am figuring out the velocity field around the structure and the head water.

After parallelizing my case, i run the solver, it takes about 1 or 2 days running and it gives me this error (i just copied the last part of the log file):


PIMPLE: iteration 1
smoothSolver: Solving for alpha.water, Initial residual = 4.097e-09, Final residual = 4.097e-09, No Iterations 0
Phase-1 volume fraction = 0.7029 Min(alpha.water) = -0.0002897 Max(alpha.water) = 1.007
MULES: Correcting alpha.water
Phase-1 volume fraction = 0.7029 Min(alpha.water) = -0.0002897 Max(alpha.water) = 1.007
GAMG: Solving for p_rgh, Initial residual = 0.2751, Final residual = 0.002164, No Iterations 13
time step continuity errors : sum local = 1.977e-10, global = 2.921e-12, cumulative = 4.478e-07
GAMG: Solving for p_rgh, Initial residual = 0.08213, Final residual = 7.147e-06, No Iterations 50
time step continuity errors : sum local = 1.634e-12, global = -3.544e-14, cumulative = 4.478e-07
smoothSolver: Solving for omega, Initial residual = 9.928e-07, Final residual = 9.928e-07, No Iterations 0
smoothSolver: Solving for k, Initial residual = 1.566e-06, Final residual = 3.268e-08, No Iterations 1
bounding k, min: 0 max: 1.439e+77 average: 4.407e+73
ExecutionTime = 7889 s ClockTime = 8363 s

surfaceFieldValue inletFlux write:
sum(inlet) of rhoPhi = -499.5

surfaceFieldValue outletFlux write:
sum(outlet) of rhoPhi = 0

surfaceFieldValue atmosphereFlux write:
sum(atmosphere) of rhoPhi = -7.511e+93

Courant Number mean: 1.834e-07 max: 8.948
Interface Courant Number mean: 1.22e-08 max: 2.914
deltaT = 1.279e-107
Time = 0.001915785357951

PIMPLE: iteration 1
smoothSolver: Solving for alpha.water, Initial residual = 4.094e-09, Final residual = 4.094e-09, No Iterations 0
Phase-1 volume fraction = 0.7029 Min(alpha.water) = -0.0002897 Max(alpha.water) = 1.007
MULES: Correcting alpha.water
Phase-1 volume fraction = 0.7029 Min(alpha.water) = -0.0002897 Max(alpha.water) = 1.007
-------------------------------------------------------
Primary job terminated normally, but 1 process returned
a non-zero exit code.. Per user-direction, the job has been aborted.
-------------------------------------------------------
--------------------------------------------------------------------------
mpirun detected that one or more processes exited with non-zero status, thus causing
the job to be terminated. The first process to do so was:

Process name: [[12165,1],3]
Exit code: 145
--------------------------------------------------------------------------

i tried to change the wall's conditions to wallfunctions and not y+=1 conditions but it does the same thing.
Can you help me figure out the problem? i didn't find the answer elsewhere. Thank you.
fatlem is offline   Reply With Quote

Old   July 25, 2019, 04:02
Default
  #2
Member
 
Rodrigo
Join Date: Mar 2010
Posts: 75
Rep Power: 12
guin is on a distinguished road
Something went wrong with the calculation already before the error. I suggest you to investigate further the reason for such big values for k:

Code:
bounding k, min: 0 max: 1.439e+77 average: 4.407e+73
guin is offline   Reply With Quote

Old   July 25, 2019, 04:04
Default
  #3
Member
 
Rodrigo
Join Date: Mar 2010
Posts: 75
Rep Power: 12
guin is on a distinguished road
Same with the fluxes. I guess it became unstable at once.

Code:
surfaceFieldValue atmosphereFlux write:
sum(atmosphere) of rhoPhi = -7.511e+93
guin is offline   Reply With Quote

Old   July 25, 2019, 04:05
Default
  #4
Member
 
Rodrigo
Join Date: Mar 2010
Posts: 75
Rep Power: 12
guin is on a distinguished road
...indeed, this is the probe of it


Code:
deltaT = 1.279e-107
guin is offline   Reply With Quote

Old   July 26, 2019, 03:44
Default
  #5
New Member
 
kindi jan
Join Date: Jul 2019
Posts: 2
Rep Power: 0
fatlem is on a distinguished road
Thank you for your answer.


k is calculated with the equation (k=1.5*(UI)) for the internalmesh and equal to zero at wall boudaries for y+=1 condition. i tried also with kwallfunction i gives me the same error.
fatlem is offline   Reply With Quote

Old   July 27, 2019, 07:48
Default
  #6
Member
 
Rodrigo
Join Date: Mar 2010
Posts: 75
Rep Power: 12
guin is on a distinguished road
Quote:
Originally Posted by fatlem View Post
Thank you for your answer.


k is calculated with the equation (k=1.5*(UI)) for the internalmesh and equal to zero at wall boudaries for y+=1 condition. i tried also with kwallfunction i gives me the same error.
...unfortunately I don't have any expertise regarding turbulence nor wall models, but don't worry, his forum is plenty of more experienced users!

PS: Disregarding of that, this information may be insufficient to give a diagnostic of your problem. I suggest you to upload your case, so that other users can more efficiently help you to fix the settings.
guin is offline   Reply With Quote

Reply

Tags
exit code, interfoam, parallel error

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[snappyHexMesh] Error while running SnappyHex in parallel mg.mithun OpenFOAM Meshing & Mesh Conversion 1 February 10, 2016 13:13
Parallel running of 3D multiphase turbulence model (unknown problem!!) MOHAMMAD67 OpenFOAM Running, Solving & CFD 7 November 23, 2015 10:53
OF 2.0.1 parallel running problems moser_r OpenFOAM Running, Solving & CFD 7 March 18, 2014 08:49
Issues running custom code in parallel BigBlueDart OpenFOAM Programming & Development 4 October 23, 2013 06:17
Something weird encountered when running OpenFOAM in parallel on multiple nodes xpqiu OpenFOAM Running, Solving & CFD 2 May 2, 2013 04:59


All times are GMT -4. The time now is 05:19.