CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Running, Solving & CFD

Particles lost in MPPICFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By GerhardHolzinger

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   June 16, 2021, 09:46
Default Particles lost in MPPICFoam
  #1
New Member
 
Join Date: May 2018
Location: Vienna, Austria
Posts: 10
Rep Power: 5
evamaria is on a distinguished road
Dear foamers,


I have encountered a strange behaviour with MPPICFoam. I set up a case, to fill a 2D column with lagranigan particles. When the cellValueSourceCorrection is set to off, particles suddenly vanish when the bed is packing.


The particles, are not escaping through a patch.



Does somebody know, how and why particles are removed / deleted?


I attached the two case setups - everything was run in OpenFOAM 8.
Attached Images
File Type: jpeg Parcels_sourceOff.jpeg (56.0 KB, 12 views)
File Type: jpeg Parcels_sourceOn.jpeg (53.1 KB, 10 views)
Attached Files
File Type: zip Column_sourceOn.zip (35.2 KB, 2 views)
File Type: zip Column_sourceOff.zip (35.3 KB, 3 views)
evamaria is offline   Reply With Quote

Old   June 16, 2021, 13:50
Default
  #2
Senior Member
 
Gerhard Holzinger
Join Date: Feb 2012
Location: Austria
Posts: 306
Rep Power: 24
GerhardHolzinger will become famous soon enoughGerhardHolzinger will become famous soon enough
Hi,

I have no idea what causes the particle loss, however, the particles are not lost when you change the interpolation scheme for velocity to cellPointWallModified. This scheme was removed by commit fbf0020, and reinstated by commit 63b641a.

Code:
    interpolationSchemes
    {
        rho.air         cell;
        U.air           cellPointWallModified;
        mu.air          cell;
        alpha.air       cell;
    }
Attached Images
File Type: jpg column.jpg (31.2 KB, 7 views)
File Type: jpeg Parcels.jpeg (52.9 KB, 4 views)
evamaria likes this.
GerhardHolzinger is offline   Reply With Quote

Old   June 17, 2021, 06:26
Default
  #3
New Member
 
Join Date: May 2018
Location: Vienna, Austria
Posts: 10
Rep Power: 5
evamaria is on a distinguished road
Hi,

thanks a lot!


Do you think this should be reported as a bug? In my opinion, it is clearly unwanted and unphysical behaviour.

I am wondering, if this also happens for other simulations, where you might not notice it that easily.
evamaria is offline   Reply With Quote

Reply

Tags
lagrangian, mppicfoam, packing limit

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
strange stuck particles on the rebound wall in MPPICFoam carye OpenFOAM Running, Solving & CFD 5 June 24, 2021 03:25
UDF in case with DPM modle POSTHU Fluent UDF and Scheme Programming 0 March 3, 2021 08:21
Particles lost in MPM model(macroscopic particle model)-ANSYS Fluent? shanferns12 FLUENT 0 February 24, 2019 10:48
MPPICFoam and particles visualisations MrJeff OpenFOAM Post-Processing 7 July 31, 2017 11:16
Lost .... new injected particles on last node_DPM Fluent Jourak FLUENT 9 December 13, 2016 11:56


All times are GMT -4. The time now is 21:50.