CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Running, Solving & CFD

Simulation Explodes when I add surface Layers

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   May 10, 2022, 20:15
Default Simulation Explodes when I add surface Layers
  #1
New Member
 
Felipe Griffiths Fonck
Join Date: May 2021
Posts: 5
Rep Power: 4
Phill_G is on a distinguished road
Hi, I'm trying to simulate a single wind turbine blade rotating in a wind tunnel, I have gotten it to work with using openFoam tools to mesh around an stl. and using a rotating mesh.

The general mesh is a big rectangle for the wind tunnel, a disk stl for the AMI that rotates, a blade stl that is located inside the disk stl for rotating.


Using a refinement level of 7 (standard square is 2m) around the blade, I have gotten results close but not yet acceptable to experimental, so I wanted to add layers to the blade to get into the y+ domain where the results would be closer. When I add the layers, if the refinement level is 8 it covers most of the blade stl, if its 7, it covers around 85% and doesn't form in the attack border of large parts of the blade, so I modified the mesh so the surrounding area of the blade was 8, followed by 7 in a bit larger area then before (using distance refinement)


This is the snappyhexmesh code I am using, snapping has been turned to false to see if it runs without it. currently that is the case, but will update my problem if it does not

snappyHexMeshDict.zip


The layers was added on 91.6% so in parts the mesh looks like this
20220510_125236.jpg


I will also add the schemes that worked on the mesh and the 0 file

files.zip


The last thing I tried was add more orthogonal corrector since the layers did bring the non orthogonality from around 49 to 52 max that resulted in a crash in more iterations
The crash and residuals log in the last attempt was this one

Screenshot from 2022-05-10 15-56-02.jpglog.zip


Any help would be appreciated, I have been struggling with this simulation.



I'm using pimple foam, kEpsilon and wall functions
Phill_G is offline   Reply With Quote

Old   May 11, 2022, 15:38
Default
  #2
Member
 
Join Date: Feb 2020
Posts: 79
Rep Power: 6
Fouch is on a distinguished road
Hi,

I had this problem with kEpsilon. May you can try with kOmega ?
Fouch is offline   Reply With Quote

Old   May 23, 2022, 14:44
Default
  #3
New Member
 
Felipe Griffiths Fonck
Join Date: May 2021
Posts: 5
Rep Power: 4
Phill_G is on a distinguished road
Quote:
Originally Posted by Fouch View Post
Hi,

I had this problem with kEpsilon. May you can try with kOmega ?
Currently trying it out and will post the results. It has not exploded yet, been running for a week
Phill_G is offline   Reply With Quote

Reply

Tags
ami, openfoam, pimplefoam, snappyhesmesh, wind turbine blade

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[snappyHexMesh] Surface layers do not merge mc6421 OpenFOAM Meshing & Mesh Conversion 3 December 5, 2023 03:00
Add layers on the whole surface Emanueledes OpenFOAM 10 December 19, 2017 14:40
[snappyHexMesh] How to add layers on the whole geometry surface meithid OpenFOAM Meshing & Mesh Conversion 1 January 24, 2017 05:41
[snappyHexMesh] SnappyHex add layers, is it adding hex's? Madeleine P. Vincent OpenFOAM Meshing & Mesh Conversion 1 July 18, 2016 09:05
interFoam simulation yields inconsistent results for alpha1 surface Ralinus OpenFOAM Running, Solving & CFD 8 January 13, 2014 08:54


All times are GMT -4. The time now is 16:35.